Lighter™ Suite 7.2

USER MANUAL

Marking Software

SOATALOGIC




Datalogic S.r.l.

Via S. Vitalino, 13

40012 Calderara di Reno (BO)
Italy

Tel. +39 051 3147011

Fax +39 051 3147205

© 2015-2020 Datalogic S.p.A. and /or its affiliates

All rights reserved. Without limiting the rights under copyright, no part of this documentation may be repro-
duced, stored in or introduced into a retrieval system, or transmitted in any form or by any means, or for any
purpose, without the express written permission of Datalogic S.p.A. and/or its affiliates.

Owners of Datalogic products are hereby granted a non-exclusive, revocable license to reproduce and
transmit this documentation for the purchaser's own internal business purposes. Purchaser shall not
remove or alter any proprietary notices, including copyright notices, contained in this documentation and
shall ensure that all notices appear on any reproductions of the documentation.

Electronic versions of this document may be downloaded from the Datalogic website (www.datalogic.com).
If you visit our website and would like to make comments or suggestions about this or other Datalogic pub-
lications, please let us know via the "Contact" page.

Disclaimer

Datalogic has taken reasonable measures to provide information in this manual that is complete and accu-
rate, however, Datalogic shall not be liable for technical or editorial errors or omissions contained herein,
nor for incidental or consequential damages resulting from the use of this material. Datalogic reserves the
right to change any specification at any time without prior notice.

Trademarks

Datalogic and the Datalogic logo are registered trademarks of Datalogic S.p.A. in many countries, including
the U.S.A. and the E.U.

Lighter Suite and MARVIS are trademarks of Datalogic S.p.A. and/or its affiliates. All other trademarks and
brands are property of their respective owners.

Ed: 02/2020
This manual refers to software version 7.2.1 and later



TABLE OF CONTENTS

PREFACE ....otciiiissssssssssrssssssssssssnmmsssssssssnsnssnsssssssssssssnnssssssnssnss snesssssnnnnns snenssssnnnnnnnsnssss IX
About this Manual .......cccccemmmiinissemnnimmsenmmssssss s ———————————. ix
MaNUAL CONVENLIONS ....vuvuvceiecisieeietssie ettt s st s s s s s bt es s en st ensnans iX
L =0 Uy T X
ADOUL this HEP SYSTEM: ..vueeecececcrceee ettt X
Using the Help System: ................
CoNtENtS O the HELP «...ouveececeeeceeeee et s s
Technical SUPPOIt ....cciiiiiissmnmiiisssmnnrnssssnnnnrrsssssnnnse s snnnae s ssann s be s s snannn e e s s nnnnn e e s s snnnneesnsnnnnns X
Support Through the WEDSIEE ...ttt X
CHAPTER 1. GETTING STARTED WITH LASER EDITOR......cccommmmmmsssssssssssssssssnsssnnnnnnnnns 1
About Laser EditOor .......ccccusesrusssmmssssmmssansssssnsssssnssssssnsmssnsmssssssnssasssssanssnsanssnssnssnssasssssansens 2
What's NEW iN LASEr EQILOr ....cuvuiereeirieieceeiseseiciseisee ettt sssssessssssssssssssssssens 2
New graphic editing features have been added, including but not limited to: ...
New advanced features have been added: ..o sseees 3
A fully programmable appUCAtION: .........c.eeieeereereereeeseieer et ses s 3
ActiveX interface (liCENSEA fEALUMNE) .....iviviiieeieeisee ettt s ses
Laser Editor's User Interface quick reference
WOTK ENVIFONMENT ..ooveeericeeie ettt sttt
Work environment components
Using toolbars tools ........ccuereeeeenen:
Vertical vs. horizontal toolbar ......
IS =000 = R Lo o] Lo OO
INSErt OBJECES tOOLDAI ......ivrceicte et
Evaluator toolbar
Objects OPeration tOOLDAN ..o
Adjust ObJECS tOOLDAN ......cereeeeeeeereeiet ettt

Zoom toolbar
Laser toolbar

LR (T o[ (oo} L OO
CHAPTER 2. PRELIMINARY OPERATIONS......ccttteemmmmmmmmssssssssssssssssssssssssssssnnnsnnnnnnnnnns 16
Registering your product ......cccseussssssssmssssssnssmssssssnsnsessssssnsssssssssnsnsssssssnnnsesssssnnnnnssssnnnnnss 17
Obtaining the UCENSE file ...ttt nnaes 17
TO register Laser EditOr: ...ttt s ss s sssssssnns 17

Sending the activation key to the remote device

TO SENA the lICENSE ..euveeeeeeeireeetreicee ettt 18
Installation types and connection Modes .....icceeerrsssssmmsmmsssssnssmssssnnssmssssnnsessssnnsnssssssnnnnsnss 19
Setting the default behavior of Laser Editor ........cccousssssssmmmsssssssmmsssssssssssssssnsssssssssnsnesssnss 20
Setting language, measurement unit and graphical effects (General page) .......ccocveererveereeneennnes 20
To set the GENEral PAraMELErS: ......vucucerreeecereeeseisese e seses st ssssessssssssanes 20
Setting documents parameters (GEOMELrY PAGE) ...vurrereerrrreeeeirsenieirsssesssssssessssssessssssesssssssesseens 21
To set the dOCUMENLS PArAMELES: ....c.cvcereceeereeeser et sssenses 21
Importing Materials Database ......ccocssresssssssnmemssssssssnmsssssnsssesssssnnnnssssssnnnsnsssssnnnsnssssssnnnnsnss 22
To import a materials database from SMartist: ... 22
Open Smartist Projects ....ccccsseessesssmmmmmmmmssssssssssnsnsnmsnnssssmesmmmsssssssssssnsnnnnssnnnssnsenssnssssssnnsans 23
To open a Smartist project 0r AOCUMENT: ....c.cvcueceeerrirereesissieeet e ssseesssessessssssesssnens 23
Automatic conversion Smartist Projects ......cccccccessrrmmmmsssssssssssnmnsmssssmsmmsssssssssssssnnnnnnnnsnnnnns 24

S$IOATALOGIC USER MANUAL iii



CONTENTS

Opening the data fOlders ......cusesrmmsmmmssmnmsssnnmsssnnssssenssssannssssmnenssannesssnsesssnsnsssnnsnssannnsssnneas 25
To VieW the fOlders CONTENTS: .....cvvcecriececeeeie sttt s s ssss bbb ss e 25

CHAPTER 3. CREATING GRAPHIC LAYOUTS.......cceemmmmmmmmmmmmmnnnnsssssssnssssssssnssssssssssssnss 26
Setting your work environment .......ccuusesssmmisssssmmmmssssmemmsssssnmm s ————————n, 27
Hiding/Displaying WindOWS OF t00IDAIS ........ceieeeceeieieieeieeiseseiseeseesee s 27
To hide/display @n LeMENT: ..ot 27
Docking/UNdOCKING PANES .......ceueremerreeeiseiseisesseiseieiesse s ssessesseessssssssss s sssssessssens 27
To dock/undock a pane: 27
Graphics editing OVErVIEW .....iccuusssssssssssssssnmsssnsmssssssssssnssssssssssnnssssasesssanssssansssssnnesssnnensnn
ADbOUt dOCUMENTS ..covuerrismnnsanrssmnsssnsssnssssnsssnsssansssnssssnsssassssnnasns sasnassassnsnsssasssnnsssassssnsnsanennns
CommMON dOCUMENES PIrOPEILIES ..ucvueercerresreseeeesessseseasesesessssssessssssss s sssss st st ssssns
Target properties for AOCUMENTS ......ccewereererrerrireeeeseeseee s ssssss s sssssssssssssssssssessessessessessnes
Laser properties for documents .................
Creating a document for plane engraving
Creating the document ........cccocevveereenene
TO Create the LAYEI: ...t et a b neas 33
To create the EXtended LAYer: ...t en e 34
Saving a Materials database for a later re-use
To save @ materials database: .........cccceerrrrrrrereee e 35
To re-open a previously saved database: ..o 35
Setting the work area
To set the focal length at the laser device level: ..o 36
To set the focal length at the document level: ... 36
Geometry properties - LaYer .......cceeeeeneseessensnennenns
Geometry properties - Extended layer
Creating a document for ring engraving .............
Creating the OCUMENT .....c.cuceeeeeeeeeeseiess et sess e sssesesssssssssssesssssssssssssssnssessessessessessssnsans
To Create the dOCUMENT: ..ottt 40
Geometry properties - Ring document
OpENiING EXIStING LAYOULS w.vuvvuveeeereceresssssseesseesessesssssesssssssssssssssssss s ssessessessssssssesssssssssssssssenssssnsans
Opening a layout on your PC ...................
Opening a layout from a device ...............
Saving layoULS ...c.eeveeereereerersereeeeeese s
Saving @ layouUt 0N YOUT PC ...t issssssesssssessssssssssssssssssssesssssessessessssssssssssssanes
T SAVE the LAYOUL: ..ttt b e e a bbbt A
Saving a layout to a device
To save the layout 10 @ AEVICE: ...ttt 45
ADOUL SEQUENCES ..ovcvreereseteeesesseessesssessess st ees sttt ettt
Creating and executing a sequence ........
To create a sequUENCE: ......cccecereeervencne
EXample: ..o
To execute a Sequence: ...
About graphic objects .....cuiisssssriissssnmmmmssssnnrressn s —————————————————————————
CoMMON ODJECES PrOPEIIES ..uvvuveieerercirereseeesseeess st sssesssesses s ssses s essesssssssesnssessesnssassesas
Geometry properties for ODJECLS ...t sssssesans
Custom Laser parameters for ODJECES ..o s sesssssesssssssssssens
Filling properties for ODJECES ......vircinereicisse st ssess st s s ssssssssssnens
Clone properties for ODJECES ..ot ss s sessss s ssssseas
Working with simple vectorial objects
Adding a shape
To add @ Shape: ......coeeririreeerere e
To add a circle or a rectangle, do one of the following:.....
To add a poly, do one of the following: .......ccccccveuruenee.
To add a Line, do one of the following:........cccccceerurunnne.
To operate 0N ShAPES: ........ccceerererereeererreeesereseseseseeaenes
Using Text Strings ......ccovveeeenen.
Adding @ TEXE StFING c.vveeeeeerrrrreeirereereesee e ssssesnens
Lo (6 I T3 (T OO 60
g oo Tl g To o] 3PS
To import fonts: ......ccccevreeeecnernneceneens
Using special character sequences .........
To create dates and times by using special character sequences: ........c.ccocvvevecenercenene 61

iv LIGHTER™ SUITE SOATALOGIC




CONTENTS

1] 0 0] o1 T T O TP 62
Making a text string to include an incremental counter .63
To use special character sequences to create a counter: ..........c.cuce.... .63
EXGMIPLE oot ...64
Editing a string as a pure Vectorial ObJECt .......ccovecirrcereireeere e 65
TO €dit the VECIOIS: ...ttt 65

WHhat i @ LGAtUr? .....eeeeeereece et 67

Using the Contour property to merge the Letters: ... 67
Text String Properties .......rerererseneereseeseseseseeneenes ...68

Using COES ...ovvererreeereeennerneneens .70

Usual Codes terminology .... w71

2 F Tl alo T LT3 g1 T OO 71

2] =TT A T =N = T J OO RR 71

Codewords

ELEBMIENT ...ttt ettt b ettt

GST1-128 StANAAIT ....cceeeeeeiicieieieiri et

Inter-character space

Linear bar code.................

Module .....ooveeierriririeene

Quiet Zone ...

Print ratio .....coeeveceveecnne

Stacked COde ......oovevevrerenecineeienine

Two-dimensional codes (2D codes)

ADOUL INEAI DAI COUBS ....vuvvririeircieiciree sttt neaes
Available linear bar codes in Laser Editor ...
Bar codes With tWo thiCKNESS .....coveeiriiirre e
Bar codes with multiple thickNeSss ...
Postal codes ......cccovrreneneneririneienenene

About stacked bar codes .....

Available stacked bar codes in Laser Editor ..............

About two-dimensional (2D) COURS ... st essesese et sesessse s ees e sesseses
Available 2D codes in Laser EItOr ... sesees

AXo o oo JE= N olo o /=TT

Setting the data restoring Capability ...

Setting the level of redundancy for 2D Codes ...

To set codes dimensions: ..........ccceeeveveecenen

Setting the error correction level .

To set the error correction LeVeL: ... 77

Balancing the black and White ratio ...t senaes 77
To balance the ratio: .......ccceunnee. .77

Codes properties ........ccoeune. ... 78

USIiNG AITaYs ...cvvveeeeereriseineressenens .93

Adding an array .94
To add an array: ......cccceeueee .94

Setting the NUMDET O CELIS ..uviiricircc s 95
To set the number of cells that compose an array: .........cccovreeeesernnneccererr e 95

Resizing arrays or cells .95
To resize the objects: .. 95

Changing the distance between cells 96
To change the distance between rows and/or COlUMNS: ........coevvevieerceeeeerrerer e 96
To change the distance between cells or groups of cells: .......cccecvvevernieccrvvcceeccrereeee, 96

Cells MISAlGNMENT .....cveececieece e e e .97
To change the alignment of cells: ..... .97

Selecting/Deselecting one or more cells .. .98
To select/deselect iNdividual CeLLS: ... 98

Creating the contents of INAIVIUAL CELLS .....vuvueueureeeereereeee e
To create the contents of acell: .......cccccueeee

Array and cells properties .......

Importing graphic objects ............
Supported file formats .....
Raster graphics vs. Vectorial graphiCs ...

GOATALOGIC USER MANUAL v



CONTENTS

F Y oL 1=y =T g =T o] ot SRR 104
About vectorial graphiCs ... . 104
Raster vs. Vectorial Marking ........ocoverererereeerererneseseseseseseseesessseneees . 104
Importing a file into Laser Editor ... ..105
Linking the imported file ........cooeiirnreeceeee e ..105
Setting the Filter Options (.DWG and .DXF fileS) ......cccvcverreureereereenernsennnns ..106
To set the filter 0ptioNS: ... .. 106
Using Advanced ProceSSiNg OPLIONS ......c..ceeereseesmessesnssssnssssssssssessssssessessssssssssssssssssessessens 107
Step 1 - Make the object vectorial and check nodes: .........ccccevveviececccecece e 107
Step 2 - Automatically edit vectors to correct imperfections: ........cccccceveeverererecrenenne. 108
EXamPLe Of USAQE ...voveveeiiirie ettt s ea s ... 108
Imported graphics PrOPEItIES .......c.cerieriereereeriereise e seeeese s see bbb esssssssenis 110
Using the tilING FUNCHION ...ttt bbb
Example of tiling usage
Understanding objects colour in the WOrk area ........cccuucesersssmsrsssmnsssemsmssnnsssssenssssnsssssanees 113
Using global variables ........ccccccceuicommisiesmnsssmnsmsmsssssssssssssssssssms s sssssssmssnsssnsssssnssnsanns 114
Purpose of the FUNCHIONALILY .....c.cvcueeeeciceeere et naas 114
Adding, viewing, or editing a global variable ... 115
To add a global variable: ... .
To view, edit, or delete an existing global variable: ... 116
Using special character sequences to associate global variables to a String ........ccceeereerveene. 117
To associate a global variable t0 @ StriNg: .....cccvreereereereeeereeeereneeseineinas w117
EXGMPLE ottt 117
Common operations 0N 0bJects ......uuirerrrussssssrmmssssssnssmsssssnsssssssssnnnsesssssnnnssssssnnnnssnnssnnnns 119
Using the dOCUMENL'S GFid .....ceevcueerieecireieessess st sssesssssss s ssssssssssssessssnsens 120
TO CUSLOMIZE the GFId: w.vueceeecicieeetret ettt en 120
Enabling/disabling objects ...
Lo [1SF= o] (ST o] 1Tt OO 120
Using the mouse to select and manipulate ObJECES ......ccvcevvreereiree s
What you can do with the MOUSE: .......cceeeuveerecirereeseseeese e
Selecting 0BJECH(S) vt

To select a single ObJECE: .....cocverueeeeeer e

To select multiple ODJECES: ....ovvceeeeieiercceere e
Moving, resizing, or locking OBJECLS ......vvevvevverrereireireeeereeeeeeeseessesessesseees

TO MOVE @N ODJECE: ettt st

TO reSize an ODJECE: .ovevivcece e

To lock/UNLOCK @N OBJECL: ... 122
Skewing and rotating objects

To rotate an object: .............. .

TO SKEW @N ODJECE: ..ueeieeieieiee ettt et e 122

o AT g T g o =3P 122

TO €It NOUES: ... .
Copying, pasting, cutting, or remMoViNG ODJECES ....vuvvererrerreeirrereeeireeseessesessssssssssssssssssssssssssssnens 123
To copy and Paste AN ODJECE: ...uvurureeereeirereeeeseersesessse s s s ssssssssessessessessessassenssssensans 123

To cut an object: ..o.eeeeeereenrens

To remove an object: ....
Aligning, flipping or spacing objects ...
To adjust graphiC ODJECES: ..vvreererrise et eneans
Grouping, merging, or joining objects
To use the grouping tools: ............... .
Editing ODJECS VECIOIS vuvvureueeecseestssisesssessesesssssssssssesssssssssssssssssssssssssssssesssssessesssssssssssssssssssssanes
About nodes and CONIOL POINES ...uvrererirerreeeeerrsseessessssses e sssssessssssessessssssssessessassssssssnsans
Making an object vectorial ..........

To make an object vectorial: ...
Starting nodes editing .................

To edit the nodes: ...

ZOOMING «.vertrirreeeesersersesseeessses s ses bbb bbb bbb bbbt

To zoom or reduce objects in the graphic area: ........cocovevereeneeeeeniennens
Specifying the filling PAtLEINS ...ttt 133

To set the filling ProPerties: ...t 133
Setting the origin of an object

To set the origin of @N OBJECE: ... e 134
Optimizing the objects Marking Order ...t enes 135

vi LIGHTER™ SUITE SOATALOGIC



CONTENTS

To optimize the 0bjects eNgraving Order: ... ssssessessessns 135
Calculating the Marking tiMe ......c.cceeenrrerererneeeeeessesese st sessesssssssssssssssssssssssssssnes 136
To calculate the MArking tIME: ... ssessessssesesesssssessesssssssssessssssssessessns 136
MATKING PIEVIEW wvuvuresvrreseseeseessessesssssssssssssssssssessessssssssassasssssssssssssssessessessessassasssssssssssssssnssessessessas 137
TO MAMK @ PrEVIEW: 1uvuevueescseseesssssessssssssssssssssssssssssssssesssssssssssssssssssssessessessessssssnssssssssnsssssnssns 137
CHAPTER 4. PERFORMING THE ENGRAVING OPERATION .......ccossssssssnnnnsnnnnnnnnnnnnnns 138
Setting custom laser parameters ......cccccrrissssesnnmmmnssessrr—————————————— 139
To set laser properties for all ODJECES: ....c.vvrerrrieirrsc s et anes 139
To set laser properties for individual 0DJECES: ... 139
UsSiNg MOre @NGraVviNg FUNS .....cceereeeeeneeeessesinssessssesssssssssssssssesssssssssssssssnsns ... 140
TO SEt MO PASSAPES: vrvrerrrerirerireressiressssesessssssessssssessssssessssssssssssssnes ... 140
Using the wobble function to engrave with thicker lines .........ccecovervrunee. w141
To enable the Wobble FUNCLION: ...ttt 141
Displaying the limits ....cccerusssssrmmsssssnssmmsssssssnmssssssnsneessssssssessssnnnsnssssssnnsessssssnsnsnssssnnnnness 143
TO display the lIMILS: ...t st ensesnsns 143
Simulating the marking operations .....ccccsusssssssrssssssssssmssssssnssessssssssnesssssnsnnsessssnnnssesssnnn 145
TO SIMULALE the BNGrAVING: vuveeeeeerreeeeerrieeeisssseesssssesessseesse s s ses s sssesssssssesssssssesssessessssesnssans 146
Connecting to the laser device .......cicrrrmissssnmmmmssssssnemmssssssrmmssssssssessssssssneessssnnnssessssnnnns 147
To set your Windows Firewall so as to enable remote connection: .........ccoeeeeeeverreeeensensneneenns 147
To cONNECt 10 the dBVICE: ....cuieiececireeeieeei e
SeNd MArKiNG wurceisssssmrmsssssnnnmmsssssnsnmesssssnsnmesssssnnmessssnsnnsesssannnnesssssnnnnsssssnnnneesssssnnnnessnsn 148
Auto Mode VS. ManNUAL MO ...t 148
AULO MOTE ..ottt bbb
WOTK MO .ottt
Manual mode -
To switch to Auto Mode if Manual mode has been activated: .........c.coceeeennrncccccnenenne 149
Sending the [ayout 10 MArKING ..o s 150
CHAPTER 5. LASER ENGINE USER INTERFACE ........ccossmsummmmmrmmssssnnnnsnssssssssnnsnnsnenss 151
Launching Laser ENQINe .....c.ccccussscsrmssmsmssmsessnsmssssnsmssnssssssmsenssnsssssnnsessasssnssnsenssnsssnsanees
User interface OVEIrVIEW .......ccccuiececccssssmsssmsmssassmssssssssssssssssmsenssnsssassmsessansssssmnssssnsssnsnnes
Main WINAOW ELEMENLS .....ceuiurierireeeiieieeeseiseiset it ss bbbt
MENU DULLONS ...ceovrtreeieee ettt st bbb
Shortcut MENU COMMEANGS ...ouvuiereereeeieeseeseeseisetsee et bbbttt bbbt
Managing users and access rights
To enable the users management and to set the access rights: .......ccoerererenenenenieneensneiees 157
Disabling USErs’ aCCESS CONEIOL .....uvueueeieeeeireieireise i esse ettt
To disable the access control for a type of user or for all users: .
To re-assign the access to a function for a type of USer: ..o 159
Switching between working modes 160
Local/RemOte CONEIOL ....eueueeeeeeeieieeee et 160
Local control ........ ...160
Remote control 160
To set the Remote mode as the default working Mmode: ........ccoeevvvenerveserneireeseeseesesessenes 161
Auto/Manual Working MOGE .......c.weiereuueeeeeeeiseeseesseise s ss s
To set the Auto mode as the default working mode: ........cccvvveeverieennes
Disenabling the Winsat Task ....cccuusssrmssssssssmmsssssssssssssssnssnsssssssnnsnssssssnsssssssssnsnsessssnnnnnnss
Configuring the laser parameters
To access the Laser configuration WiNAOW: ..........ccvcurceeeeisesesnsessssssssssssssssssssssssessesssssessnes 165
Setting the GENEral PArAMELENS .......ccvvcecurieereeseeesesee st esses st ensesssassnsans
Setting the head Scanner parameters .
Calculating Waiting tiMES ......cuveeeeirrieeeeseisseese st sss st essesanes
TFIFSEIHS] ivvviueueesinsiresessisessse sttt
TNext [ps] ......
TLaSt [US] cvvvererrrereirerirnens
TDraw (Diode Laser) [ps] .....
TJIUMP (DI0de LASEN) [HS] cvuvvveeeerreeeerrissessssssssesssssssessssssssssssssssssssssessssssssssssssssssssssssssssssssseens
Setting the Laser PAramELers ......ccccecreerseeessssesssssessssssssssesssssssesssssssessssssssssssessessssesssssssans

w175
176

Configuring the Field Orientation ....
Setting the Correction parameters

SIATALOGIC USER MANUAL vii



CONTENTS

Setting the AIMING PArAMELETS ....c.cvevereerrerereirsireesesseeessessessssssssss st sssssssssssssessessessessesssssesssssnsans
Setting INPUL/OULPUL PATAMELETS .....ouvereereerieseeeeeseeseeeese st
Setting the X, Y, Z, and Rotor AXeS Parameters ........ueeerermeseeessnsssssmssssssssssssssssssssessessessessas
Configuring the Marking on the Fly fUNCLION .....ceveceeenrnecssseesesese s ssssssssesssseens
When USING @N ENCOUET ....uvuevereeerisriseieiseeseeseesesssssssssssssssssssssessssesssssessessssssssessssssssssssessnssns
When using the Continuous marking mode .
Setting the configuration PAraMELErS ... ssessesssssessans
USING the WIZAT ..ot ssss st esssssesssssssssssssssssssssssssssssessessssanes
Parameters description ........
Setting the Network parameters
MARVIS™ configuration .............. .
Distance SeNSOr CONIGUIAtION .....vucureeucesreeeseesesssssessssssssssesessesessessesssssesssssssssssssssssssssessesssssssanes
SBIVICE outtueutseeseeserseesses e st es bbb
Managing axis and executing the laser test
Mechanical axis management

Axes reference ..o .
LINEAI VS. FOLAIY @XIS .viueerescireissiresise sttt
Using the X-Y or Rotor Axis tabs for axis management .........coeeueermenernnenmersensseseseeseesessenes 194
TO MANAGE AXES: wouveererirrereirreriseie e .
Using the Z Axis tab for axis management and [aser teSt .........cuvmemrnrnenrnnersesssseessesesssssnssnees 195
MaNAGING the Z AXIS .uvueveeerrerrersirseseeessesessessssssssssssssssssssssssessessessasssssssssssssssssssssessessesssssessans 195
Executing the laser test for focus ... .. 196
TO €XECULE the tEST: ..o 196
Executing the Autofocus Search (if available) .......ccccovveerveriineninenenies 196
Set the fOCUS POSITION: ....cccveveeeeiieeeie e ...196
To execute the AULOFOCUS SEAICN........cccviiiieeeeeire e 196
Correcting LeNS diSTOIION ........irceceierrireireee ettt

Sending documents to marking ...
Viewing the Device Status ...
Statistics .o .
TrOUDLESNOOLING .vuvecerierieeereteise ittt bbb bbb bbbt
Errors and Event Tracing GUI
Errors Tab

EVENt Tracing Tab ..ottt et

TESHING the SYSTEM ....vueeececectree ettt en s ns st senans
To test the system's connections: ..

To test the Laser: ......coovereeneereeneen.

To test the inputs: .....

TO tESt the OULPULS: w.vuvveeeeecicreect sttt nsees 205
Photometric AJUSTMENT ......vvvececieeeetreeesere st s st sessnsanans 206
Quality Grade TraiNiNG .....ceceerereererseeeseeesessssssesssssssssssssssssssssssssssssssesssssssesssssssssssssssesssssssesssssnsens 208

viii LIGHTER™ SUITE

SOATALOGIC



PREFACE

ABOUT THIS MANUAL

This User Manual (UM) is provided to users for learn how the use of the marking soft-
ware. Other publications associated with this product can be downloaded free of charge
from the website listed on the back cover of this manual.

Manual Conventions

The symbols listed below are used in this manual to notify the reader of key issues or
procedures that must be observed when using the laser marker:

Notes contain information necessary for properly diagnosing,
repairing and operating the laser marker.

NOTE

The CAUTION symbol advises you of actions that could damage equipment
or property.

>

CAUTION

The WARNING symbol advises you of actions that could result in harm or
injury to the person performing the task.

WARNING
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PREFACE

WELCOME

About this Help system:

This Help System is designed for users who will be using Laser Editor to create graphics
layouts for laser engraving operations.

Using the Help System:

You might access the whole contents by choosing Help > Help from the Laser Editor's
menu bar, or pressing F1 in the main screen of the application.

Furthermore, you can take advantage of the context-sensitive Help, that is, you can dis-
play a Help topic based on what you are doing:

Pressing F1 (or the ? button in a window's title bar) opens dialog or window level Help;

clicking a properties title in the Properties window (such as, for example, Geometry)
when working on a document or a graphic object, then pressing F1, opens a table with a
description of those properties.

Contents of the Help

The Help is organized into the following main topics:

Chapter Contents
"GETTING STARTED WITH LASER EDITOR" |Presents an overview of the product in terms
on page 1 of scope, architecture, and User Interface.

Describes how to register Laser Editor as
"PRELIMINARY OPERATIONS" on page 16  |well as how to set the default parameters for
the application.

Describes how to create a graphic layout by
"CREATING GRAPHIC LAYOUTS" on page 26 |adding objects to a plane or ring document,
and how to operate on objects.

Provides instructions on how to test your
graphic layout and how to complete the laser
engraving operation

"LASER ENGINE USER INTERFACE" on page |Describes how to use the Laser Engine user
151 interface.

"PERFORMING THE ENGRAVING OPERA-
TION" on page 138

TECHNICAL SUPPORT

Support Through the Website

Datalogic provides several services as well as technical support through its website. Log
on to (www.datalogic.com).

For quick access, from the home page click on the search icon O\, and type in the name of
the product you’re looking for. This allows you access to download Data Sheets, Manu-
als, Software & Utilities, and Drawings.

Hover over the Support & Service menu for access to Services and Technical Support.

X LIGHTER™ SUITE
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CHAPTER 1

GETTING STARTED WITH LASER
EDITOR

This chapter is organized into the following sections:

Topic
"About Laser Editor" on page 2
"Laser Editor's User Interface quick reference" on page 4

GOATALOGIC USER MANUAL 1



GETTING STARTED WITH LASER EDITOR

ABOUT LASER EDITOR

Laser Editor is the ultimate laser marking software suite that allows users to easily mark,
etch, or engrave product identification information such as 2D matrix codes, linear bar-
codes, postal codes, stacked bar codes, text including any industry standard font for-
mats, alpha-numeric serial numbers, date codes, part numbers, graphics and logos in
any production environment.

Laser Editor represents an evolution of the development undertaken with the previous
program Smartist.
Laser Editor is a complete laser marking system that can be used for:
e graphic layouts editing
e laser devices fine-tuning and control, including an integrated 1/0 module for axis
management that allows integration into a production line or other marking
equipment
e fully customization by creating automated procedures
e easy integration into assembly lines with or without PC

What's new in Laser Editor

Laser Editor has a new smart and intuitive graphic interface which has been localized
into several languages. A context-sensitive help system guides you through the proce-
dures for creating and marking your layouts.

Furthermore, new powerful and flexible features have been added.

New graphic editing features have been added, including but not lim-

ited to:

e improved vectors editing capabilities

e advanced vectorial processing features for automated editing of nodes

e new import filters

e advanced filling patterns are supported

e acomplete “Array” feature specially designed for Integrated Circuits (IC) marking
e interactive marking time evaluation function

e marking order optimization feature

e mark preview capability (implemented at scripting editor level too)

e undo/redo capabilities

(For further information, see "CREATING GRAPHIC LAYOUTS" on page 26).

2 LIGHTER™ SUITE
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ABOUT LASER EDITOR

New advanced features have been added:

e 4 axis motor control for rotary indexers, Z axis, Rotor axis, X-Y tables, and so forth
e Built-in I/O module for external equipment control

e “On the fly” marking capabilities with a configuration wizard

e Remote control of the marking process over Ethernet

e User control and password management

A fully programmable application:

Project Editor, a new powerful programs editor, has been added. You can create your
own programs and automation tools:

e update the layout contents at runtime

¢ load and mark documents

e collect data from external sources or database systems
e build a custom user interface

e use advanced debugging functions

e and much more

Project Editor is supplied with source files samples, reference material, and a context-
sensitive Help system.

ActiveX interface (licensed feature)

ActiveX interface has been added to Laser Engine. This provides users that are familiar
with Smartist ActiveX programming a similar way to easily write custom graphic inter-
face on top of Laser Engine without dealing with the details of low level laser con-
trolling.

Plugins are not available when using ActiveX. For more details, please
refer to the Project Editor online documentation, chapter “Language refer-

ence”.
NOTE

Related topics:

"Laser Editor's User Interface quick reference” on page 4
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GETTING STARTED WITH LASER EDITOR

LASER EDITOR'S USER INTERFACE QUICK REFERENCE

This section provides an overview of the Laser Editor User Interface to be used as a
quick reference, and in particular:

e "Work environment" on page 4 - How the Laser Editor's environment is organized
e "Using toolbars tools" on page 6- A quick overview of the available toolbars buttons

Work environment

The picture below shows the main window of Laser Editor when you access it:

©)

NHe Edt Vew Adkes L Resder Window M

iBALE S Rl Sl oMo 25 XX | 7 LB
TEo@onaysi 2 8
ax

) T ) 1 i

| @
‘

o\
@ P ——

Work environment components

For a more detailed description of how to display, hide, or dock the compo-
nents of the work environment of Laser Editor, please refer to "Setting your

work environment" on page 27.
NOTE

Area Description

Menu bar with all the Laser Editor commands.

Toolbars with the tools that allow you to:

« draw and manage the engraving layout (see "Using toolbars tools" on page
6)

« manage user rights on the system functions (see "Managing users and
access rights" on page 157)

You can display a toolbar by selecting the corresponding button in the vertical
Select toolbar. Furthermore, you can hide/display toolbars by right-clicking a
blank area in the upper part of the window.

Select toolbar - The vertical toolbar allows switching between toolbars. Each
buttons activates a subset of horizontal toolbar buttons.

@ « interact with the laser device (see "Laser toolbar" on page 13)

You can hide/display this toolbar by right-clicking a blank area in the toolbars
area.
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LASER EDITOR'S USER INTERFACE QUICK REFERENCE

Undo/redo command list - It lists all the actions that you have performed during
layout editing, It allows keeping track of all actions, and undoing or redoing any of
these actions. To undo/redo an action, select it, then do one of the following:

o clickthe < £ buttons on the toolbar

« choose Edit > Undo (or Redo) from the menu bar

The Undo/redo window can float over the work area, or you can dock it at the left-
side of the window, just below the toolbars, by double-clicking its title bar. Fur-
thermore, you can hide/display this window by right-clicking a blank area in the
toolbars area.

Objects engraving order - It shows the order in which the objects that were
added to the document will be engraved. To change the marking order, drag the
objects to the desired position. To optimize the marking order, you can use the
2 Marking order function that is made available after clicking the &) Adjust
Objects button on the vertical toolbar.

This window can float over the work area, or you can dock it at the left-side of the
window, just below the toolbars, by double-clicking its title bar. Furthermore, you
can hide/display this window by right-clicking a blank area in the toolbars area.

Work area - The graphic work area where the engraving layout or the sequence
will be represented. When you select File > New plane (or ring) document, the
document is displayed in this area. You might work on more documents at the
same time; in this case, at the top of the work area, the documents tabs will be

displayed | pocumentt* | Deamentz | to allow you to switch between docu-

ments. To close an individual document, click the [E button at the top-right of
the area.

Attention: The maximum width of the work area is defined by the focus length
set in Laser Configuration. (See "Setting the work area" on page 36)

Properties browser - It tells you information (that is, settings) about any
selected object in the work area. Documents are treated as objects in Laser Edi-
tor; so, if no object is selected, the document's properties are displayed. The
Property browser can float over the work area, or you can dock it at the right-side
of the window, just below the toolbars, by double-clicking its title bar. Further-
more, you can hide/display this window by right-clicking a blank area in the tool-
bars area.

The property browser supports context-sensitive Help: Clicking a properties title
(e.g., Geometry) and then pressing F1, opens a table with a description of those
properties.

Status bar -It shows name and status of the connected laser device. Further-
more, when the mouse pointer rests on a toolbar button, a brief descriptions of
the button is displayed in this area.

SOATALOGIC
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GETTING STARTED WITH LASER EDITOR

Using toolbars

tools

In this section:

"Vertical vs. horizontal toolbar" on page 6
"Standard toolbar" on page 7

"Insert Objects toolbar" on page 8
"Evaluator toolbar" on page 9

"Objects Operation toolbar" on page 10
"Adjust Objects toolbar" on page 11
"Zoom toolbar" on page 12

"Laser toolbar" on page 13

"Reader toolbar" on page 15

Vertical vs. horizontal toolbar

Laser Editor has a vertical toolbar (the select toolbar) and a horizontal toolbar.

The horizontal toolbar contains a standard set of buttons (the main toolbar) plus a vari-
able set of buttons; this set changes depending on the button that you click on the ver-

tical

toolbar.

In the example below, the Zoom toolbar has been displayed after pressing the Zoom
button on the vertical toolbar:

™ File Edit View Actions Laser Reader Window Help

d s Bl @ PN (LS Ol Do, 2 E XXy e
|}

d ﬂ 1 Q 1 1 ¥ Photometric Adjustment  Quality Grade Training
0 Undo/redo nds list 5 X Document1*® l Document2* Document3 Document4 Document5

<empty>

The following tables briefly describes the function of each toolbar buttons. Follow the
link in the table to display the Help topic with more function details.

U Buttons are available or unavailable depending on the operation you are

NOTE

performing.

Toolbars can also be hidden/displayed by right-clicking on a blank area in
the toolbars area and then deselecting/selecting the items from the short-
cut menu.
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Standard toolbar
This toolbar is always displayed:

Button |Description
Layer - It allows opening a new document in the work area, either Layer,
Extended Layer, Ring Document or Sequence. Click the button to open a new
Plane Document opens; click the down arrow. To display the dropdown list that
allows you to select the desired document:
™ Fle Edt View Actions Laser Reader Window Help
S S a2 S 0S8
1 el Sl a2+ |
| 4| Extended Layer O 78 %
6B - A g prm—— DUJDE

|: *| Ring Document

Sequence ‘ ‘

(Same as menu command File > New):

File | Edit View Actions Laser Reader Window Help

‘,' New Y| Layer Crl+i s

™
=l Project editor 48| Extended Layer =
<3| Open ctl+0 | Ring Document

Close shift+T .| Sequence

Project editor - It launches the Project Editor application which allows creating
programs in order to automate marking operations. (Same as menu command
File > Project editor).

Q

Open - It opens the window that allows choosing an existing layout. (Same as
menu command File > Open).

L

Save - It opens the window that allows saving a layout. (Same as menu com-
mand File > Save).

Jof

Mark Preview - It allows checking the final result of the marking process of your
layouts directly in Laser Editor. This button is made available after creating or
opening a document in the work area. (Same as File > Mark Preview).

Cut - It allows cutting the selected object. (Same as menu command Edit > Cut).

Copy - It allows copying the selected object. (Same as menu command Edit >
Copy).

Paste - It allows pasting the object. (Same as menu command Edit > Paste).

Undo - It allows undoing the selected command. (Same as menu command Edit >
Undo).

V| O B O #F

Redo - It allows redoing the previously undone command. (Same as menu com-
mand Edit > Redo).

SOATALOGIC
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GETTING STARTED WITH LASER EDITOR

Insert Objects toolbar

This toolbar is displayed after pressing the ¥ Insert Objects button on the vertical
toolbar. It allows adding objects to the current document. See "About graphic objects" on
page 51 for more information.

Button

Description

o

Remove object(s) - It allows removing the selected object. (Same as menu com-
mand Actions > Remove object(s).

Text string - It allows inserting a text string into the current document. (Same as
menu command Actions > Insert > Text string).

Code - It allows inserting a code into the current document. (Same as menu com-
mand Actions > Insert > Code).

Imported - It displays the window that allows you to insert an imported graphic
object into the current document. You might import vectorial or raster images,
AutoCad/AutoDesk .DXF and .DWG files, . HPGL or . PLT files, as well as exist-
ing layouts (. XLP files). (Same as menu command Actions > Insert > Imported).

Array - It allows inserting an array into the current document. (Same as menu
command Actions > Insert > Array).

Circle - It allows inserting an ellipse into the current document. (Same as menu
command Actions > Insert > Circle).

Rectangle - It allows inserting a rectangle into the current document. (Same as
menu command Actions > Insert > Rectangle).

Poly - It allows inserting a polygon into the current document. (Same as menu
command Actions > Insert > Poly).

Lines - It allows inserting a line into the current document. (Same as menu com-
mand Actions > Insert > Lines).

Dot - It allows inserting a dot into the current document. (Same as menu com-
mand Actions > Insert > Dot).

8 LIGHTER™ SUITE

SOATALOGIC




LASER EDITOR'S USER INTERFACE QUICK REFERENCE

Evaluator toolbar

This toolbar can be hidden/displayed by right-clicking on the blank area in the toolbars
area and then deselecting/selecting Evaluator from the shortcut menu.

Button |Description

Hoooo |Marking time - It allows calculating the time for engraving the active document

GOATALOGIC USER MANUAL 9



GETTING STARTED WITH LASER EDITOR

Objects Operation toolbar

This toolbar is displayed after pressing the () Objects Operation button on the vertical
toolbar. It allows operating on objects, such as, for example, grouping/ungrouping
objects, editing vectors, and so forth. See "Grouping, merging, or joining objects" on page

125.

Button

Description

Group selection - It allows grouping the selected objects in a single object. Sin-
gle objects keep their properties, but the transformation and movement opera-
tions involve all grouped objects. (Same as menu command Actions > Group
selection).

Merge selection - It allows assembling two or more objects in a single object.
Single objects keep their properties, with the exception of laser and filling proper-
ties. (Same as menu command Actions > Merge selection).

Ungroup selection - It allows disassembling grouped or merged objects so they
can be moved or changed individually. (Same as menu command Actions >
Ungroup selection).

Union - It allows assembling vectorial objects so that their constituting polygons
are merged into a single object. This operation can only be reversed using the
Undo command. (Same as menu command Actions > Union).

Intersection - It allows assembling overlapping objects into a new single vecto-
rial object. Only the area that is common to the objects will be considered for the
engraving. This operation can only be reversed using the Undo command. (Same
as menu command Actions > Intersection).

Difference - It allows assembling overlapping objects into a new single vectorial
object. Only the outline of the first selected object, minus the common area, will
be marked. This operation can only be reversed using the Undo command. (Same
as menu command Actions > Difference).

Exclusion - It allows assembling overlapping objects into a new single vectorial
object. The outlines of the two objects will be marked, minus the common
area.This operation can only be reversed using the Undo command. (Same as
menu command Actions > Exclusion).

Make vectorial - It allows converting the selected string or code into a vectorial
object for you to be able to edit nodes. Note that, when a string is made vectorial,
it loses its properties and becomes a simple vectorial object. (Same as menu
command Actions > Make vectorial). See "Editing objects vectors" on page 128 for
more information.

Advanced processing - This button allows accessing the advanced vectorial pro-
cessing options that provide an automated way to edit vectors. (Same as menu
command Actions > Advanced processing). See "Using Advanced Processing
options" on page 107 for further information.

Edit nodes - It allows editing the nodes of a vectorial object. When you press this

button, the « = ¢ & & . & Edit Nodes toolbar is displayed that allows you to
edit the object's shape. (Same as menu command Actions > Edit nodes).
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LASER EDITOR'S USER INTERFACE QUICK REFERENCE

Adjust Objects toolbar

This toolbar is displayed after pressing the &) Adjust Objects button on the vertical
toolbar. It allows aligning, spacing, flipping, or resizing objects, as well as fine-tuning the
marking order. See "Aligning, flipping or spacing objects" on page 124 for more informa-

tion.

Button

Description

Align left - It allows aligning the selected objects to the left. (Same as menu
command Actions > Align > Align left).

Align top - It allows aligning the selected objects to the top. (Same as menu
command Actions > Align > Align top).

Align right - It allows aligning the selected objects to the right. (Same as menu
command Actions > Align > Align right).

Align bottom - It allows aligning the selected objects to the bottom. (Same as
menu command Actions > Align > Align bottom).

Align center X - It allows aligning the selected objects along the X axis. (Same as
menu command Actions > Align > Align center X).

Align center Y - It allows aligning the selected objects along the Y axis. (Same as
menu command Actions > Align > Align center Y).

Flip horizontally - It allows flipping the selected object(s) horizontally. (Same as
menu command Actions > Flip > Flip horizontally).

Flip vertically - It allows flipping the selected object(s) vertically. (Same as menu
command Actions > Flip > Flip vertically).

Space horizontally - It allows spacing the selected objects evenly across. (Same
as menu command Actions > Spacing > Space horizontally).

Space vertically - It allows spacing the selected objects evenly down. (Same as
menu command Actions > Spacing > Space vertically).

Make same size - It allows making the same size for the selected objects. (Same
as menu command Actions > Size > Make same size).

Make same width - It allows making the same width for the selected objects.
(Same as menu command Actions > Size > Make same width).

Make same height - It allows making the same height for the selected objects.
(Same as menu command Actions > Size > Make same height).

Restore transformations - It allows restoring the selected object(s) to its origi-
nal size oy orientation. (Same as menu command Actions > Size > Restore trans-
formation).

Marking order - It allows optimizing the order in which the objects will be
engraved. (Same as menu command Actions > Marking order). See "Optimizing
the objects marking order" on page 135 for more information

SOATALOGIC
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GETTING STARTED WITH LASER EDITOR

Zoom toolbar

This toolbar is displayed after pressing the & Zoom button on the vertical toolbar. It
allows displaying the whole graphic area on the screen or a greatly enlarged detail of a
particular part. See "Zooming" on page 132 for more information.

Button

Description

In - It allows gradually zooming the whole graphic area. (Same as menu com-
mand View > In).

Out - It allows gradually reducing the zoom. (Same as menu command View >
Out).

Selection - It allows zooming in the selected object(s) so that it fits the entire
graphic area. To return to the original graphic area, click on Zoom page. (Same as
menu command View > Selection).

Page - It allows restoring the original graphic area. (Same as menu command
View > Page).

AN RN ORE ORI

Window - It allows zooming a specific area in the drawing. (Same as menu com-
mand View > Window).
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Laser toolbar

This toolbar is always displayed. It allows interacting with the laser device. For further
information, see "PERFORMING THE ENGRAVING OPERATION" on page 138 for more
information.

Button

Description

&

Connect to device - This button is only available if you have a Supervisor installa-
tion of Laser Editor (see "Installation types and connection modes" on page 19).

It displays the window that allows you to connect to a laser device, either locally
or remotely. (Same as menu command Laser > Connect to device).

Open from device - It allows opening a laser document that you have previously
saved to the laser device. (Same as File > Open from device).

Save to device - It allows saving a layout to a specific device with a specific
name, into a folder managed by Laser Engine. (Same as File > Save to device).

Switch to Manual (or Auto) Mode - It allows switching between operating
modes. Selecting Manual Mode allows you to set laser parameters or send docu-
ments to marking. By default, Auto Mode is set and layouts are sent to marking
via a Project Editor's program. (Same as menu command Laser > Select Manual
(or Auto) Mode).

Work Mode - This button is only enabled if you are in Manual Mode. It allows
marking the selected layout using the external Start and Stop commands directly
from editor. If you are not connected to a device, it activates the simulator. (Same
as menu command Laser > Send marking).

Send marking - This button is only enabled if you are in Manual Mode. It allows
sending the layout to the device for marking. If you are not connected to a device,
it activates the simulator. (Same as menu command Laser > Send marking).

Send marking on selection - This button is only enabled if you are in Manual
Mode. It allows sending the selected object to the device for marking. If you are
not connected to a device, it activates the simulator. (Same as menu command
Laser > Send marking on selection).

Stop marking - It allows interrupting the laser marking operation. (Same as
menu command Laser > Stop marking).

Limits on selection - It allows tracking the engraving limits of the currently
selected object(s). The area involved in engraving is shown and not the profile of
the object to be engraved. (Same as menu command Laser > Limits on selection).

Limits all - It allows tracking the engraving limits in the work plain. Margins are
displayed using a red laser pointer. (Same as menu command Laser > Limits all).

Limits previous/next sector - These buttons allow tracking the engraving limits
of the sectors that compose the object(s). This function is suitable when engrav-
ing on ring documents. (Same as menu commands Laser > Limits previous sec-
tor and Limits next sector).

Simulator - It is used to simulate the engraving results when in Manual Mode. A
new graphic window is displayed where engraving is simulated. The simulation
maintains all the speed, filling, wobble or other parameters set for the document.
(Same as menu command Laser > Simulator).

Show Laser Engine - It allows opening Laser Engine window directly from Laser
Editor, either locally or remotely. See "LASER ENGINE USER INTERFACE" on page
151.

Laser Configuration - It allows opening the Laser Configuration window directly
from Laser Editor so as to set the laser and axis parameters. (Same as menu
command Laser > Laser Configuration).

SOATALOGIC
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Edit device global variables - It allows managing global variables, so as to
share contents (counters and strings) between more documents. (Save as menu

m command Laser > Edit device global variables). See "Using global variables" on

page 114.

Manage Device Users - It allows you to set and manage the users' rights on the

system you to connect to a laser device, either locally or remotely. See "Managing

users and access rights" on page 157.

System Test - It allows accessing the dialog where you can test the Laser sys-

tem and check your system's connections. In particular you can test all Inputs and

Outputs, as well as the external Start and Stop signals.

<> -
| &
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Reader toolbar

This toolbar can be hidden/displayed by right-clicking on the blank area in the toolbars
area and then deselecting/selecting Reader from the shortcut menu.

Button

Description

a
Photometric Adjustment

Photometric Adjustment - It manages image acquisition photometry and focus-
ing. (Same as menu command Reader > Photometric Adjustment). See "Photo-
metric Adjustment" on page 206

Quality Grade Training

Quality Grade Training - It manages the quality grade training. (Same as menu
command Reader > Quality Grade Training). See "Quality Grade Training" on page
208

SOATALOGIC
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CHAPTER 2
PRELIMINARY OPERATIONS

This chapter is divided into the following sections:

Topic

"Registering your product" on page 17

"Installation types and connection modes" on page 19
"Setting the default behavior of Laser Editor" on page 20
"Importing Materials Database" on page 22

"Open Smartist Projects” on page 23

"Automatic conversion Smartist Projects” on page 24
"Opening the data folders" on page 25

Before you begin working with Laser Editor, you have to complete the following proce-
dures:

e "Registering your product" on page 17

¢ "Installation types and connection modes" on page 19

e "Setting the default behavior of Laser Editor" on page 20
¢ "Importing Materials Database" on page 22

e "Open Smartist Projects" on page 23

e "Automatic conversion Smartist Projects" on page 24

e "Opening the data folders" on page 25
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REGISTERING YOUR PRODUCT

While Laser Editor does not need to be licensed, Laser Engine, that is the run-
time component of the marking system, can be installed as a trial version for 30
days, after which it will no longer engrave. However, Laser Editor will still func-
tioning as a graphic editor.
To register Laser Engine before it expires, complete the following procedures:

e "Obtaining the license file" on page 17

e "Sending the activation key to the remote device" on page 18

Obtaining the license file

To register Laser Editor:

e From the Laser Editor menu bar, choose Help > Get device ID.
¢ In the Device ID window, select button Copy Device ID to clipboard:

r ~
™ DevicelD =50
IP Address: localhost
Device ID: XSUOV-TTMCE-COBVS-I64ZN-LER SR-60 2WP

] Copy Device ID to dipboard

To license this software please e-mail the code above together with laser serial
number and order invoice number or delivery note or OA

Customer Administration mailbox:
orders.FR.@datalogic.com (FRANCE)

orders,ES @datalogic.com (SPAIN)

orders.UK-IE @datalogic.com (UNITED KINGDOM)
orders. IT@datalogic.com (ITALY)

orders.BX @datalogic.com (BEMELLIX)
orders.DE@datalogic.com (GERMANY-AUSTRIA-SWITZERLAND)
orders.5E @datalogic.com (NORDIC)

orders,EE @datalogic.com (EAST EUROPE)
orders,MEA @datalogic.com (MIDDLE EAST & AFRICA)
ordersamericas @datalogic.com (AMERICAS)
orders.asia@datalogic.com (ASIA PACIFIC)

L, |

e Copy the identification code and paste it into an e-mail that you will send to the
address that appears at the bottom of the dialog.

e You will receive a reply with an attached file called License.dat.

COATALOGIC USER MANUAL 17



PRELIMINARY OPERATIONS

Sending the activation key to the remote device

To perform this operation, you must be connected to the device. For further
information, see "Connecting to the laser device" on page 147.

CAUTION

This procedure allows sending the activation key to the remote device to which you are
connected:

To send the license:

e From the Laser Editor menu bar, choose Help > Send license.

¢ Inthe Choose license file window that is displayed, select the License . dat file
that you have received from the manufacturer (see "Obtaining the license file" on
page 17).

e Click on Open. This will automatically send the license to the remote device.
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INSTALLATION TYPES AND CONNECTION MODES

When installing Laser Editor, you can choose between different installation types,
depending on your needs.

The installation type determines if you are installing either Laser Editor or Laser Engine,
or both components, as well as whether you can interact to Laser Engine remotely.

The following table summarizes the available solutions:

Installation type and description

Laser Editor can con-
nect to any Laser
Engine available on
the network

Laser Engine is suit-
able for remote con-
trol through the
network

Interactive

Installs both Laser Editor and Laser
Engine.

Use this option if you are installing
the software on the PC that will con-
trol the laser locally (SLAVE device).
This option will install components
for editing layouts and controlling the
laser source locally.

This option allows the laser source to
be controlled by MASTER device via
Ethernet.

NO

YES

Supervisor

Use this option if you are installing
the software on the PC that will con-
trol the laser source remotely (MAS-
TER device).

This will install components for edit-
ing layouts and control the laser
source via Ethernet.

This option allows the laser source to
be controlled by MASTER device via
remote ActiveX control.

YES

NO

SOUATALOGIC
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SETTING THE DEFAULT BEHAVIOR OF LASER EDITOR

You can use the Configuration dialog box of Laser Editor to set the default configuration
parameters for your application.

See the following for further information:

e "Setting language, measurement unit and graphical effects (General page)" on page
20

e "Setting documents parameters (Geometry page)" on page 21

Setting language, measurement unit and graphical effects (General
page)

This window allows you to specify the user interface language, the linear measurement
unit and the graphical effect for your application.

To set the General parameters:
e From the Laser Editor menu bar, choose File > Configuration. The Default param-
eters configuration window is displayed.
¢ Inthe left pane of the window, leave General selected.
e Set the default parameters using the following table as a reference.

Group box Parameter Description

It lists the available languages for the user
interface. Select the language you want to use.
Language Note that by default, the language is set to
Autodetect, meaning that it depends upon the
language of your operating system.

Sets the linear measurement unit. Available

Linear . .
Units options are mm or inches.
. Sets the number of decimals to be used. Admit-
Decimals
ted values are 0 to 5.
Max log space (KB) The log funcionality is intended for the exclusive
Loqgin use of technical support staff. Setting values
gging Max log file number other than the default ones could cause the sys-
tem to slow down and/or its instability.
Graphical effects Text dimension It allows increasing the font dimensions. This is

particularly useful when using Asiatic fonts

It allows managing the evaluator for the
marking time in order to speed up the lay-
outs editing. Two settings are available:
« every change - the evaluator is calcu-
lated whenever the contents of a docu-

Tools Evaluator updates ment are changed. This settings slows
down the editing operations.

« on click - the evaluator is calculated at
the user's request. This is the recom-
mended setting, especially in case of lay-
outs with many graphics.

Choose this button to restore the default param-

Restore window settings eters. A restart of the application is required

Choose this button to clear the lists of laser
Reset to factory settings sources and lenses got from several engines. A
restart of the application is required.

e Click OK to implement your settings.

20 LIGHTER™ SUITE SDATALOGIC



SETTING THE DEFAULT BEHAVIOR OF LASER EDITOR

Setting documents parameters (Geometry page)
This window allows setting dimension, orientation, and grid settings for documents.

All measurement units in this page depend on the units that were selected
in the General page. See "Setting language, measurement unit and graphical

effects (General page)" on page 20.
NOTE ( page)’ on pag

To set the documents parameters:
e From the Laser Editor menu bar, choose File > Configuration. The Default param-
eters configuration window is displayed.

e In the left pane of the window, select Geometry. The parameters in this window
allow setting the default parameters for the documents that you will create.

e Make the desired changes using the following table:

Group box Parameter Description
Width Sets the width of the work area for a plane document.
Height Sets the height of the work area for a plane document.
Plane Margin X Sets the width of the margins in the work area for a plane
document.
Margin Y Sets the height of the margins in the work area for a plane
document.
. Sets the size of the external or internal diameter for a ring
Diameter
document.
Ring Thickness Sets the height of the ring or cylinder for a ring document.
: Sets the width of the margins in the work area for a ring doc-
Margin Y
ument.
Enable grid If selected, displays the grid in the work area (Default:
selected).
Grid setting Snap to grid If selected, enables the objects snap to the grid. (Default:
deselected).
Grid step It allows setting the grid spacing.
The default origin for the Cartesian coordinates (x y) that are
used as the reference point. Their origin is set by default to 0.0
(Center).
Origin position |The dropdown list allows you to select an origin other than
Center, such as Left Top or Right Bottom.
Furthermore, you can set a Custom origin: in this case, enter
. ) new values for the XY coordinates.
(e)rzltgltri]oind ort- Origin X Sets the X coordin.a.te (horizqntal) of the new origin, in relation
to the default position, that is the Center of the document.
Origin Y SetstheY coorsii.nate (ver'tical) of the new origin, in relation to
the default position, that is the Center of the document.
Invert X If selected, inverts the X axis so as to change the field orienta-
tion. (Default: deselected)
Invert Y If s.elected, inverts the Y axis, so as to change the field orien-
tation. (Default: deselected)

the Properties window for the active document. See "Setting language,

U You will then be able to change the settings at a document level by editing
measurement unit and graphical effects (General page)" on page 20.

NOTE

e Click OK to implement your settings.
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IMPORTING MATERIALS DATABASE

This function is used to import into Laser Editor database materials that you have cre-
ated using Smartist. You can import:
e Materials Database (. ini, .DB files)

To import a materials database from Smartist:
¢ From the Laser Editor menu bar, choose File > Import Materials Database to dis-
play the Choose a materials database to open window.
e From the Type of file dropdown list, select the proper type of file. There are two
available options:
-.1ini files
-.DB files
e Browse to locate the desired file and click Open.

e After completing the import operation, a number of information messages will be
displayed providing information on imported file(s).
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OPEN SMARTIST PROJECTS

Is possible to open into Laser Editor any project or document that you have created
using Smartist. You can open:

e Smartist projects (. prj files)

e Smartist documents (. LDX, . LDC files)

To open a Smartist project or document:

* From the Laser Editor menu bar, choose File > Open to display the Choose a docu-
ment to open window.

e From the Type of file dropdown list, select the proper type of file. There are two
available options:

- Smartist projects (.pxrj files) - It allows importing a Smartist project,
which can be composed by one or more graphic layouts.

- Smartist documents (. LDX, . LDC files) - It allows importing a specific
document that you have created using Smartist

e Browse to locate the desired file and click Open.

e After completing the import operation, a number of information messages will be
displayed providing information on imported file(s), Smartist version, and so forth.
Any opened document will be displayed in a tab within the Laser Editor window,
for you to manage or edit as any other Laser Editor document.

Note that, if any script or formatter file was included in the project, a mes-
sage tells you in which folder on your PC it has been saved during the
import operation. You can use Project Editor to open or edit it. Project Edi-

NOTE  tor is a tool that allows creating custom programs, which includes his own
Help system. To access it, choose File > Project Editor from the Laser Edi-
tor menu bar.

COATALOGIC USER MANUAL 23



PRELIMINARY OPERATIONS

AUTOMATIC CONVERSION SMARTIST PROJECTS

Is possible to convert automatically a list of Smartist Projects from input directory and
subdirectories.
Usage: LaserEditor.exe --convert-files <from directory> <to directory> <file pattern> [--
convert-subdirs] [--convert-log <log file name>]

e --conver-files - It allows to specify the Input and Output directories.

- <from directory> - Input directory
- <to directory> - Output directory

- <file pattern> - You can specify a file name pattern
e --convert-subdirs - It allows to specify to convert files from subdirectories.
e --convert-log - It allows to specify the log file name created in the Output direc-
tory. The default file name is 'convert.log'.

- <log file name> - Log file name

Example:
LaserEditor.exe --convert-files c:\temp\prj_from c:\temp\prj_to *.prj
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OPENING THE DATA FOLDERS

The Open data folder function allows retrieving informations that you might need for
support purposes, as well as to check the data or the device's configuration.

To view the folders contents:

e From the Help menu, select Open data folder.

™ File Edit View Actions Laser Reader Window Help |
R (=1 - s 1 A 3 Hel F1
L Ll BBy S (L G e
Get device ID
¥ [1ER I [ &y @ Send license
Tm@ﬁguﬂd/
| COpen data folder N

O“Undo;"redu commands list &= X‘ Save debug information nen
[—|--~\ ‘{Empty} ‘ About I

¢ Inthe window that is displayed, select the desired folder. Use the following table
as a reference:

Folder Contents

Config Configuration files, laser configuration, and license.

Correction Files for lenses correction.

Database Databases of passwords, materials, and global variables.

Fonts List of the fonts that can be used in Laser Engine.
List of the script available in the drop-down menu of the custom formatters

Formatters (see "Custom Formatters" on page 69)
Database history files. See "Statistics" on page 200, that shows statistic

History rela.ting to marking processes and marking .&verifi.catilon processes (feature
available with Marvis enabled; see the Marvis Application Note for more
details)

Logs Log files that were generated from Laser Engine and Laser Engine Service
Controller.

Docs/Layouts Documents laser engine tab.

Docs/Temp List of the temporary documents.that are sent to the marking in Manual
mode, directly from the Laser Editor.

Minidumps Files for technical support team.

OEM Files for Lighter personalization.

Plugins Plugins that are registered when launching Laser Engine.

. Folders containing the projects that are saved to the device. The “default”

Projects . :
folder must always include the default project.

ReaderConfig Reader’s configuration files.

Recovered Automatic backup file generated in case of a crash of the Laser Editor.

Upgrade Reserved for laser engine applications.
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CHAPTER 3
CREATING GRAPHIC LAYOUTS

This chapter is divided into the following sections:

Topic

"Setting your work environment" on page 27

"Graphics editing overview" on page 28

"About documents" on page 29

"About graphic objects" on page 51

"Understanding objects colour in the work area" on page 113
"Using global variables" on page 114

"Common operations on objects" on page 119
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SETTING YOUR WORK ENVIRONMENT

By default all child windows are displayed in the Laser Editor window, that is, the Prop-
erties, the Undo/Redo commands list, and the Objects engraving order windows.

Furthermore, several toolbar buttons are displayed, to allow you a quick access to the
main functions of Laser Editor.

However, you can customize your work environment by displaying or hiding both win-
dows and toolbars.

Hiding/Displaying windows or toolbars

To hide/display an element:

e Right-click in a blank area next to the toolbars to display a shortcut menu that lists
all the elements that compose the work environment (panes and toolbars)

Undo/redo commands list

Properties O Prmh’es

Objects marking order Property Value

Select

Laser

Reader

Evaluator

Insert ohjects
Object operations
Adjust objects

Zoom

e Deselect/select the corresponding checkbox to hide/display an element, respec-
tively

Docking/Undocking panes

By default, the three panes Undo/redo commands list, Objects engraving order, and
Properties, are displayed at the left and the right side of the Laser Editor's window,
respectively. You can move or resize them. For example, you might want the Properties
window to float over the work area.

To dock/undock a pane:
e Toundock a pane, click on its title bar, for example on Properties, and then drag it

to the desired position.
e To resize a pane, undock it, and then use the mouse to change its dimensions.

e To dock a pane in its original position, double-click the title bar.

COATALOGIC USER MANUAL 27



CREATING GRAPHIC LAYOUTS

GRAPHICS EDITING OVERVIEW

In order to create and manage layouts for laser engraving, you will do the following:
Create a document, that is the “container” for the graphic objects that compose

the layout. (See "About documents" on page 29)

Add and edit the graphic objects to be engraved (see "About graphic objects" on

page 51)

The Property browser, which is available for documents and objects, allows you to edit
the properties so as to suit your engraving needs. You can customize the parameters
that define how the objects will be engraved: this includes sizes, origins, filling, laser
parameters, and so forth.

Furthermore, you can operate on objects by using toolbars, mouse, and menu bar.

While editing, you can use the F1 key to access the context Help that relates to what you
are doing, as well as to display information on each properties group, as illustrated in
the following example where a String object has been added to a plane document:

N
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to display the toolbars
for objects operations

Press these buttons ]

Laser Marking

[

Select a Properties title and

_
)

press F1 to display the context

Help for those properties
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ABOUT DOCUMENTS

In Laser Editor, a document can be referred to as a container for graphic objects that
compose the layout to be engraved. The document's area corresponds to the engraving
laser work area.

Laser Editor provides two types of documents that you can use depending on your
engraving needs:

e Layer documents, are used for vectorial or raster engraving on flat surfaces.

e Ring documents, are used for vectorial or raster engraving on cylindrical surfaces.
When you install Laser Editor, it is necessary to be connected to the Laser Engine, that
is, to a laser source in order to be able to create new documents. If you are operating in
a standalone station, the Laser Engine is launched automatically; while, if you are oper-
ating on a network, you need to manually connect to the Laser Engine at least once.
Otherwise, you will only be able to edit existing documents.

When creating e new document, default parameters are used to set the laser source,
the dimensions of the graphic work area, and so forth; these are the parameters that
have been set for the application (See "Setting the default behavior of Laser Editor" on
page 20). However, you can use the documents Property browser to change these set-
tings, as it is described in the sections that follow.

When adding an object to a document, the laser parameters that have been set for the
document are used. You can still setting different laser parameters for each object; in
this case, the object will appear blue. (See "Understanding objects colour in the work
area" on page 113).
The following sections describe how to work with documents in Laser Editor:

e "Common documents properties" on page 30

e "Creating a document for plane engraving" on page 32

e "Creating a document for ring engraving” on page 39

e "Opening existing layouts" on page 43

e "Saving layouts" on page 44

e "About sequences" on page 46

You can also use the Sequence feature to create programs that allows automating docu-
ments' marking operations (see "About sequences” on page 46).
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LAYOUTS

Common documents properties

ring documents. Properties that are specific to either plane or ring docu-

B The properties that are described in this section apply to both plane and
ments, are described in the relevant section.

NOTE

The following tables describe the Target and Laser properties, which are common to
plane and ring documents.

These properties are available when a document is being created and no objects are
selected.

Target properties for documents

This set of properties is only visible if:
o you are operating on a network and you are not yet connected to a
laser source; or
CAUTION * you are connected to more laser sources.

When creating a new document, the default parameters that have been set in the
Default configuration parameters window for Laser Editor are used.

The following properties are available when you first install Laser Editor and are not yet
connected to a Laser Engine. Once you are connected to a Laser Engine, these proper-
ties are not longer available. They become available if you connect to a Laser Engine
which is connected to another laser source or a lens; in this case, you can select from
the lists the desired source or lens.

Group Property |Description
It lists the available laser sources (stand-alone installation), or
Laser source the laser source(s) to which you might remotely connect (super-

visor installation).

It contains a list of available optical lens that you can install on
the scanner head of the laser device.

The dimensions of the Work Area depends on this parameter
(see "Setting the work area" on page 36).

Objective lens

Laser properties for documents

The following properties will be used as the default laser parameters when adding new
objects to the document. However, you can still set different parameters for a specific
object. (See "Custom Laser parameters for Objects" on page 54).

Group Property |Description

It allows setting the number of runs of the laser light on the object
to engrave. You might set up to 3 passages, each with different laser
Passages parameters. This option may be particularly useful to make several
engraving runs to clean the work piece after a more incisive engrav-
ing process. (See "Using more engraving runs" on page 140).

This indicates the laser output power. The value is expressed as a

Power percentage of the maximum power of the laser source.
Light emitted by the laser is pulsed. Use this parameter to adjust
Passage (#) the frequency of the emlltted light. |
Frequency All other parameters being equal, a lower frequency causes a higher

per pulse. Not all combinations of power and frequency are allowed.
Depending on the laser source type, low frequencies require corre-
spondingly low powers.
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This indicates the engraving speed. The value is expressed in milli-
meters per second. (Note: A slower speed implies engraving a

Scan Speed deeper engraving. Set a very slow speed (50-100 mm/s) for special
processes, such as burnishing or deep engraving.
Sets the engraving time for each dot, that is, the time required for
Dot Delay o
laser emission on the dot.
) Sets the duration of the laser shot pulse i.e. the time the Q-switch is
Shot Time

open (or, better, transparent).

Pulse Profile

Set the duration of the laser pulse (available only for MOPA laser
source).

Repetitions

Sets the number of times objects are marked. Increasing the num-
ber of passes will increase depth of engraving, consequently affect-
ing the cycle time.

Wobble

If it is set to True, this property allows engraving thicker lines through a spiral
movement instead of a linear movement. See "Using the wobble function to
engrave with thicker lines" on page 141

Radius

Represents the radius of the spiral curve.

Speed

epresents the frequency of spiral repetition.

X Axis

If it is set to True, it allows setting the desired position for the X Axis.

Y Axis

If it is set to True, it allows setting the desired position for the Y Axis.

Z Axis

If it is set to True, it allows setting the desired position for the Z Axis.
If the distance sensor is enabled, the Origin property is available.
The Origin property has the following values:
o Logical Zero: the Height value is related to the Z Axis logical
zero value
»  Reference Position: the Height value is related to the position
that the Z axis has, before the layout is processed

R Axis

If it is set to True, it allows setting the desired position for the R Axis.

You can set the parameters for the objects in the document, based on a specific material
(e.g. plastic) and its reactions to the marking operation. For further information on how
to save and recover a materials database, see "Saving a Materials database for a later re-
use" on page 35.
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Creating a document for plane engraving

A plane document is used for vectorial or raster graphic engraving on flat surfaces.

The document's area corresponds to the engraving laser work area. It is where you cre-
ate the layout by drawing and editing graphics objects, or importing raster or vectorial
image files, such as a logo (see "About graphic objects" on page 51).

When you create a new document, the default parameters that have been set in the
Default configuration parameters window for Laser Editor are used. (See "Setting the
default behavior of Laser Editor" on page 20). You can use the Property browser to set
other parameters.

For further information, see:
e "Creating the document" on page 33
e "Saving a Materials database for a later re-use" on page 35
e "Setting the work area" on page 36
e "Geometry properties - Layer" on page 37
e "Geometry properties - Extended layer" on page 38
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Creating the document

To create the layer:
Do one of the following:

- From the Laser Editor menu bar, choose File > New > Layer.

- From the Laser Editor standard toolbar, click the £& - button.

The document appears in the Laser Editor's window, where the engraving layout is
represented.

N Fle Bt View Acions Leser Reader Window Help

TV EM= T E-WARNERNESWEIR B2 15040 R0 oM [P 2 WI¥: [HOR=
e [TR R e 2 looloocalarlalimmanzel b a
[" : :::::mm B x Document4 |
O
D]
(4]

Objects marking order & X

Note that the Properties window contains the default parameters, that is the parame-
ters the have been set for Laser Editor.

SOUATALOGIC

To create the engraving layout, complete the following operations:

- Set the properties for the document that best fit your engraving require-
ments. Refer to sections "Common documents properties" on page 30, "Geome-
try properties - Layer" on page 37, and "Saving a Materials database for a later
re-use" on page 35 for further information.

In particular, when setting the document's work area, refer to "Setting the
work area" on page 36.

- Add the graphic objects for engraving, either by drawing or importing them
(see "About graphic objects" on page 51)

When you are finished, you might save the document in the following ways:

- Choose File > Save or click the [z button to save the document on your PC,
as a graphic layout (. x1p file).

- Choose File > Save as to save a copy of the document.

- Choose File > Save to Device or press the § button to save the layout
remotely, directly to the laser device for marking. You can select the device
and enter a name for the document.
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The document(s) will be actually sent to the laser engraver through an auto-
mated procedure written with Project Editor.

(For further information, see "Saving a layout to a device" on page 45).

procedures or to update the layout contents at runtime. It has its own con-
text-sensitive Help and it is integrated into Laser Editor. To access it,

NOTE  choose File > Project Editor.

M The Project Editor is a programs editor that is used to automate marking

e To close a document, click the [£) button at the top right of the work area

You can work on more documents simultaneously. Each document will be
displayed in a tab in the Laser Editor's window.

NOTE

To create the Extended Layer:
e Do one of the following:

- From the Laser Editor menu bar, choose File > New > Extended Layer.
- From the Laser Editor standard toolbar, click the ;@ - button.
e The document appears in the Laser Editor's window, where the engraving layout is
represented.

»
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Saving a Materials database for a later re-use

The Materials property, allows saving specific laser settings and filling parameters in a
database that you can then import in a new layout. After setting your parameters
according to a specific material and its reactions to the marking procedure, and once
your layout is ready, you can store it for a later re-use.

The same operation can be done for each individual object in the document.

To save a materials database:
e Click Materials properties:
4 Materials

Material [ hd
Save ]

e Click the Save button to display the following dialog:
™ Save material lili_h_J

Material name

e Enter a meaningful Material name (e.g., plastic) and click OK to save the database.
Note that the dropdown list contains the materials databases that you have cre-
ated previously.

e Use the Delete button to delete existing databases.

To re-open a previously saved database:
¢ From the Laser Editor menu, select File > Import Materials Database.
¢ Inthe windows that is displayed, navigate to Data_Lighter > Database and then
select the desired file: . ini file, if the layout was created in Smartist, . db if it
was created in Laser Editor.
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Setting the work area

The size of the work area is a fundamental setting. The maximum size that can be used
is based on several elements, including the focus height installed on the engraving laser
and the quality of the lens. As a general rule, increasing the focal length will result in the
work area increasing, but the model and the quality of the lens can also affect the size
of the work area.

The lens can have different focal lengths: this determines the size of the marking area.

The focal lengths also determine other properties of the laser marking system, such as
the working distance and the laser spot.

When you set the work area parameters, keep in mind that its width cannot exceed the
focus length set for the laser. The figure below shows an example:

The focal length for the objective lens are set both at laser device's level and at the level
of the document.

To set the focal length at the laser device level:

e Right-click the Laser Engine icon on the Windows taskbar and select Laser Config-
uration. (For more information on how the Laser Engine works, see "LASER
ENGINE USER INTERFACE" on page 151).

¢ Select the Correction page.

e Under Lens, choose from the Focal Length [mm] dropdown list the focal length
used by the laser device.

To set the focal length at the document level:
¢ Inthe Properties window of the active document, under Target, choose from the
Lens dropdown list the optical lens to be used.
e When setting the work area for the document, remember not to exceed the
dimensions that the installed optical lens determine.
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Geometry properties - Layer

When creating a new document, the default parameters that have been set in the
Default configuration parameters window for Laser Editor are used. For further infor-
mation, see "Setting documents parameters (Geometry page)" on page 21.

You can use the document's Property browser to set parameters other than the default
ones.

All measurement units that are used in this page depend upon the units
that you have selected at the application level. See "Setting language, mea-

NOTE surement unit and graphical effects (General page)" on page 20.

Group Property ‘ Description

It corresponds to the surface to engrave. The size of the work area is a fundamen-
tal parameter. The maximum size that can be used is based on several parame-
ters, including the focus height installed on the engraving laser and the model of

Work Area | jans. (See "Setting the work area" on page 36)

Width Sets the width of the work area

Height Sets the height of the work area

. X Sets the distance between left and right margins of the work area
Margins

Y Sets the distance between top and bottom margins of the work area

If it is set to True (default), the grid is displayed and the relevant properties are
available. The grid is a series of traced lines which intersect. They can be used to
precisely align and position objects in the drawing window. (See "Using the docu-

Grid ment's grid" on page 120)

Step Sets the dimension of the cells on the grid

If it is set to True, enables the snap to the objects in the grid, that is,
Snap to grid |when you move objects on the grid, they will be aligned to the clos-
est grid line. (Default: False)

The default origin for the Cartesian coordinates (x y) that are used as the reference
point. Their origin is set by default to 0.0 (Center). The position of the objects
refers to this point.

The dropdown list allows you to select an origin other than Center, such as Left
Top or Right Bottom.

Furthermore, you can set a Custom origin: in this case, you should enter new val-
ues for the XY coordinates

Origin Sets the X coordinate (horizontal) of the new origin, in relation to the

X Position default position, that is the Center of the document

Sets the Y coordinate (vertical) of the new origin, in relation to the

Y Position default position, that is the Center of the document

If it is set to True, inverts the X axis so as to change the field orienta-

Invert X Axis | . (Default: False)

If it is set to True, inverts the Y axis, so as to change the field orien-

Invert Y Axis tation. (Default: False)
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Geometry properties - Extended layer

Group Property ‘Description
It corresponds to the surface to engrave. The size of the work area is a fun-
damental parameter. The maximum size that can be used is based on sev-
eral parameters, including the focus height installed on the engraving laser,
Work Area the model of lens, and the X-Y axis configuration. (See "Setting the X, Y, Z,

and Rotor Axes parameters" on page 180)

Width Sets the width of the work area

Height Sets the height of the work area

Enabled Area Ref-
erence

The default origin for the Cartesian coordinates (x y) that are used as the ref-
erence point. Their origin is set by default to 0.0 (Center). The position of the
enabled extended area refers to this point

Frame Size

X Set the length in mm of the single marking area

Y Set the height in mm of the single marking area

Enable Area Posi-
tion

X position of the enabled extended area in relation to the
Enabled Area Reference parameter

Y position of the enabled extended area in relation to the

Y Enabled Area Reference parameter

Number of the
Enabled Frame

Sets the number of frames in X and Y coordinates

Grid

see Grid

Origin

see Origin
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Creating a document for ring engraving
In order to mark a ring document, you must install and configure on your
device a rings separator.

Furthermore, the Rotor axis must be enabled (Enable axis property) in your
Laser Configuration settings. (See "Setting the X, Y, Z, and Rotor Axes
parameters" on page 180).

NOTE

Ring documents are used when you need to engrave a cylindrical surface. The docu-
ment's work area represents the whole linear development of the surface to be
engraved (360°).

The document's area corresponds to the engraving laser work area. It is where you cre-
ate the layout by drawing and editing graphics objects, or importing raster or vectorial
image files, such as a logo (see "About graphic objects" on page 51).

When you create a new document, the default parameters that have been set in the
Default configuration parameters window for Laser Editor are used. (See "Setting the
default behavior of Laser Editor" on page 20). You can use the document's Property
browser to set other parameters.

For further information, see:
e "Creating the document" on page 40
e "Geometry properties - Ring document" on page 41
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Creating the document

To create the document:

e Do one of the following:
- From the Laser Editor menu bar, choose File > New > Ring Document.

- From the Laser Editor standard toolbar, click the down arrow next to the ;m -
button and then select Ring Document:

N Fle Edit View Actons Laser Reader Window Hep

T N Y e WY, 5555 B 00 R [ X, 3- 0 [fore
] aver culin i - : . o - : : | 2 :
il 8 Extended Layer O.12.0 %0 1 ‘.d L (DGO ‘/‘J“ R k 1 _ ‘;](
A Ring Document |\ 5 x| Document7 | Q_
|1, sequence
]
]
3]

Shicdepalin o B

Note that the displayed work area represents the linear development of the surface to
be engraved and the Properties window contains the default parameters that have

been set for Laser Editor.

e To create the ring engraving layout, complete the following operations:
- Set the properties at the document level, so as to fit your engraving require-
ments. Refer to sections "Common documents properties” on page 30, "Geome-
try properties - Ring document" on page 41, and "Saving a Materials database for
a later re-use" on page 35
- Add the graphic objects, either drawing or importing them (see "About
graphic objects" on page 51)

e When you are finished, you might save the document in the following ways:
- Choose File > Save or click the [ button to save the document on your PC,
as a graphic layout (. x1p file).
- Choose File > Save as to save a copy of the document.
- Choose File > Save to Device or press the @ button to save the layout
remotely, directly to the laser device for marking. You can select the device
and enter a name for the document.

The document(s) will be actually sent to the laser engraver through an auto-
mated procedure written with Project Editor.

(For further information, see "Saving a layout to a device" on page 45).

The Project Editor is a programs editor that is used to automate marking

procedures or to update the layout contents at runtime. It has its own con-

text-sensitive Help and it is integrated into Laser Editor. To access it,
NOTE  choose File > Project Editor.

To close a document, click the [E) button at the top right of the work area.

You can work on more documents simultaneously. Each document will be
displayed in a tab in the Laser Editor's window.

NOTE
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Geometry properties - Ring document

When creating a new document, the default parameters that have been set in the
Default configuration parameters window for Laser Editor are used. For further infor-
mation, see "Setting documents parameters (Geometry page)" on page 21.

You can use the document's Property browser to set parameters other than the default
ones.

All measurement units that are used in this page depend upon the units
that you have selected at the application level. See "Setting language, mea-
surement unit and graphical effects (General page)" on page 20.

NOTE
Group Property |Description
Diameter The size of the external or internal diameter
Ring Height The height of the ring or cylinder
Mark Sets engraving inside or outside the ring
Margins Sets the width of the vertical margins
If it is set to True (default), the grid is displayed and the following properties are
available
Grid Step Sets the dimension of the cells on the grid
If it is set to True, enables the snap to the objects in the grid, that is,
Snap to grid |when you move objects on the grid, they will be aligned to the clos-
est grid line. (Default: False).
The default origin for the Cartesian coordinates (x y) that are used as the reference
point. Their origin is set by default to 0.0 (Center). The position of the objects
refers to this point.
The dropdown list allows you to select an origin other than Center, such as Left
Top or Right Bottom. Furthermore, you can set a Custom origin: in this case, you
should enter new values for the XY coordinates
Origin X Position Sets the X c_o.ordinate _(horizontal) of the new origin, in relation to the
default position, that is the Center of the document
Y Position Setsthe Y c_qordinate_(vertical) of the new origin, in relation to the
default position, that is the Center of the document
. |Ifitis set to True, inverts the X axis so as to change the field orienta-
Invert X Axis tion. (Default: False)
. |Ifitis set to True, inverts the Y axis, so as to change the field orien-
Invert Y Axis tation. (Default: False)
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Advanced

Sector Size

Defines the width of the sector. The sector represents a portion of
the working area to be engraved within a single movement of the
rotating axis.

The 0 value (default) provides the highest level of quality: to each
polygon is associated a movement of the rotating axis, so that the
portion being marked is always placed on the center of the marking
area. Greater value results in a shorter total marking time, but
might impact quality.

Note that the sector size can't exceed the portion of the area which
is in focus; this is based on the laser's depth of focus. If you set a
greater value, the application ignores it and uses the maximum
allowed value instead, based on the depth of focus of your laser

Sector Gap

It is used in association with the Sector Size property and the Til-
able property for vectorial objects. It allows fine tuning the marking
results.

When you apply the Tillable property to an object, the following
occur:

o The object is separated into its constituting polygons.

« If apolygonis larger than the sector and it is closed (algo-
rithm won't work if the figure is open), Laser Engine will try to
“slice” it in portions whose dimension is equal to the ring's
sector to be marked.

If it is set to 0, only one cut line is used between the two sectors (left
and right borders), while if it is < 0, two cut lines are used, allowing
you to overlap or separate the borders, as needed.

For a detailed description of how the Tillable property works, see
"Using the tiling function” on page 111.

Angle

The slant angle of the rotating axis, expressed in degrees. (Possible
values: 0 to 60)

Reset axis at

If it is set to True, it brings the rotor to its initial position at the end

the end of .
: of engraving

execution
fitis set to True, allows setting the focus as ring radius-indepen-
dent. This means that (being the rings separator fixed), if the ring
radius changes, the Z axis must change accordingly in order to focus
the area to be engraved. Enabling this function, you only need to
focus the revolution centre; then, the system will automatically con-
trol the Z axis so as to set the focus accordingly to the ring dimen-
sions.

——— Mechanical Zero (proxy zero)

Use ring

radius as Z

axis position _ [y

Logic Zero VY- — — |-

oD

Rotor

For correct operation, set the logic zero of axis Z in the revolution
center. Logic zero is the focus position on the item to be engraved.
The logical zero also depends on the 'Ring Offset' parameter in
Laser Configuration settings, see "Setting the X, Y, Z, and Rotor
Axes parameters"” on page 180
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Opening existing layouts

You can open layouts (that is, .x1p Laser documents) that you have previously saved
for further editing, or for sending them to the engraver.

You can open a layout that was saved locally, or a layout that was saved to a device.

For further information, see:

"Opening a layout on your PC" on page 43
"Opening a layout from a device" on page 43

Opening a layout on your PC

Do one of the following:
- From the Laser Editor menu bar, choose File > Open.

- From the Laser Editor standard toolbar, click the #5 Open button.
In the Choose a document to open window that is displayed, browse to locate the
.x1p Laser document you want to open.
Click on Open. The selected document is displayed in the work area of Laser Edi-
tor.

Opening a layout from a device

This function allows you to open a laser document that you have previously saved to the
laser device for further editing.

SOUATALOGIC

Do one of the following:
- From the Laser Editor toolbar, click the @ Open from device button.

- From the Laser Editor menu bar, choose File > Open from device.
In the Choose a document to open window that is displayed, select from the
Devices dropdown list the device to which the document was saved. (Here are
listed all the available devices on the network).
The File area shows the layouts that have been saved to the selected device.
Choose the file you want.
Click OK. The selected document is displayed in the work area of Laser Editor.
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Saving layouts

When you are finished creating a laser layout, you can save it either locally, or to a
device so that it is then sent to the engraver through an automated procedure.

Saving a layout on your PC

The following procedure allows saving a layout as a .x1p file on your disk, for later use
or editing.

To save the layout:
e To save a new, unnamed layout:

- Choose File > Save (or click the [ button on the toolbar).

- In the Save document as window that is displayed, go to any location avail-
able from your computer (or create a new folder).

- In the File name box, type a name for the document and click Save. The doc-
ument will be saved with the . x1p extension.

e To save a copy of an existing document:
- Choose File > Save as.

- In the Save document as window that is displayed, go to any location avail-
able from your computer (or create a new folder).

- In the File name box, type a new name for the document and click Save.
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Saving a layout to a device

The following procedure allows saving a layout to a specific device with a specific name,
into a folder that the Laser Engine manages.

You can then use Project Editor to write a program for documents uploading, so that
the saved documents are sent to the engraver in an automated way.

The Project Editor is a programs editor that is used to automate marking
procedures or to update the layout contents at runtime. It has its own con-
text-sensitive Help and it is integrated into Laser Editor. To access it,

NOTE  choose File > Project Editor. Default programs and easy-to-use examples
are provided with the tool.

To save the layout to a device:
e Do one of the following:

- From the Laser Editor toolbar, click the @ Save to device button

- From the Laser Editor menu bar, choose File > Save to device.
¢ Inthe Save document as window that is displayed, select from the Devices drop-
down list the device you are sending the layout to. (All the available devices on the
network are listed).
The File area shows the layouts that have been saved to the selected device.
e Enter a name for the document and click OK. This is the name that will be used in
the Project Editor's program.
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About sequences

A sequence is a program containing actions that Laser Engine will automatically exe-
cute.

It allows automating marking operations in simple scenarios and provides a user with an
easy-to-use interface for programs design using Laser Editor.

A typical scenario where this feature can be used, is a production line with a PLC (Pro-
grammable Logic Controller) that manages automations and that is connected to the I/
O PCI card: The sequence feature allows interacting with the PLC in order to execute a
specific order of marking operations.
Using a sequence you can:

e define a specific order of marking operations that will be automatically executed;

e create or import plane or ring documents to be marked;

e interacting with the PLC by setting outputs or reading inputs;

* moving axis, if enabled.

In addition to creating sequences, in order to automate marking proce-
dures, you might also use Project Editor, which is a programs editor inte-

grated into Laser Editor. To access it, choose File > Project Editor. Default
NOTE  programs and easy-to-use examples are provided with the tool, as well as
a context-sensitive Help.
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Creating and executing a sequence

To create a sequence:
e Do one of the following:

- From the Laser Editor menu bar, choose File > New > Sequence.

- From the Laser Editor standard toolbar, click the down arrow next to the but-
ton and then select Sequence:

Extended Layer

Ring Document

B

[Prope rties pane]/

Connection - Device: LV device (ocalhost)

Note that the Sequence items toolbar is displayed next to the Standard toolbar of Laser
Editor and a sequence with the default item is displayed in the work area.
e Click the buttons on the toolbar to add items to your sequence, using the follow-
ing as a reference (see also the "Example:" on page 49).
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Button |Description
2 If-Else-End IF - is a control structure that allows you to perform a block of items
wo=ox | Dased on the Boolean condition

o]

Counter - It allows to set a local counter to the sequence or select a counter in
the global variable database. Is required to use the Condition property with the
If-Else-End if item

Input - It allows setting inputs on the 1/0 PCI card, which can be connected to a
PLC (16 input bits are available). This allows you to interact with the PLC that
manages operations and tell it how to behave when executing the program.
Properties: Bit 0 to Bit 15 are the input bits that you can set. Possible options
are:

« Don't care - Ignores the bit, that is, leaves the bit how it was

» Ifreset - if bit = o then process item If, otherwise process item Else-End If

o Ifset-if bit=1 then process item If, otherwise process item Else-End If

Break - Stop the sequence in any condition

Label - It is a placeholder. It is required in order to use the Get and Go item. The
Label tells the Get and Go item where it must jump after verifying the specified
condition.

Properties: The Label property is an editable field where you can enter a text for
the label. The typed text will then be displayed in brackets next to the Label item

Move Axis - This item is only enabled if at least one axis is enabled on the laser.

Execution of this item result in one or more axes being moved; execution is com-
pleted when all axes target positions have been reached. (See also "Setting the X,
Y, Z, and Rotor Axes parameters" on page 180).

Properties: Set to True to enable one or more axis.
The Home Search parameter is used to move the axis in home position.
The Position parameter is then displayed for you to specify the axis position.

The Origin parameter define the reference for the Position Z value:
e Logical Zero: the Position Z value is related to the Z Axis logical zero value
« Reference position: the Postion Z value is related to the position that the Z
axis has, before the Move Axis item is processed
If the distance sensor is enabled and the Z axis is enabled, the Autofocus Search
parameter is available. If the Autofocus Search is set to True a Focus Distance
Search is performed

Document - It allows creating or importing a layout, extended layout or ring doc-
ument into the sequence. Do one of the following:

o  To create a new document, double-click the Document item that you have add
to the sequence. If ring documents management is enabled, a window is dis-
played prompting you to specify which type of document you want to create.
(See "About documents" on page 29 for information on how to work with doc-
uments).

o Toimport an existing document, click the Import property in the Properties
pane and then use the .| browse button to select the document.

Properties: The Import property allows importing an existing document. The
Name property is an editable field for you to enter the document's name
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&

Set Out - It allows setting outputs on the I/0 PCI card, which can be connected to
a PLC (16 output bits are available). This allows you to interact with the PLC that
manages operations and tell it how to behave when executing the program.
Properties: Bit 0 to Bit 15 are the output bits that you can set. Possible options
are:

o Don't care - Ignores the bit, that is, leaves the bit how it was

o Set- It sets the bit to True

» Reset - It sets the bit to False

Delay - It allows setting a delay that you might need to complete a pending oper-
ation.

Properties: The Delay [ms] property allows you to specify the delay in millisec-
onds

o

Wait Start - It is the default item that is displayed when creating a sequence. In
order to execute or to continue processing a sequence, Laser Engine waits for the
user pressing Start

Get and Go - To enable this item, you must first select at least one Label. A Get
and Go item is associated to a specific Label to which it might jump or not,
depending on the condition to be verified (if any). To do this, the Get and Go item
verifies the input bits as they are set by the PLC and then uses this information to
proceed (jump to label or continue).

If the If Set option is selected, it verifies that the input bit is activated before jump-
ing to the associated label. Otherwise, ignores the jump and executes the next
operation that follows. (See the "Example:" on page 49 below).

Properties: The Jump to property is an editable field for you to enter the associ-
ated label's name, which will then be displayed in brackets next to the Get and Go
item. Bit 0 to Bit 15 properties allows setting the conditions that the Get and Go
item must verify before proceeding into the execution. Possible options are:

o Don't care - Ignores the bit. It indicates an unconditional jump, that is, the jump

will be executed in any case
« If Set - Verifies that the bit has been activated (True)
» If Reset - Verifies that the bit has been deactivated (False)

Clone document - It allows cloning a document that is already into the sequence,
that is, adding one or more copies of an existing document

Properties: The Name property allows you entering a new name for the cloned
document

Delete sequence item - It allows deleting from the sequence an item that you
have previously added. To delete an item, select it and then press this button

7

NOTE

You can drag and drop items in order to move them to a new location into
the sequence.

The example here below shows a sequence where Get and Go is used to repeatedly
mark two documents. The figure also shows how properties was set for the Get and
Goes items:

Example:

SOUATALOGIC

Sequence

& ‘Label [Start

A Wait Start e e
g; Getand Goto [P2] |———————» “cetadse

£ Document [Planel] i

[.~ Get and Go to [Start] |
-2 Label [P2] \ Propery [vake
-2 Document [Plane2] = ot anel 0

Jump to Start
[[c Getand Go to [Start]']/’" TR N

USER MANUAL 49




CREATING GRAPHIC LAYOUTS

The following diagram shows how the program will be executed based on this

sequence:

* [Label [Start]—> Starts the process

Wait Start

> Waits for user's confirmation

y

et and Go

to[P2)

—3 Verifies the status of the /O bit O

Jumps to Label [Pzr
and marks Plane2

Ignores junp
and marks Plane 1

—~

/

iGet and Go

Jumps unconditionally

to[Start] »to Label[Start]

To execute a sequence:

Sequences are executed as projects, that is, after you save a sequence to the device, it
will be executed at the Laser Engine level by activating the Auto Mode (see "Auto/Man-
ual working mode" on page 162).

For further information on saving a sequence, follow the instructions as described in
section "Saving layouts" on page 44.
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ABOUT GRAPHIC OBJECTS

Once you have created a document, you can compose the layout for laser engraving by:
e adding shapes (circles, rectangles, or polygons);
e importing the following raster or vectorial graphics:
- vectorial: . PLT, .HPGL, .DXF, .DWG

- raster: .BMP, .JPEG, .GIF, .PNG, .TIF
e creating text strings, matrix codes, bar codes, or arrays.

For further information:

The following sections describe how to work with objects in Laser Editor:
e "Common objects properties" on page 52
e "Working with simple vectorial objects" on page 57
e "Using Text strings" on page 59
e "Using Codes" on page 70
e "Using Arrays" on page 93
e "Importing graphic objects" on page 102
e "Using the tiling function" on page 111
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Common objects properties

The Properties window supports context-sensitive Help: During layout
editing, selecting a properties title (for example, Geometry), and then

pressing F1, opens the context Help for those properties.

NOTE For further information on how to operate on objects using properties, see

"Common operations on objects" on page 119.

Properties that are specific to each object or to documents, are described
in the relevant section.

The tables that follow describe the Geometry, Laser, Filling and Clone properties which
are common among graphic objects.

Geometry properties for Objects

The following table describes the Geometry properties that allow enabling/disabling
objects, resizing, rotating, and skewing them, as well as changing the objects position.
These properties are displayed when an object is selected in the work area.

For a quick, rough sizing, rotating, and positioning of an object, you might
use your mouse (See "Using the mouse to select and manipulate objects" on
page 121).The Property browser allows more precise operations.

NOTE
Geometry Description
properties
D To each object loaded in the graphic area can be assigned an unique alpha-

numeric ID that identifies the object in the layout

If it set to True (default), it enables engraving of the selected object. If the
Enable object is not enabled (False), it will not be engraved and the object's colour
in the work area changes to gray

If it set to True, it locks the object preventing any editing. The selection
Locked handles around the object disappear and the @ handle appears: Click it to
unlock the object. (Default: False.)

If it set to True (default), keeps the proportions between width and height.

Keep Aspect |11 4oes not apply to the Code object

If it set to True, it allows merging the vectors that compose an object. In
the case of a string, this property is particularly useful when working with
languages whose alphabets have ligatures, such as the Arabian language.

Contour (See "Working with ligatures" on page 67). (Default: False.)

It does not apply to the Array, Imported Bitmap objects and About two-
dimensional (2D) codes

It allows fine-tuning the object's dimensions by adjusting the contour.

Pocketing It does not apply to Array, Bitmap objects and About two-dimensional (2D)
codes

It only applies to vectorial objects on ring documents, that is, on cylindrical
surfaces. It is suitable for high precision markings, typically in jewellery.

It allows cutting the object's polygons having dimensions that exceed the
Tillable sector size, into tiles whose dimension is equal to the ring's sectors. For a
detailed description, see "Using the tiling function” on page 111.

This property is used in association with the ring document's Sector Gap
and Sector Size properties that define the sector's dimensions
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Origin

This is the point of origin of the object. The origin is identified by the cross
symbol which, by default, is placed in the center. If you select a value other
than Center (default), this symbol moves accordingly. The following exam-
ple shows an object whose origin has been set to Center Top in a docu-
ment whose point of origin is set to Center:

-

origin of the object
(Center Top)

origin of the
engraving area: Center|
document’s origin)
& L]

You can specify the object's position in relation to the document's origin by
setting the X and Y coordinates

§88f 8
HH

v

R s

mmmmmmmmmmmmmm

il

ten

Position (X)

Sets the horizontal position of the object in relation to the origin that has
been set for the document. You may increase X value to move the object to
the right, decrease it to move the object to the left

Position (Y)

Sets the vertical position of the object in relation to the origin that has been
set for the document. You may increase Y value to move the object to the
top, decrease it to move the object to the bottom

Dimensions (W)

Sets the width of the object

Dimensions (H)

Sets the height of the object

Angle

Sets the rotation angle (in degrees) of the object on the engraving area. It
does not apply to the Array object

Scale (X)

By default, is set to 1,00. Increasing/decreasing this value results in the
object's width changing. It does not apply to the Array object

Scale (Y)

By default, is set to 1,00. Increasing/decreasing this value results in the
object's height changing. It does not apply to the Array object

Skew

Sets a skewing for the object: if you set a positive value, the object is
skewed to the right, while, with a negative value is skewed to the left.
(Default: 0). It does not apply to the Array or Code objects

SOUATALOGIC
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Custom Laser parameters for Objects

The following properties are displayed when you select an object in the work area, and
then set to True the Custom Laser parameter in the Properties window.

By default, this parameter is set to False because, when you add a graphic object to a
document, the object inherits the laser parameters that have been set for that docu-
ment. You can still set different laser parameters for each object; in this case, the

object's colour changes to blue.

Group

Property

Description

Passaged

It allows setting the number of runs of the laser light on the object
to engrave. You might set up to 3 passages, each with different laser
parameters. This option may be particularly useful to make several
light engraving runs to clean the workpiece after a more incisive
engraving process. (See "Using more engraving runs" on page
140)

Passage (#)

Power

This indicates the laser output power. The value is expressed as a
percentage of to the maximum power of the laser source

Frequency

Light emitted by the laser is pulsed. Use this parameter to adjust
the frequency of the emitted light. All other parameters being equal,
a lower frequency causes a longer pulse. Not all combinations of
power and frequency are allowed. Depending on the laser source
type, low frequencies require correspondingly low powers

Scan Speed

This indicates the engraving speed. The value is expressed in milli-
meters per second. (Note: A slower speed implies engraving a
deeper engraving. Set a very slow speed (50-100 mm/s) for special
processes, such as burnishing or deep engraving

Dot Delay

Sets the engraving time for each dot, that is, the length of time for
the laser emission on the dot

Shot Time

Sets the duration of the laser shot pulse i.e. the time the Q-switch is
open (or, better, transparent)

Repetitions

Sets the number of runs required by the laser for engraving the
imported objects. Increasing the number of passes will increase
depth of engraving, consequently affecting the cycle time

Wobble

If it is set to True, this property allows engraving thicker lines through a spiral
movement instead of a linear movement. (See "Using the wobble function to
engrave with thicker lines" on page 141)

Radius

Represents the diameter of the spiral curve

Speed

Represents the frequency of spiral repetition

X Axis

If it is set to True, it allows setting the desired position for the X Axis

Y Axis

If it is set to True, it allows setting the desired position for the Y Axis

Z Axis

If it is set to True, it allows setting the desired position for the Y
Axis. If the distance sensor is enabled, the Origin property is avail-
able.
The Origin property has the following values:
» Logical Zero: the Height value is related to the Z Axis logical
zero value
» Reference Position: the Height value is related to the position
that the Z axis has, before the layout is processed

R Axis

If it is set to True, it allows setting the desired position for the R Axis

You can set the parameters for a specific object, based on a specific material (e.g. plas-
tic) and its reactions to the marking operation. For further information on how to save
and recover a materials database, see "Saving a Materials database for a later re-use" on
page 35.
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Filling properties for Objects

The following properties are displayed when you select an object in the work area, and
then set a value other than None (default) for the Filling property.

7

NOTE

The Filling properties do not apply to the Array object or the imported bit-

maps.

See also "Specifying the filling patterns" on page 133 to see examples of

filling.

Filling
properties

Description

Filling

This property is used to set the filling for the object. The engraving is mostly
done with exact parallel lines. In particular, filling can be done with:

Single line

Cross lines - Inclination of the lines will be 0 and 90 degrees

Triple lines - Inclination of the lines will be 0, 60, and 120 degrees.
Islands - It allows deep engraving by executing a series of concentric
markings, starting from the object's outline, so as to obtain countersunk
shapes. The Islands allows to avoid crossed path, so each etched sur-
face is exposed to the laser only once, which is particularly useful when
engraving on delicate materials.

Dot - It only applies to About two-dimensional (2D) codes. It allows
treating a square as a dot. This filling type is tailored for marking micro-
elements, such as, for example, objects whose size is as big as the laser
spot on the surface. In this case, the Dot filling allows marking directly a
dot rather than filling a square.

Raster - It allows marking a vectorial object as if it were a raster object,
that is, using the raster engraving technique (for more information, see
"Raster graphics vs. Vectorial graphics” on page 104). This setting is
particularly suitable for plastic cards because constant scanning speed
allows for better quality

Interline

Sets the distance between filling lines

Angle

The angle (0-360°) that defines the direction of the engraving parallel lines.
Setting an angle results in the engraving lines changing direction (0 = horizon-
tal, left to right (default) - 90 = vertical, bottom to top - 180 = horizontal, right
to left)

Advanced

Direction

This property is used to specify how the laser performs the filling operation:

Bidirectional - The laser marks parallel lines, first lines from left to right,
then right to left (or vice versa, according to the value that has been set
for the Angle), and so forth. This allows reducing the markingtime.
(Default).

Unidirectional - The engraving is done only in one direction, increasing
the marking time
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Outline option

This property is used to specify how the outline is to be marked relative to the
filling:

«  No outline - The outline of the object will not be marked

o Filling first - The filling of the object will be marked first. (Default)

o Outline first - The outline of the object will be marked first

Tolerance

Sets the distance between object's outline and filling lines

Fill by

This property is used to specify how the laser marks the filling of objects that
are composed by more polygons (such as strings):

e Object - The laser marks horizontally, using parallel lines across all the
vectorial data that compose the object (for example, a string will be
marked from bottom to top, scanning all letters with a single run). This
filling option results in longer marking times, but it is recommended
when marking on plastic cards because it ensures a uniform result.

o Polygon - The laser marks polygon by polygon (for example, letter by
letter in a string, or bar by bar in a code). This filling option results in
faster marking times and it is recommended in industrial environments

Clone properties for Objects

The following properties are displayed when you select an object in the work area.

U The Clone properties do not apply to the Array object or the imported

graphics.
NOTE
Clone Description
properties
This property is used to repeat graphic object to a different position. Inparticu-
Clone lar, the clone can be done with:

¢ Number of clones
« Offset

Clones number

Sets the number of clone objects in X and Y coordinates

Offset

Sets the distance between objects in X and Y position

56 LIGHTER™ SUITE

SOATALOGIC




ABOUT GRAPHIC OBJECTS

Working with simple vectorial objects

_EEE;EfILHKI Reader Window Help
¥ Remove object(s) Del a | S
| Insert N P |“I' Textstring
Align T tug| Code
Flip ¥ | &) Imported
Spacing Y |55 Array .
Size » |* Elipse
Sequence b t] Rectangle
Group selection #3 Poly
Merge selection % Lines
Ungroup selection * Dot

The Circle, Rectangle, Poly, Lines and Dot toolbar buttons (as well as the Actions menu),
allow inserting in your layout simple vectorial shapes that can be easily manipulated by
editing the vectors. (See "Starting nodes editing" on page 130).

A vectorial object like this uses lines and curves, called vectors, to describe the image. In
laser engraving a vectorial graphic is faster in engraving and more defined in terms of
outline lines and filling.

Furthermore, you can use the Properties window, the toolbars, or the mouse to resize,
adjust, group, space, shear, tile, fill the shapes, and so forth.

7

NOTE

For information on mouse operations, see "Using the mouse to select and
manipulate objects" on page 121.

For information on how to operate on graphics, please refer to "Common
operations on objects" on page 119 on objects.

Clicking a properties title in the Properties browser and then pressing F1,
opens a table with a description of those properties.

The following sections describe how to work with vectorial shapes:
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"Adding a shape" on page 58

"Starting nodes editing" on page 130

"Using the tiling function” on page 111

"Geometry properties for Objects" on page 52
"Custom Laser parameters for Objects" on page 54
"Filling properties for Objects" on page 55
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Adding a shape

To add a shape:

First, create or open a document to enable the insertion of objects (see "CREATING
GRAPHIC LAYOUTS" on page 26 and "Opening existing layouts" on page 43).

To add a circle or a rectangle, do one of the following:
e On the vertical toolbar click on the ¥ Insert objects button and then, in the hor-
izontal toolbar that is displayed, click on #2 Circle or #¥7] Rectangle.

e From the Laser Editor menu bar, choose Actions > Insert > Circle or Rectangle.
The shape (a circle or a square) appears in the work area, surrounded by the selec-
tion handles: Drag to make the shape the size you want (see "Using the mouse to
select and manipulate objects" on page 121).

To add a poly, do one of the following:
e On the vertical toolbar click on the ¥ Insert objects button and then, in the hor-
izontal toolbar that is displayed, click on #3 Poly.

¢ From the Laser Editor menu bar, choose Actions > Insert > Poly.

e Position the mouse pointer at the required start point for the polygon and left
click.

e To create a curve: Left-click and hold down while dragging to the desired position:

°

[ ]

\

R

(For further information on nodes, see "Starting nodes editing" on page 130).
e Once the pointer is in the desired location, left-click to draw a green-coloured line.

e Repeat the previous step as many times as required to add subsequent corners of
the polygon.

e To close the polygon click on the first click point. The selection handles appear
around the object. To exit the Poly creation mode, press Esc.

(For further information, see "Using the mouse to select and manipulate objects" on page
121).

To add a Line, do one of the following:

On the vertical toolbar click on the ¥ Insert objects button and then, in the horizontal
toolbar that is displayed, click on %~ Lines.

From the Laser Editor menu bar, choose Actions > Insert > Lines.

Click and drag to draw the desired line.

To close the line click on the first click point. The selection handles appear around the
object. To exit the Lines creation mode, press Esc.

(For further information, see "Using the mouse to select and manipulate objects" on page
121).

To operate on shapes:

Use the Properties window, the toolbars or the mouse to customize the look of the
shape, in terms of size, position, rotation, filling, and so forth, as well as for setting cus-
tom laser parameters.

Select the shape, then double-click it: This will result in the shape's segments changing
to the green colour and in the Edit nodes function being enabled. See "Starting nodes
editing" on page 130.
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Using Text strings

 Actions | Laser Reader Window Help

* )| Remove object(s) Del rf"l q Ii’"‘;}
Insert L T Text string [}

By using the toolbar button or the Actions menu, Laser Editor allows you to insert text
strings in a layout.

You can then use the Properties browser, the toolbars tools, or the mouse to set dimen-
sions, printing character, font style, spacing, shear and filling. (Click a properties title,
then press F1 to open a table with a description of the properties.)

Laser Editor allows you to:

dynamically display updated texts;

use special character s to create variable texts (date, time, auto-incremental
counter);

place the text inside or outside of a circumference arc;

import any kind of font;

set the font, dimensions, style, printing characters, spacing, and filling;

edit strings as pure vectorial objects;

rotate, shear, or resize strings using the mouse (see "Using the mouse to select and
manipulate objects" on page 121);

set custom laser parameters that differ from those that have been set for the doc-
ument.

The following sections describe how to work with Text Strings:

SOUATALOGIC

"Adding a Text string" on page 60

Changing the characters style (see "Text String properties" on page 68)
Aligning the text to a circle (see "Text String properties" on page 68)
"Importing fonts" on page 60

"Using special character sequences" on page 61

"Making a text string to include an incremental counter" on page 63
"Editing a string as a pure vectorial object" on page 65

"Dynamically managing strings that share contents" on page 66
"Working with ligatures" on page 67

"Text String properties" on page 68
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Adding a Text string

To add a string:

Create or open a document to enable the insertion of objects (see "CREATING
GRAPHIC LAYOUTS" on page 26 and "Opening existing layouts" on page 43).

Do one of the following:
- On the vertical toolbar click on the ¥ Insert objects button and then, in the
horizontal toolbar that is displayed, click on ' Text string.
- From the Laser Editor menu bar, choose Actions > Insert > Text string.
The String object is displayed in the work area, surrounded by the selection han-
dles: for quick, rough sizing, rotating, or positioning, use your mouse (see "Using
the mouse to select and manipulate objects" on page 121).
Use the Properties window and the toolbars buttons for formatting and customiz-
ing the string. (See below).

bars tools" on page é.

B For a quick-reference on using toolbars in Laser Editor, see "Using tool-

NOTE

Clicking a properties title in the Properties window and then pressing F1,
opens a table with a description of those properties.

Importing fonts

In order to enable this function, all documents have to be closed.

CAUTION

By default, Laser Editor uses standard fonts but you can use this function to import any
kind of fonts. You will then be able to select the fonts from the Font property list under
the Style property group.

Furthermore, two non-standard, single line fonts are provided (namely, Roman-s and
Standard) that allow optimizing the marking time. You might also import One Line single
line commercial fonts ("https://www.onelinefonts.com/").

To import fonts:

Choose File > Import fonts from the menu bar. The Font import dialog box is dis-
played.

The System font area on the left lists all the fonts that are currently installed on
your system; by selecting a font, a preview is displayed on the left pane.

Select the font(s) you want to import in Laser Editor, and then click > | to enter
the font in the Laser fonts list on the right.

Click | to import all existing fonts.
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Using special character sequences

You can use the Text string tool to create variable texts that include dates and/or times.
To do so, you will use special character sequences.

To create dates and times by using special character sequences:
e Add a text string to the document (see "Adding a Text string" on page 60).
¢ In the Properties browser, under String select the Text box, and then enter the
desired special character sequence, depending on the date and/or time format
you want to use. Use the following table as a reference:

Table 1: Special character sequences for dates and times

Special charac- |Result

ter sequences

%a, %A Day of the week, abbreviated (a) or full (A)

%b, %B Month of the year abbreviated (b) or full (B)

%c Date and time according to current location

%d Day of the month, decimal number (01 -31)

%H Time 24 hour clock format (00 - 23)

%l Time 12 hour clock format (01 - 12)

%)j Day of the year, decimal number (001 - 366)

%m Month of the year, decimal number (01 - 12)

%M Minutes, decimal number (00 - 59)

%p A.M. / P.M. indicator

%S Seconds, decimal number (00-59)

%U Week of the year, decimal number (00 - 51, Sunday is the first day of
the week)

%w Day of the week, decimal number (1 - 7, Sunday = 1)

%W Week of the year, decimal number (01 - 52, Monday is the first day of
the week)

%x Date according to current location

%X Time according to current location

%y Year, two digit decimal number (00 - 99)

%Y Year, four digit decimal number

%z, %Z Time zone, name (Z) or abbreviation (z)

%% Percentage sign%
Percentage sign followed by an ID string that allows copying the con-

%[ID] tent of a str?ng int(? another string for dynamic update. (See "Dynami-

’ cally managing strings that share contents” on page 66, for further

information)

Yotic Long date and time representation, appropriate for current locale. (For
example: Tuesday, April 1, 2008, 12:41:29)

Optix Long date representation, appropriate for current locale. (For example:
Tuesday, April 1, 2008)
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These sequences allow using global variables. V forces the capitaliza-

0, 0,
vIl, %V tion. (For further information, see "Using global variables" on page 114)

It allows encoding the FNC1 character for symbologies supporting the
GS1 standard. (For further information, see section "Using Codes" on
%f page 70, GS1-128 standard, and GS1 Site).

Example: providing a text value %f00350123451234567894 to a 128
code, encodes a GS1-128 having Al 00 and code 350123451234567894

Inserts the ASCIl character corresponding to the number between
square brackets. It is useful for adding string ASCII char that do not have
a graphical representation. (For example: %T[21] will encode the NAK
ASCIl code

%TIl

e After entering the selected sequence, press Enter. The string changes to the
selected date and/or time format. Set the required parameters for the string by
setting the Text String properties, or using the toolbars buttons.

Example:

e Entering the sequence %d/%m/%Y in the text box will result in a text string with
the following format: 01/04/2008.

e Entering the sequence %d/%m/%y in the text box will result in a text string with
the following format: 01/04/08.

U To enter the character % into the string, type it twice %% into the Text box.
NOTE
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Making a text string to include an incremental counter

You can use the Text string tool to create a variable text that includes an incremental
counter. To do so, you can:

Use special character sequences to associate a counter to a specific string.

Use of this type of counter is maintained for legacy software support only.

You should avoid using it in new projects. This counter is deprecated in

favour of global variables. Using such counters from the Editor may result
CAUTION  jn a value presentation not aligned with the one in use from the Engine.

e Create a global variable so as to save the counter at the device level, and then use
proper special character sequences to associate it to more strings and/or docu-
ments. (See section "Using global variables" on page 114).

To use special character sequences to create a counter:
This procedure describes how to use special character sequences to associate a counter
to a specific string, into a specific document. (To create a variable that you can share
between more strings and/or document, as well save at a device level, please refer to
section "Using global variables" on page 114).
e Add a text string to the document (see "Adding a Text string" on page 60).
¢ Inthe Properties window, under String select the Text box, and then enter the
desired special character sequence, depending on the type of counter you want to
create. Use the following table as a reference:

Table 2: Special character sequences for counters

Special charac- |Result
ter sequences

%n Counter, decimal format. It can be associated to a specific string
%o Counter, octave format. It can be associated to a specific string

Counter, hexadecimal format, lower case (e) or upper case (E). It can be

%e, %E . oo .
= associated to a specific string

It allows using a global variable (see "Using global variables" on page

%v, %V 114)

e Press Enter. The string changes to the specified counter format. Set the required
Counter properties.

|Properties g x|
Property Value =
4 String
Text Text
4 Style
Font Garamond
Style Regular
Height 10.00 mm
Shear 0.00
Angle 0.00®°
4 Displacement
Spacing 0.00 %
Compression 100.00 %
Circle ]
4 Counter
Start marking a
Stop marking 933
Current a
Step i
Cycles 1
Digit 3
Custom Formatters ]
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e Use the following table as a reference:

Counter property |Result

Start The minimum value for the counter

Stop The maximum value for the counter

Current The current value of the counter as it appears in the string
Step Increment value (positive or negative)

The number of times the counter will be marked before it is incre-

Cycles mented by one step
Digits The minimum number of digits to be displayed
Example

e Entering %n in the text box and then setting the parameters as follows
Current =1 -Start =1 - Stop = 10 - Steps = 2 - Cycles = 2 - Digits = 3
would result in the format 001 to become 003 ... 005 ... 007 ... 009 ... 002 ... 004 ...
006 ...008 ... 010 ... 001.
An increment would occur every two engraving jobs.
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Editing a string as a pure vectorial object

This procedure involves making the string a pure vectorial object.
This way, the string loses its specific properties and changes to a vectorial object that

you can edit by using the Edit nodes function of Laser Editor (see "Editing objects vec-
tors" on page 128).

To edit the vectors:
e Select the string you want to make vectorial.

e Do one of the following:
- From the Laser Editor menu bar, choose Actions > Make vectorial.
- On the vertical toolbar, click ¥ and then click (5 Make vectorial in the hor-
izontal toolbar.

e To enable the edit nodes function, click the 4 . Edit nodes button. This will result
in the Edit nodes horizontal toolbar being displayed and in the colour of the out-
line changing to green.

e Click the string to display nodes and control points that you can use to edit the
characters:

For detailed information on how to edit nodes, please refer to "Editing objects vectors"
on page 128.
e To exit the Edit nodes operating mode, click the #) Insert objects button.
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Dynamically managing strings that share contents

Laser Editor allows for dynamically managing strings contents.

Suppose that you have two strings that share the same content and that you want to
keep their content aligned if a change occurs. To do this, you can connect the strings
content to each other by means of their ID, which is a unique alphanumeric string that
identifies the object into the layout.

Circular references are not allowed. If a circular reference is being intro-
duced, an error message will be displayed.

NOTE

To use IDs to connect and dynamically update text strings:
e Select the string whose content you want to enter in another string.
e Associate an ID to the string: In the Properties window, under Geometry, click the
text box beside ID and then enter the desired alphanumeric string. Note that the
ID appears below the string:

Cywes

Ry = | 3 &

I
LU

Digit
Custom Formatters o
4 Geometry

™ st1
Enable @]
= Locked g
A, N ® Keep Aspect &l
Contour ]
Pocketing 0.00mm
Origin Center
4 Position (3.75, 0.42)
3

X 3.75mm

st1 %y Y -0.42mm
4 Dimensions 36.28 x 8,81

Add to the document the string that must share the same content as the above
string (see "Adding a Text string" on page 60).

In the Properties window, under String, click the text box beside Text and enter
%[St1] followed by the text of the new string, as it is illustrated below:

&

Property Value

) | .y “:";";;im
‘ IDTest |F==
= . | j —=] | -

D TeDondle—
il ‘ ‘ ] 4 = .

In this way, when the string IDTest changes, the second string will be also dynamically
updated.
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Working with ligatures

What is a ligature?

A ligature occurs where two or more letter-forms are joined as a single glyph. Ligatures
usually replace consecutive characters sharing common components.

For example, in the Arabic alphabet, historically a cursive, most letters take a variant
shape depending on which they are followed (word-initial), preceded (word-final) or
both (medial) by other letters.

From the point of view of an engraving layout, the ligatures would appear as letters
(that is, vectorial data) overlapping each other; as a result, the overlapped areas would
not be filled as expected.

To fix the problem, the Contour property is used, which allows merging the letters,
while keeping the string from becoming a vectorial object.

Using the Contour property to merge the letters:

SOUATALOGIC

Select the text with ligatures (letters that overlap each other).

From the Properties window, select Filling and then, from the dropdown list,
choose the desired filling value. (For further information, see "Filling properties for
Objects" on page 55). The overlapped areas will appear as follows:

I =] $i

By -

Under Geometry, select the Contour checkbox to set the True value. As a result,

Enable (€]

]

B0
Origin Center
4 Position (0.39,6.19)
X -0.39 mm
v 6.19mm
4 Dimensions 19.29x 1152
Width 19.24mm
Height 11.52 mm
Angle 0.00°

x 81.81%
v 8181%

Skew 0,00
Singie e

the overlapped areas will be filled and the object will be kept as a String:

8!

S

| 4 Geometry
»

Enable Wl

[ 4

|

4 Position (0.39,6.19)
X -0.39mm

4 Dimensions 19.24x 11.52
Width 18.24mm
Height 11.52mm

Angle 0.00°

x 8181%
i 8181%

|
‘ v 6.19mm
|
[
\
|

Skew 200

4 Filling Sngeine |
210 mm
Angle 0.00°
4 Advanced

Direction Bidrectonal

Outline option Filing First.

Tolerance 0.00 mm

Fill By Object
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Text String properties

The Properties window supports context-sensitive Help: During layout editing, selecting
a properties title (for example, Geometry), and then pressing F1, opens the context Help
for those properties.

The following properties appear when a Text string object is selected in the work area
(see "Using Text strings" on page 59).

7

For a quick, rough sizing, rotating, and positioning of a string, you might
use your mouse (See "Using the mouse to select and manipulate objects" on
page 121).The Property browser allows more precise operations.

NOTE Refer to section "Common operations on objects" on page 119 for further
information on how to use properties to perform specific operations on the
object.

Property [Subproperty |Description
The text string to be engraved. Select the Text box, enter the string
Text or the value of the variable which represents it and press Enter. (For
information on how to use special characters sequences, refer to
"Using special character sequences” on page 61)
The converted font that the text must use. The dropdown list con-
Font tains the available fonts. You might also import new fonts (See
"Importing fonts" on page 60)
The font style to be applied to the string. The dropdown list contains
Style . .
the available options
Height The height of characters
Style Shear Represents the shear of the selected string on the X axis
Represents the angle of rotation that a single letter uses in relation
to its origin. The example below shows a string with a character
angle of 15 degrees:
Angle o 5 e, -
o~ o - e s
Otring-Plrtin g Fa—=s
= TTTE——
Represents the distance between the string's characters (default
, Spacing value is 0). Negative values decrease the default spacing, whereas
Displace- o . .
ment positive values increase it

Compression

Represents the compression of each character of the string (default
value is 100)
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If enabled (True), the Circle property enables placing the text on a circumference
arc (default value is False). Setting the value to True, will result in making the fol-
lowing properties visible for you to specify the appropriate parameters

Represents the diameter of the circumference arc to align the string
on. Set a value other than 0 to create a circle. The figure shows a
circle with a radius value of 8:
Radius -
. Counter clock- |Sets the direction of text on the circumference arc. By default, is set
Circle wise to clockwise
Inside If enabled (True), it allows placing the string within the circle
If enabled (True), it allows setting the start point of the string on the
arc. You can then set the start point in degrees in the Start Angle
field below. The figure shows an Automatic start angle (when this
Autostart option is set to False):
angle = i
cmm|
Start angle Represents in degrees the start point of the string on the arc
The Counter group enables creating a variable text that includes an incremental
counter (see"Making a text string to include an incremental counter” on page 63
)
Start The minimum value for the counter
Stop The maximum value for the counter
Counter Current The current value of the counter as it appears in the string
Step Increment value (positive or negative)
The number of times the counter will be marked before it is incre-
Cycles
mented by one step
Digit The minimum number of digits to be displayed
Formatters are source files that are supplied with Project Editor. These files can be
used as functions libraries. Their purpose is to make it easier for developers to cre-
ate custom applications. For example, as an integrator, you might need specific
Custom functions that these libraries provide. Formatters have a . gs extension and are
Formatters |stored in the folder ...\Data\Formatters
True or False |Enable or Disable the use of a Custom Formatter file
Script Visible only if Custom Forma_tters is s_et to True. Use to select the
Custom Formatters from a list of available files
See also:

e "Geometry properties for Objects" on page 52
e "Custom Laser parameters for Objects" on page 54
e "Filling properties for Objects" on page 55
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Using Codes

Actions | Laser Reader Window Help

Remove ohject(s) Del ,'—] I Q /;} .:’ 9
| Insert * |'L Textstring ——

Align »lm code N B

Fip P =) Imported

Codes are representations of text data that is formatted and displayed especially for
automatic acquisition by dedicated optical devices (code scanners or readers).

There are several codes symbologies, which are provided in Laser Editor:

e Llinear
e Postal
e Stacked

e Two-dimensional (2D)
By using the Code toolbar button or the Actions menu, you can insert codes in a layout.

You might then use the Properties browser or the toolbars tools to set dimensions, the
type of standard, the size, the error levels, a checksum, the filling and so forth. (Clicking
a properties title in the Properties window and then pressing F1, opens a table with a
description of those properties).

The code is treated by Laser Editor in the same way as a text string, therefore it is possi-
ble to associate the functions of special character sequences as described for the string
object. (See "Using special character sequences” on page 61).
Furthermore, you can:

e set dimensions, black and white ratio, and filling;

e rotate or resize the code;

e set custom laser parameters that differ from those that have been set for the doc-
ument.

The following sections describe how to work with Codes:
e "Usual Codes terminology" on page 71
e "About linear bar codes" on page 72
e "About stacked bar codes" on page 73
e "About two-dimensional (2D) codes" on page 74
e "Adding a code" on page 75
e "Setting the data restoring capability" on page 75
e "Setting the level of redundancy for 2D Codes" on page 76
e "Setting the error correction level" on page 77
e "Balancing the black and white ratio" on page 77
e "Codes properties" on page 78
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Usual Codes terminology

Bar code symbol

A complete bar code, made of a blank area before the code, a start character, one or
more characters containing the information, a stop character and a final blank area
(quiet zone).

Black/White ratio

The ratio between white and black modules. You can fine-tune this ratio when marking
very small elements.

Codewords
Group of bars and spaces representing one or more numbers, letters, or other symbols.

Element
Name of a space or a bar.

GS1-128 standard

The GS1-128 standard is an application standard (visit the GSI Site for further informa-
tion) within the Code 128 barcode. It allows using a series of Application Identifiers to
include additional data such as best before dates, batch numbers, quantities, weights
and many other attributes that a user might need. It's supported in our software by
Using special character sequences.

Inter-character space

A space which separates two adjacent characters, in some codes (code 39, bar code) the
spaces inside a character contain information, inter-character spaces do not.

Linear bar code

A linear bar code symbol (also known as 1D barcode) is made up of a series of bars and
spaces which contain information and check elements.

Module

The smallest thickness in a code element. In the case of linear bar codes, it constitutes
the measurement unit of the thickness of wide elements. In the case of 2d codes, it is a
single cell, which represents a bit in the code representation. It is represented by a
square.

Quiet Zone

The blank spaces immediately preceding the start character and following the stop char-
acter.

Print ratio

In two thickness codes, it is the ratio between the thickness of the wide element and
that of the narrow one.

Stacked code

A symbol that is broken into sections and "stacked" one upon another similar to sen-
tences in a paragraph. Extremely compact codes.

Two-dimensional codes (2D codes)

A two-dimensional code (also known as matrix code) is built on a true 2-D matrix. It is a
two-dimensional way of representing information and contains information in both the
vertical and horizontal directions.
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About linear bar codes

A linear bar code symbol (also known as 1D barcode) is made up of a series of bars and
spaces which contain information and check elements. Bars can be all same length or
have some of them longer protruding the bottom part as in EAN codes.

In Linear symbologies there are also the Postal Codes can be distinguished by bars dis-
posed always the same interval, same width but different bar heights (up to 4) like the
Royal Mail code shown here below.

The following shows the EAN 8 linear bar code and the Royal Mail code:

Y TR

12345678
The following represents the structure of a bar code symbol:

I alh

e Y:Thickness of the wide element
e X: Thickness of the narrow element
e Q: Thickness of the blank overflow zones at the end of the label (quiet zones)

Available linear bar codes in Laser Editor

The Encoding Type property of the Code allows selecting the desired code from the
dropdown list:

For further information on properties, and for a description of the available
codes, select the Encoding properties title and press F1 to display the rele-

vant Help topic.
NOTE pop

Bar codes with two thickness

Bars and spaces of code 20f5 or 39 can just assume two thicknesses, in a print ratio
between 2 and 3, which is the standard-compliant ratio. To set this parameter use the
Advanced > Print ratio property in the code's Property. (See "Codes properties" on page
78).

There are other codes in this category (Codabar, code 32, etc.), but their print ratio is
fixed.

Bar codes with multiple thickness

There are many code symbologies whose bars and spaces can assume more than two
different thickness. Some examples of them are EAN, UPC, code 128, code 93, DPD
code, etc..
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Postal codes

This kind of symbologies is built with same bars having same width but varying height.
Bars are regularly interspersed since also the the distance of consecutive bars equals
the bar width.

Where bars have two different heights (short and long bar), they share the same base
line, growing bottom up. Examples are US Postal, CEPNet, Planet.

Where codes uses three different heights consist of long bars and short bars either
growing bottom up or to down, and short bars. One example is the Pharmacode 2-Track.

Barcodes with four different heights consist of long bars, medium sized bars either
growing bottom up or to down, and short bars, drawn vertically centered. Examples are
Australian Postal, Royal Mail 4 State, KIX, Intelligent Mail® Barcode, DAFT, Japanese
Postal.
Related topics:

e "Usual Codes terminology" on page 71

e "About stacked bar codes" on page 73

e "About two-dimensional (2D) codes" on page 74

e "Adding a code" on page 75

e "Setting the data restoring capability" on page 75

e "Balancing the black and white ratio" on page 77

e "Codes properties" on page 78

About stacked bar codes

Stacked bar codes are a compromise between true 2D barcodes and linear codes and
are constructed like a layer cake of barcodes stacked on top of the other. These are
extremely compact codes.

Codablock-F and PDF 417 are examples of stacked bar code, where a long symbol is bro-
ken into sections and "stacked" one upon another similar to sentences in a paragraph.

See picture below:
|I|IIIIIIIIIIIIIIIIIIIIII” | [
TN N RN (N (RN ,‘
12345678

In particular, PDF 417 has error correction capability that allows restoring data if the
code is dirty or damaged. For further information, see "Setting the error correction level"
on page 77.

Available stacked bar codes in Laser Editor

The Encoding Type property of the Code allows selecting the desired 2D Code from the
dropdown list:

For further information on properties, and for a description of the available
codes, select the Encoding properties title and press F1 to display the rele-

vant Help topic.
NOTE pfop

e "PDF 417" on page 89

e "MicroPDF417" on page 85

e "Codablock F" on page 81

e "GS1 DataBar (RSS-14)" on page 84
e "GS1 DataBar Limited" on page 84

e "GS1 DataBar Expanded" on page 84
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About two-dimensional (2D) codes

A two-dimensional (2D) code (also known as matrix code) is built on a true 2-D matrix. It
is a two-dimensional way of representing information whose primary advantage is the
ability to encode a lot of information in a small space.

A 2D code contains information in both the vertical and horizontal directions, whereas a
bar code contains data in one direction only.

Information encoded in a 2D matrix code symbol, can be recovered even if the mark is
damaged and missing a portion. This capability depends on how much redundant infor-
mation your code contains and on the error correction level (see "Setting the data
restoring capability” on page 75).

Matrix codes are made up of a pattern of cells that can be dot, square (as in the Data-
matrix 2D code here below), hexagonal or circular in shape, like the MaxiCode code

shown here below:
L
Available 2D codes in Laser Editor

The Encoding Type property of the Code allows selecting the desired 2D Code from the
dropdown list:

B For further information on properties, and for a description of the available

AN

codes, select the Encoding properties title and press F1 to display the rele-

vant Help topic.
NOTE P Top

e "Datamatrix" on page 88
¢ "QRcode" on page 89
e "MicroQRcode" on page 90
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Adding a code

To add a code:

Create or open a document to enable the insertion of objects (see "CREATING
GRAPHIC LAYOUTS" on page 26 or "Opening existing layouts" on page 43).

Do one of the following:
- On the vertical toolbar click on the #) Insert objects button and then, in the
horizontal toolbar that is displayed, click on % Code.
- From the Laser Editor menu bar, choose Actions > Insert > Code.

The Code is displayed in the work area. By default, the last code type is used but at
first installation the linear bar code type 128 is displayed. To change the symbol, in
the Property browser: under Code symbol, select Encoding > Type, then choose
from the dropdown list the option that best fit your requirements. (See "Codes
properties” on page 78 for more information on the available codes).

Use the Properties window to set other code parameters, and the mouse and
toolbars buttons to operate on it.

tools" on page 6.

B Or a quick-reference on using toolbars in Laser Editor, see "Using toolbars

NOTE

Clicking a properties title in the Properties window and then pressing F1,
opens a table with a description of those properties.

For further information on how to operate on objects, see "“Common opera-
tions on objects" on page 119.

Setting the data restoring capability

Information encoded on 2D codes can be recovered, even if the mark is damaged and
missing a portion.

This capability depends on how much redundant information your code contains and on
the error correction level that you set. Greater redundancy and higher error correction
level result in a greater recovering ability, but impact code dimensions and, conse-
quently, the marking time.

Note that PDF 417, which is a stacked codebar, has error correction capabilities.

For further information:

SOUATALOGIC
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"Setting the error correction level" on page 77
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Setting the level of redundancy for 2D Codes

Please consult the "Barcode Reference.pdf" for specific information about
each simbology supporting this feature.

NOTE
In the case of 2D Codes you can set different codes dimensions, that is, you can specify
how much redundant data your code can contain.

2D Codes range from smaller to larger versions. Each version has a different number of
modules. Note that, as the amount of data increases, more modules are required to
comprise the code, resulting in larger code symbols.

You can use the Size property in the code's Property browser to determine the dimen-
sions of the symbol so as to suit your redundancy needs. (See "Codes properties" on page
78).

To set codes dimensions:
e Select the code in the document. The Property browser is displayed for the code.

e Under Encoding, in the Code properties group, select from the Size dropdown list
the desired value. Note that the Best Fit options correspond to the minimum size
for the information to be encoded.

The following figure shows a range of sizes in the case of a QRCode:

QRCode

Version 3

Best Fit (Version 1) E qr.r E
E%E SELg
Rk il
A o ,'_r,,';‘i
= [Elnest
21x 21 modules 29 x 29 modules 65 X 65 modules
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Setting the error correction level

This option applies to Two-dimensional codes (2D codes) and some others.
Please consult the "Barcode Reference.pdf” for specific information about
each simbology supporting this feature.
NOTE gy supp g
The error correction capability allows restoring data if the code is dirty, damaged or par-
tially unavailable. Many codes allow setting different error correction levels.

Different error correction levels are available for users to choose according to the oper-
ating environment (the amount of data that needs to be encoded, the size and the
amount of symbol damage that could occur), each corresponding to a different data res-
toration rate for total codewords. Raising this level improves error correction capability
but also increases the amount of data and QR Code size.

You can use the Error Level properties in the Property browser to set the error correc-
tion. (See "Codes properties" on page 78).

To set the error correction level:
e Select the code in the document. The Property browser is displayed for the code.

e Under Encoding, in the Code properties group, select from the Error Level drop-
down list the desired value.

Balancing the black and white ratio

This capability allows adjusting the ratio between white and black elements when mark-
ing very small elements.

This feature is also referred as "Bar Width Reduction" (BWR), "Bar Width Correction"
(BWC), "Pixel Shaving".

In this case, the dimensions of the spot might have an effect on the black and white
dimensional ratio and you might need to balance the ratio. The engraving elements
(black) must be identical to the empty ones.

To balance the ratio:
e Select the code in the document. The Property browser is displayed for the code.
e Under Encoding, in the Code > Advanced properties group, set the Black/White
ratio value to the desired percentage. The default is 100%, meaning that black and
white elements are identical.

e Set alower percentage to compensate the dimension of the spot laser.
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Codes properties

The Properties window supports context-sensitive Help: During layout editing, selecting
a properties title (for example, Geometry), and then pressing F1, opens the context Help
for those properties.

The following properties appear when a Code is selected in the work area.

7

NOTE

Refer to section "Common operations on objects" on page 119 for further
information on how to use properties to perform specific operations on the

object.

Refer to "Usual Codes terminology" on page 71 for a description of the

technical terms.

Group

Property Values

Description

Text

The string to be engraved in the TEXT field of the
code, or the value which represents it (see "Using
special character sequences” on page 61)

Encoding

Type

Represents the encoding type

128

Linear bar code with multiple thickness. It is used
for alphanumeric or numeric-only barcodes, vari-
able length. It is the default value. It can host
GS1-128 standard. It is a modern high-density
symbology and was invented 1981 by Computer
Identics. The software analyzes input data and
chooses the best suitable barcode representation
with the highest data density. This is done by so-
called "subset switching". 3 different internal
characters (=subsets) sets are used:

Code128A = Upper Case + Non-Printable Charac-
ters (ASCII 0-31)

Code128B = Upper / Lower Case + All Printable
Characters

Code128C = Numeric with doubled density
Code128 uses a built-in check digit (Modulo 103).
This check digit is part of the code and cannot be
omitted. It is never printed in the human readable
text. Scanners are checking it when reading a
code but do not deliver the check digit to con-
nected systems
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2/5

Linear bar code with two thickness. It is a
numeric-only barcode

Subtype

Standard

This is a self-checking code. It is used for indus-
trial applications, article numbering, photo devel-
opment, ticketing

Industrial

As above, but with a different Start/Stop charac-
ter encoding

Interleaved

Code 2 of 5 Interleaved is in wide-spread use
(article-numbering, industrial applications). This
self-checking code offers high data capacity due
to encoding pairs of numbers (the first digit is
encoded in the bars, the second in the spaces).
Thus, this symbology can encode only an even
number of digits. If the number of digits is odd a
leading zero will be inserted automatically

IATA

This is a self-checking code. Start/stop-charac-
ters are identical to Code 2 of 5 Industry. It sup-
ports distance reading (>1m) and can be printed
with very simple printing techniques. It is used for
baggage handling in air-transport applications
(International Air Transport Agency = IATA)

Datalogic

This symbology is proprietary variant of Code 2 of
5 Standard

Checksum

True or False

If it is set to True, enables a terminating check-
sum code-words

3/9

Code 39 is in heavy use in industry, organizations
and commerce. It was developed 1974 by INTER-
MEC and got standardized by ANSI MH 10.8 M-
1983 and MIL-STD-1189.

Linear bar code with two thickness. It is a self
checking, medium density, alpha-numeric bar
code, variable length

Subtype

Standard

Encodes 43 characters: A-Z, 0-9, space, and -.$/
+%.

Full

This version is rarely used because Code 128
offers much better compression. It uses the same
symbology as Code 39 but encodes also lower-
case letters and special characters ("+A" results
in a lower case "a" when scanned). Scanner must
be configured correctly for decoding Code39 Full/
Extended

LogMars

This is a special variant of Code 39 used by the
U.S. Department of Defense. This standard
defines acceptable ranges for a number of vari-
ables, include density, ratio, bar height, and size
of the human-readable interpretation line. The
modulo-43 check digit, which is optional for Code
39, is defined and recommended in the specifica-
tion

Checksum

True or False

If it is set to True, enables a terminating check-
sum codewords
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93

Code 93 was invented 1982 by INTERMEC to
achieve better information densities (compared
to Code 39). Code concatenation is possible (if the
first encoded character is a space subsequent
barcodes are concatenated by the scanner)

Standard

Encodes 43 characters: A-Z, 0-9, space, and -.$/
+%

Subtype
Extended

Based upon Code 93 but encodes the complete
ASCII character set. One of the four available con-
trol characters is used to shift into the ASCII-
character table

Australian Post

This barcode is used by the Australian Post for
marking shipments. Special code variants are
available for redirections, replies and so on

Customer

The barcode height is between 4.2 mm and 5.8
mm. The module width should be adjusted to
0.47 mms. Usual no readable text is displayed.
The length will depend on the use of additional
bars (code variants Customer 2 and Customer 3)

Customer 2

Subtype

This is the same barcode as the Australian Post
Standard Customer, but with additional 5 charac-
ters for customer specific data. The first 8 charac-
ters must be digits. This symbology is also called
Australia Post 52-CUST (Due to its 52 bars)

Customer 3

This is the same barcode as the Australian Post
Standard Customer, but with additional 10 char-
acters for customer specific data. The first 8 char-
acters must be digits. This symbology is also
called Australia Post 67-CUST (Due to its 67 bars)

Redirect

If selected, the code can contain up to 8 digit

Reply Paid

If selected, the code can contain up to 8 digit

Routing

If selected, the code can contain up to 8 digit

Aztec Code

Aztec Code can encode from small to large
amounts of data with user-selected percentages
of error correction. The symbol size adjusts auto-
matically depending on the amount of input
data.The input data is always analyzed and the
appropriate encoding mode is chosen automati-
cally. Mode switching is done as required to pro-
duce the most efficient encoding

Brazilian CEPNet / Brazilian
Postal Code

This code is used by the Brazilian Postal Services.
An 8 digit ZIP-code is encoded.The check digit is
calculated automatically. It cannot be specified in
the input data. The barcode height should be
adjusted to 3.2 mms; the module width to 0.423
mms; usually no plain text is displayed. The
encoding is based on US Postal codes

Codabar

The characters "A", "B", "C", and "D" are useable
as start or stop characters only. The barcode uses
2 element-widths and 4 different start/stop-char-
acters (A, B, C, and D). These start/stop charac-
ters can be utilized for additional information -
e.g. "B1234B". The print ratio should be in the fol-
lowing range: 1:2 -1:3 (Pr >= 2.25:1). Since the
symbology is "self-checking" there is no estab-
lished check sum method
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Codablock F

Is de facto a "stacked" Code128 symbology. It is
based upon Code 128 - each row is a single Code
128 symbol extended with row indicator informa-
tion and additional check digits. The UCC/EAN/
GS1 format indicator is supported

Code 11

This symbology is mainly used in telecommuni-
cations for marking equipment and components.
It was invented in 1977 by INTERMEC. It is similar
to Code 2 of 5 Matrix. The symbology is not self-
checking therefore 2 check digits are recom-
mended. Code 11 is a high-density code, but
requires also a high-density output device (mainly
because of the print ratio utilized)

Code 32

It is used by the Italian Pharma Industry. The code
is also called Italian Pharmacode. The Code 32
number, consisting of 9 digits, is converted to an
equivalent Code 39 Barcode of é characters. The
letter the human readable text is prepended by
"A" which is not encoded

DAFT code

DAFT Code is no symbology. It is a technique to
generate arbitrary postal codes (like for instance
the Australian Postal Codes or the Royal Mail 4
State code)

Deutsche Post

This symbology is used by Deutsche Post

Leitcode
Subtype

The code is basically a Code 2 of 5 Interleaved
enhanced with a special check digit calculation. It
is used for encoding the ZIP-Code, Street and
number of the shipment

Identcode

The code is basically a Code 2 of 5 interleaved
enhanced with a special check digit calculation
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Dotcode

DotCode is 2D dot code symbology designed to be
reliably readable when printed by high-speed ink-
jet or laser dot technologies. The encoding modes
of DotCode are based on the Code128 data
encoding (with modes A, B, and C) extended by a
so called Binary Mode. The default interpretation
for DotCode data is ECI 000003 representing the
Latin-I character set. The DotCode symbology
does not have absolute capacity limits, but a
maximum symbol size of 124x124 dots is recom-
mended

Subtype

Auto Discrimi-
nate

If the data starts with 2 digits, barcode has GS1
format, otherwise generic format is used

Generic Format

Barcode data does not fulfill any special format, if
it starts with 2 digits, FNC1 is inserted

UCC/EAN/GS1

The internal data must start with 2 digits and has
to apply to a format of an so-called application
identifier

Industry

A peculiar industry format, which adds FNC1 at
2nd position

Macro 05

The data is prefixed with "[)>" + RS + "05" + GS and
suffixed with RS + EOT

Macro 06

The data is prefixed with “[)>" + RS + "06" + GS and
suffixed with RS + EOT

Macro 12

The data is prefixed with "[)>"+ RS +"12" + GS and
suffixed with RS + EOT

Custom Macro

The data is prefixed with "[)>" + RS and suffixed
with RS + EOT; the rest of the format specifier has
to be encoded by the user

Reader Pro-
gramming

The barcode data is used to program the barcode
reader

DPD

DPD Code is used by Deutscher Paket Dienst. It is
based on Code 128 and is limited to 28 encoded
characters. The encoded data and the human
readable text differ slightly
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Linear bar code with multiple thickness. It is a
self checking, numeric code.
This symbology is reserved for the European Arti-
cle Numbering (EAN).
EAN The number is maintained by EAN and encodes
manufacturer and product.
The check digit is calculated automatically if not
specified in the input data (that is when only 7
digits are used for creating the code)
If selected, the code can contain up to 8 digit
8 numeric.
It's used for marking small articles with
restricted space
This symbology extends EAN-8 with 2 add-on
digits which are mainly used for encoding the
price or the weight.
8+2 This symbology is also used for bar-coding
paperbacks or newspapers. In this case a 2(3)
digits country code and a 4(5) article code are
encoded
This symbology extends EAN-8 with 5 add-on
845 digits which are mainly used for encoding the
price or the weight
13 If selected, the code can contain up to 13 digit
numeric
Subtype 1342 This symbology extends EAN-13 with 2 add-on
digits
This symbology extends EAN-13 with 5 add-on
13+5 -
digits
The EAN-128 code is based upon Code-128. It has
an FNC1 character at the 1st position (after the
start code). This allows scanners and data pro-
cessing software to differentiate EAN-128 from
other symbologies.
The EAN-128 code is in wide spread use (retail,
128 logistics, food and beverage, etc.). It is used for
marking transport-units in supply chains.
Besides the article-number it encodes quantities,
weights, prices, dates, and other information in a
structured way. This is supported by the use of
so-called Application Identifiers (Als) - see
"LASER ENGINE USER INTERFACE" on page
151
Text String True or False If it is set to True, displays and marks the human
readable string
Flattermarken This is a special "barcode" useq for recognizing
the correct sequence of pages in print-shops
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GS1 DataBar (RSS-14)

GS1 DataBar is used to encode the GTIN (Global
Trade ltem Number) with Application identifier
(Al) "01". The GTIN consists of a packaging indica-
tor (0..9) followed by a 12 digit number (taken
from the EAN-13 article number system) fol-
lowed by a check digit. The check digit on the 14th
position is computed automatically if not provided
in the input data

Standard

The height of the symbol should be at least 33X in
order to support omnidirectional scanning (X =
module width). TEC-IT software prefixes the bar-
code data with the Al "01" automatically - do not
provide the Al 01 with your input data

Truncated
Subtype

This symbology is similar to GS1 DataBar but the
height should be at least 13X. Omni-directional
scanning may not be possible

Omni Direc-
tional

This symbology is similar to the GS1 DataBar
Stacked and supports omnidirectional scanning

Stacked

This symbology is similar to GS1 DataBar, but it is
split into 2 rows to make the symbol smaller. It is
used for pharmaceutical packaging. Omni-direc-
tional scanning is not possible

GS1 DataBar Limited

This symbology is similar to GS1 DataBar, but it is
smaller in size and limited to a packaging indica-
tor (first digit) 0 or 1

GS1 DataBar Expanded

This is a variable length symbology. It encodes up
to 74 numeric or 41 alphabetic characters. Data
should be encoded with Application Identifiers
(Als). Omni-directional scanning is possible

Han Xin Code

Han Xin Code is a 2D matrix symbology which is
used for encoding large amounts of data and pro-
vides a special support for encoding Chinese
characters (character set GB18030)

HIBC

HIBC bar codes are commonly used by the health
industry. HIBC standards do not really describe
unique symbologies, but a family of data struc-
tures. These data structures may be represented
by several symbologies.
There are two categories of HIBC:

« Label Identification Code (LIC) - specified

by the Supplier Labeling Standard
o Provider Applications Standard (PAS)

ISBN

ISBN is the abbreviation of International Standard
Book Number. It uses the symbology EAN-13 and
can be optionally extended with 5 Add-On Digits.
The add-on is used for additional pricing informa-
tion. For more information, please refer to http://
www.isbn.org

ISMN

SMN stands for International Standard Music
Number. The ISMN is a standardized international
code, which identifies printed music.

The ISMN is preceded by the digits 9790. The
ISMN (=EAN-13) check digit is calculated and
appended automatically!

For more information, please refer http://
www.ismn-international.org/
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ISSN

ISSN stands for International Standard Serial
Number. The ISSN is a standardized international
code, which identifies any serial publication inde-
pendently of its country of origin, its language or
alphabet, or its frequency, medium, etc.

The ISSN is preceded by the digits 977. The check
digit of an 8-digit ISSN code (the last of the 8 dig-
its) must be omitted! A two digit price code,
almost always "00", is added to the end. Finally
the EAN-13 check digit is added.

Optionally the issue number can be appended as
2-digit add-on.For more information, please refer
to http://www.issn.org

Italian Postal

Italian Postal Code 2 of 5 is based upon Code 2 of
5 Interleaved, but it is limited to 12 digits (11
usable digits + 1 modulo 10 check digit)

Japanese Postal

This code is used by the Japanese Postal system.
You can encode 7 digits followed by block and
street number (uppercase alphanumeric). The
special compaction mode of Japanese characters
can be enabled on demand (Format parameter
"J"). This barcode symbology supports two meth-
ods to provide the barcode data (with and without
data-extraction from the Japanese Address B
Field)

KIX

This code is used by the Dutch Postal system

Korean Postal Authority

This code is used by the Korean Postal system.
Encoded are a 6-digit ZIP and 1 check digit

MaxiCode is in use (and was invented) by UPS®.

MaxiCode represents data by drawing hexagonal
items, which are arranged around a circular cen-
ter (a so called "Bull's Eye"). Different encoding

modes for including postal information (SCM) can

MaxiCode be adjusted: UPS Modes are Mode 2 (US Carrier)
and Mode 3 (International Carrier).
The printing size is usually set to a fixed value. If
you want to change the size of the symbol, adjust
a custom module width (default is 0.870 mm)
Mode 4 - SEC/
Standard Error  |The internal data structure is regulated by differ-
Correction ent "modes". For standard purposes, data can be
Mode 5 - EEC = |encoded with two different error correction levels
Subtype Enhanced E.C.
Mode 2 - SCM | The modes for "Structured Carrier Message"
numeric (SCM) were defined by the parcel transport ser-
Mode 3-SCM |vice UPS®. If you want to use MaxiCode for UPS,

alphanumeric

please use these SCM modes

MicroPDF417

This stacked 2D symbology is used to encode
large quantities of data. The input data is always
analyzed and the appropriate encoding mode is
chosen automatically. Mode switching is done as
required to produce the most efficient encoding

MSI

The MSI-Code is a variant of the Plessey-Code.
MS| uses various check digit calculation methods
- Lighter implemented the 2 most common used
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NVE-18

NVE stands for "Nummer der Versandeinheit" (a
German term for tracking number). This code
uses an EAN-128 symbology with a prefixed
Application Identifier (Al) 00. The Al "00" is
inserted automatically and must not be included
in the input data. It is similar to SSCC-18

Pharmacode

This code was invented by Laetus®. It is used in
pharmaceutical areas

One-Track

Subtype

The data for the bars/spaces is encoded directly in
the property Text:

o “0"is used for a narrow bar (the width of
these bars are enlarged after a color
change, according to ratio 1C)

e "1"is used for a wide bar (the width of
these bars are enlarged after a color
change, according to ratio 2C)

e "b"isused for a narrow bar

o "c"isused for a wide bar

Two-Track

Pharmacode assigns numeric values to the bars.
It is used for medicine packing in pharmaceuti-
cally area; for small labels. Usually Pharmacode
is printed without a human readable text

Placet

This code was developed for the United States
Postal Services

12
Subtype

It is a 3-of-5 variant of the Postnet barcode

It is a 3-of-5 variant of the Postnet barcode

Plessey

Plessey code is in use primarily in libraries. It is a
pulse-width modulated code and was developed
by Plessey Company Limited in UK. The basic
encoding principle in Plessey Code was used by
MSE Data Corporation to construct its MSI bar-
code. The check digit is calculated with a polyno-
mial CRC algorithm and is always part of the
symbology

PZN Germany

PZN uses Code 39 as the base symbology. It uses
a special check digit and the human readable text
always contains the prefix "PZN-" (which is not
encoded in the barcode data)

Royal Mail

This code is a height modulated code using 4 dif-
ferent vertical bars. It is used in mass-mailing
applications (Cleanmail, Mailsort) of the Royal
Mail, United Kingdom and Singapore (also called
SinPost barcode). Encoded are ZIPs

SSCC

SSCC-18is used for encoding the Serial Shipping
Container Code. It is used for the unique identifi-
cation of trade items world-wide. SSCC-18 is
based on the GS1-128 symbology with Applica-
tion Identifier (Al) 00. The check digit is encoded
automatically if 17 digits are used for the input
data

Telepen

Telepen can encode pairs of characters only. A
pair must consist of 2 digits or of one digit and the
letter X'
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USPS

United States Postal Services

Subtype

Intelligent Mail®

This symbology is also known as
e OneCode 4CB
o USPS 4CB
o« 4-CB
o 4-State Customer Barcode
o USPS OneCode Solution Barcode

Intelligent Mail®
Package

The barcode data consists of Routing Information
and Tracking Information. The Routing Informa-
tion is optional. It is not printed in the human visi-
ble text and consists of:
o Postal Code Application Identifier (Al):
always 420
« Destination ZIP Code (5 or 9 digits)

Postnet 5

Encoded are a 5 digit ZIP-code. The check digit is
calculated automatically. It cannot be specified in
the input data.

The barcode height should be adjusted to 3.2
mms; the module width to 0.423 mms; usually no
plain text is displayed.

The newer USPS Intelligent Mail®Barcode or IM®
Barcode (4-State Customer Barcode) additionally
includes a 20 digits tracking code

Postnet 6

Same as Postnet 5, but the check digit can be
specified freely (the 6th digit). To be used only if
the check digit is already part of the input data

Postnet 9

Encoded are a 5 digit ZIP-code and 4 additional
digits.The check digit is computed automatically,
it cannot be specified in the input data.

The barcode height should be adjusted to 3.2
mms; the module width to 0.423 mms; usually no
plain text is displayed.

The newer USPS Intelligent Mail®Barcode or IM®
Barcode (4-State Customer Barcode) additionally
includes a 20 digits tracking code

Postnet 10

Encoded are a 5 digit ZIP-code and 4 additional
digits.The check digit is computed automatically,
it cannot be specified in the input data.

The barcode height should be adjusted to 3.2
mms; the module width to 0.423 mms; usually no
plain text is displayed.

The newer USPS Intelligent Mail®Barcode or IM®
Barcode (4-State Customer Barcode) additionally
includes a 20 digits tracking code

Postnet 11

Encoded are a 5 digit ZIP-code and 4 to 9 addi-
tional digits. The check digit is calculated auto-
matically. It cannot be specified in the input data.
The barcode height should be adjusted to 3.2
mms; the module width to 0.423 mms; usually no
plain text is displayed.

The newer USPS Intelligent Mail®Barcode or IM®
Barcode (4-State Customer Barcode) additionally
includes a 20 digits tracking code

Postnet 12

Same as Postnet 11, but the check digit can be
specified freely (the 12th digit). To be used only if
the check digit is already part of the input data
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VIN/FIN

VIN/FIN Code is used for vehicle identification. It
is based on Code 39, but does not contain start
and stop characters. The set of valid characters
consists of digits and upper case letters. The let-
ters "I", "0", and "Q" are not allowed because they
could be easily mixed up with the digits "0", and
"1,

VIN/FIN Code is implemented differently in
Europe and North America. Both kinds are com-
patible but the North American version is defined
more strictly. So the check digit calculation
method is only valid for the North American
implementation of the code

UPC

Linear bar code with multiple thickness. It is a
self-checking, numeric code. Checksum required

Subtype

If selected, the code can contain up to 10 digit
numeric

If selected, the code can contain up to 6 digit
numeric

Text String

True or False

If it is set to True, displays and marks the human
readable string

Datamatrix

Two-dimensional matrix code consisting of black
and white square modules arranged in either a
square or rectangular pattern.lt can encode up to
3,116 characters from the entire ASCII character
set (with extensions)

Subtype

t mode

The standard format of Data Matrix without a
special header

UCC/EAN/GS1
mode

Special format defined by UCC and EAN/GST for
encoding Application Identifiers. This format adds
the function character FNC1 at 1st position in the
symbol

Industry mode

Supports peculiar industry formats (adds FNC1 at
2nd position)

Macro 05 mode

[)>Rs05Gs is encoded at the beginning of the
code, RS + EOT is added as trailer

Macro 06 mode

[)>Rs06Gs is encoded at the beginning of the
code, RS + EOT is added as trailer

Reader Pro-
gramming

Activate the Reader Programming Mode

DP Postmatrix

Special format defined by "Deutsche Post"

Size

This property allows setting the Datamatrix size
to fix the code dimension. (For further informa-
tion, see "Setting the data restoring capability”
on page 75)

Square Best Fit

Sets the smaller squared dimension according
the information to be encoded

Rectangular

Sets the smaller rectangular dimension according

Best Fit the information to be encoded
Allows specifying a dimension that ranges from
10x10 to 48x16 10x10 to 48x48 modules for the squared size, and

from 18x8 to 48x16 modules for the rectangular
size
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QRcode

Quick-Response (QR) code is a two-dimensional
matrix code. Large capacity, small printout size,
high speed scan

Size

This property allows setting the QRCode size for
redundancy purposes. Each version has a differ-
ent number of modules. (For further information,
see "Setting the data restoring capability" on
page 75)

Best Fit

Sets the smaller dimension (21x21) for the infor-
mation to be encoded

Version 1 to 40

Allows specifying a dimension that ranges from
21x21 to 177x177 modules

Error level

Level L

7% of codewords can be restored

Level M

15% of codewords can be restored

Level Q

25% of codewords can be restored

Level H

30% of codewords can be restored

PDF 417

Portable Data File 417 (PDF417) is a multirow,
variable length, stacked linear bar code. It has
high data capacity and high density and is widely
used in the automotive industry.

A data density of up to 900 characters per square
inch is possible.

The input data is always analyzed and the appro-
priate encoding mode is chosen automatically.
Mode switching is done as required to produce
the most efficient encoding

Subtype

Standard

It has control bars on both left and right sides

Truncated

It omits the right-hand portion in order to save
space

Size

1 to 30 columns

Sets the number of data columns for the symbol

Error level

This property allows setting the error correction
level for the code, which allows restoring data if
the code is dirty or damaged. To each level corre-
sponds a higher data redundancy and a different
restoration rate. PDF 417 uses Red Solomon
error correction. (Default: Recormmended). For
further information, see "Setting the error cor-
rection level" on page 77

Recommended

This value varies depending both on the specifica-
tion and the code size

Oto8

Allows specifying a level that ranges from 0 to 8.
The recommended minimum level is 2
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RSS 14(GS1 DataBar)

Standard

Stacked linear barcode. RSS 14 (Reduce Space
Symbology) is a linear symbology that facilitates
omnidirectional scanning. It encodes 14 digits of
numerical data

Subtype Omnidirectional

It allows the full height RSS-14 (see above) to be
printed in two rows

Truncated

The height is reduced to a 13X minimum

Stacked

This is a RSS-14 Truncated two-row format

RSS Limited(GS1 DataBar)

Stacked linear barcode. It encodes a 14-digit
EAN.UCC item identification with Indicator digits
of 0 or 1 in a small symbol

RSS Expanded(GS1 DataBar)

Stacked linear barcode. Can carry up to 74
numeric or 41 alphanumeric data characters in a
single row

Size ‘1 to 11 lines

Sets the number of lines for the symbol

MicroQRcode

Two-dimensional barcode. This is a smaller ver-
sion of the QR Code standard that fits applications
that require a smaller space and use smaller
amounts of data

Size

This property allows setting the MicroQRCode
size for redundancy purposes. Each version has a
different number of modules and a higher data
redundancy. (Default: M2) For further informa-
tion, see "Setting the data restoring capability”
on page 75

Best Fit

Sets the smaller dimension (11x11) for the infor-
mation to be encoded

Version M1 to
M4

Allows specifying a dimension that ranges from
11x11 to 17x17 modules

Error level

This property allows setting the error correction
level for the code, which allows restoring data if
the code is dirty or damaged. To each level corre-
sponds a higher data redundancy and a different
restoration rate. (Default: M)

Only for M1. Only error detection

15% of codewords can be restored

25% of codewords can be restored

0
L
M
Q

30% of codewords can be restored

Module

Width

Sets the width of the module (in a linear bar code this is the small-
est thickness; in a 2D code, is the smallest square)

Height

Sets the height of the module for linear bar codes. (Not available
for Datamatrix, QRcode and MicroQRcode)
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Advanced

Black/White
ratio

It allows adjusting the ratio between white and black elements
when marking very small elements. In this case, the spot laser
might affect the dimensional ratio. The default value is 100%. For
further information, see "Balancing the black and white ratio" on
page 77

Print ratio

Only available for 2/5 and 3/9 Codes. In two thickness codes, it is
the ratio between the thickness of the wide element and that of the
narrow one. The higher the ratio, the bigger the symbol, which
impacts on the scanner's reading capabilities. Default: 200

Reverse

If it is set to True, enables the bar code engraving
in reverse. Reverse bar code engraving should
only be done on those materials where the laser
marks white or black. The bar code standard does
not include reverse coding

True or False

Quiet zone

Visible only if Reverse is set to True. Immediately preceding the
start character and following the stop character is an area of no
markings called the quiet zone. The quiet zone helps the scanner
find the leading edge of the bar code so reading can begin

Bytes Encoda-
tion

This option allows the interpretation of the text property as a bytes
stream, wherever the text is Unicode only the lower bytes are used

Counter

The Counter group enables creating a variable text that includes an incremental
counter (see "Making a text string to include an incremental counter" on page

63)
Start The minimum value for the counter
Stop The maximum value for the counter
Current The current value of the counter as it appears in the string
Step Increment value (positive or negative)
The number of times the counter will be marked before it is incre-
Cycles
mented by one step
Digit The minimum number of digits to be displayed

Custom
Formatters

Formatters are source files that are supplied with Project Editor. These files can be
used as functions libraries. Their purpose is to make it easier for developers to cre-
ate custom applications. For example, as an integrator, you might need specific
functions that these libraries provide. Formatters have a .gs extension and are
stored in the folder ...\Data\Formatters

True or False

Enable or Disable the use of a Custom Formatter file

Script

Visible only if Custom Formatters is set to True. Use to select the
Custom Formatters from a list of available files
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Verification

Accordingly with ISO /IEC TR 29158 that includes the AIM DPM-1-2006, seven qual-
ity parameters or Metrics have been defined. The knowledge of the meaning of each
quality parameter may be helpful in laser marking process tuning. Each quality
parameter is classified into grades from A to F, and OVERALL is defined as the low-
est result among all the parameters or metrics

True or false

Enable or disable the use of the Verification

Overall Grade

Allow to selects an overall grade to apply to all metrics or choose
the custom metrics

Custom Met-
rics

Cell Contrast

This parameter measures the differences
between the mean brightest and the mean dark-
est values of the symbol.

‘In laser DPM the creation of background of the
code (quiet zone) with low power settings is
extremely effective to boost the contrast

Cell Modulation

Cell modulation analyzes the uniformity of the
contrast inside the code extension.

'In laser DPM this defect is usually refers to local
non-uniformity of the material surface (i.e. finish-
ing quality, dust, oil...) incorrect marking distance
or tilted/curved marking surfaces

Axial Non-Uni-
formity

'

This parameter measures and grades the mod-
ules' squareness in the direction of each of the
symbol's major axes (X-axis and Y-axis).

'In laser DPM applications this metric is typically
affected by off-axis marking (tilted surfaces vs
laser marking axis) but also off- axis reading
(skewed reader vs target surface)

Unused Error
Correction

WE
£

Data Matrix incorporates an error correction
mechanism and data redundancy .This parameter
tests and grades how much redundant data had
to be used during reading to decode the data con-
tent. A perfect mark that requires no error correc-
tion would achieve a UEC score of 100% that
results in grade A

Print Growth

Measures the deviation of actual elements
dimension from the expected element dimension
due to printing problems (i.e. overprint or under-
print)

Minimum
Reflectance

Determines the degree to which the object
reflects light.

Accurate tuning of laser parameters like power,
speed and repetition rate dramatically influence
this quality parameter.

Fixed Pattern

This metric checks the fundamental characteris-
tics of the code (quiet zone around the code, "L"
finder and clocking patterns, and reference dots).

Damage
Poor results on this metric may reduce the capa-
@ bility to locate and read the code.

LB “— |As for "Cell Contrast", the use of a smooth uni-
form background as a quite zone reduces the risk
of low grade FPD

Grid Non-Uni-  \Thjs parameter measure and grades the module
formity

placement by comparing to a nominal evenly
spaced grid. Assuming a grid on which the ideal
angle of intersection is 90°, any angle deviation
from 90° constitutes Grid Non-Uniformity
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Using Arrays
Actions | Laser Reader Window Help
* 1 Remove object(s) Del a |\‘_3\ o l‘, 9
I Insert 4 “T Text string 2 .
Align 4 m Code &
Flip 4 @ Imported
Spading v oAy N Docu

The array object is used to mark repetitively an object (or a group of objects) in different
positions, allowing you to customize both the layout and the elements arrangement.

Graphic objects are included in cells that you can customize to suit your needs.
The array object is especially tailored to Integrated Circuits (IC) chips marking.

By using the Array toolbar button or the Actions menu, Laser Editor allows you to create
an array.

You might use the mouse to resize and move the array, or to select/deselect cells; you
can use the Properties window to set dimensions and number of cells and to define
their content, as well as misalign or change the distance between cells.

Clicking a properties title in the Properties window and then pressing F1,
opens a table with a description of those properties.

For further information on mouse operations, refer to section "Using the

NOTE mouse to select and manipulate objects" on page 121.

The following sections describe how to work with arrays:
e "Adding an array" on page %4
e "Setting the number of cells" on page 95
e "Resizing arrays or cells" on page 95
e "Changing the distance between cells" on page 96
e "Cells misalignment" on page 97
e "Selecting/Deselecting one or more cells" on page 98
e "Creating the contents of individual cells" on page 99
e "Array and cells properties" on page 101
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Adding an array

To add an array:

e C(Create a plane document to enable the insertion of the object (see "Creating a
document for plane engraving" on page 32).

¢ Do one of the following:
- On the vertical toolbar click on the ¥ Insert objects button and then, in the
horizontal toolbar that is displayed, click on g% Array.
- From the Laser Editor menu bar, choose Actions > Insert > Array.

e The Array is displayed in the work area. By default, the whole array is selected and
contains 9 cells. Use the Properties window to set the array and cells parameters;
use the mouse to resize or move the array, as well as to select individual cells.

Clicking a properties title in the Properties window and then pressing F1,
opens a table with a description of those properties.

NOTE
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Setting the number of cells

The Columns and Rows properties of the Array object, allow you to set the number of
row and columns that compose the array to obtain any number of cells.

To set the number of cells that compose an array:
e Click on the array to enable the Properties window.

e Under Array, select the boxes beside the Columns and/or Rows properties and
enter the desired number.

e The array changes accordingly. You might need to resize both the array and the
cells to fit the new settings. (See "Resizing arrays or cells" on page 95).

Resizing arrays or cells

The Dimensions and Cells size properties allow you to resize the objects as needed.

For information on other Array's general properties, select the Geometry
title and press F1 to display the relevant Help topic.

NOTE

To resize the objects:

e Click on the array to enable the Properties window.

e To resize the array: Under Geometry > Dimensions, set the Width and Height
properties as you want. (You can also use the mouse: with the object selected,
drag the handles that surround it @ ¢+ % B to the desired position.)

e To resize the cells of the array: Under Array > Cell size, set the Width and Height
properties as you want.
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Changing the distance between cells

The Pitch and Extra Pitchs properties, allow you to increase or decrease the distance
between rows, columns, individual cells and/or group of cells.

NOTE

To enable the Properties window, click on the array object.

To change the distance between rows and/or columns:
e Under Array > Pitch, set the following properties:

- X - Sets the distance between columns.

-Y - Sets the distance between rows.

To change the distance between cells or groups of cells:

You can group cells and define additional distances between them, both horizontally
and vertically.
e Under Array, select the Extra Pitchs property and enter the number of instances,
that is, the number of extra-distances you want create. The properties that allow
setting the extra pitches are displayed below.

e Set the properties values as follows (see the example below, also):

- Group - Enter the number of cells that you want to include in the group to be
moved.

- First - Enter the number of the first column you want to apply the extra pitch
to.

- Pitch - Specify the size for the additional distance.

- Direction - Select the desired direction: Y direction will add the distance
between rows, X direction will add the distance between columns.

The picture below shows how the array looks after setting the properties as follows:

- . |

e Repeat step 2 for any other extra pitch you want to add.

| Property
7

Value

4
4

6.00 x 6.00
6.00 mm
6.00 mm
12.00 x 12,00
12,00 mm
12.00 mm

0.00 mm
X direction
—

T

3

1

3.00 mm
X direction
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Cells misalignment

The Interleave properties allow you to change the alignment of rows and/or columns.

To change the alignment of cells:
Click the array to enable the Properties window.

Under Array, select the Interleave > Offset property and enter the misalignment

measurement.

From the Direction dropdown list select the desired direction:

- X - Sets the misalignment between rows.

- Y - Sets the misalignment between columns.

The picture below shows how the array looks after setting the properties as follows:

SOUATALOGIC

2

Froperty
4 Array
Columns
Rows
4 Cell size
Width
Height
4 Pitch
Width
ight

vae

4
4

6.00 X 6.00
6.00 mm
6.00mm
10.00 x 10.00
10,00 mm
10.00 mm

4 Interleave
Offset
Direction

6.00 mm
X direction

4 Extra
4 N1
Group
First
Pitch
Direction
4 Increment Counter
Rows/Columns
Left/Right
Top/Bottom
On Disabled Cells
I Geometry

i

3

1

3.00 mm

X direction

By rows
Left to Right
Top to Bottom

&

USER MANUAL 97



CREATING GRAPHIC LAYOUTS

Selecting/Deselecting one or more cells

You can operate on individual cells by unlocking the array and selecting the desired
cell(s).

To select/deselect individual cells:
e Select the array and then click the pushpin-shaped handle «= at the top left. The

handle changesto @ and the cellsinthe array becomes unlocked allowing you to
select them:

e To select one or more cells, do one of the following:
- Click one or more cells. (You can select as many cells as you want).

- Right-click a cell to display a menu that allows to select/deselect all cells, or
to invert the selection between selected and deselected cells.

- Click the rows or columns blue indicator to select/deselect the whole row or
column.

e When acell is selected and enabled, its colour changes to bright yellow. (To dese-
lect a cell, click on it).

e Furthermore, in the Properties window, under Array, the new Cells group is dis-
played that allows you to:

- enable/disable one or more cells
- define custom offset settings and rotation

- link a document to the cell (see "Creating the contents of individual cells" on
page 99)

U When a cell is disabled, its colour changes to light yellow.

NOTE
e C(Clickthe @ mouse handle to lock the cells and operate on the whole array.

For further information on mouse operations, please refer to “Using the
mouse to select and manipulate objects" on page 121.

NOTE
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Creating the contents of individual cells

You can enter any content into individual cells to compose your layout, as well as define
custom offset settings and rotation. You can create a document with graphics or strings,
and then link the document to a cell.

To create the contents of a cell:
e Click the array and then click the pushpin-shaped handle at the top left «= :
e Click to select the desired cell(s). The colour of the selected cell(s) changes to
bright yellow. Note that all cells are named Plain 0.
¢ You might set a different Plain number: In the Properties window, under Array >
Cells, select the Linked Plain property and enter a Plain ID. The Plain number of
the selected cell changes accordingly:

Top/Bottom Top to Bottom

On Disabled Cells
- - -- Cells

. ( 4 Offset (0.00, 0.00)

1| e1ain: 10 . s

h 0.00

. @ Enabled |

Rotation 2.00

Linked Plain 10
L1 ] L '

e Double-click the cell. A new document representing the Plain, with the same ID
number, opens. (By default, it would be 0, as the selected cell).

Documient1® ‘ Document1: Array | %]

e Enter any object you need, as you would do in a plain document. (See "Creating a
document for plane engraving" on page 32 and "About graphic objects" on page 51).

e When your layout is done, from the Laser Editor menu bar, choose File > Save to
save the plain as an . x1p file.

e Return to the array.

e Select the cell(s) to which you want to link the Plain you have just created. (You
might select an entire row or an entire column by clicking on the blue indicator).

¢ Inthe Linked Plain property, enter the number of the Plain that you have created.
(See step 3, above).
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The cells will be dynamically filled with the contents of the linked plain when sending
the array to laser engraving. (See "PERFORMING THE ENGRAVING OPERATION" on page

138).

e You can set custom properties for a cell using the Cells properties. The settings

appear on the cell, as illustrated below:

Property

Note that, as the Rotation angle for the cell has been set to 160, the small black indica-
tor has been moved accordingly, to indicate the rotation. (See "Array and cells proper-

ties" on page 101).
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Array and cells properties

The Properties window supports context-sensitive Help: During layout editing, selecting
a properties title (for example, Geometry), and then pressing F1, opens the context Help
for those properties.

The following properties appear when an Array object is selected in the work area.

7

Refer to section"Using Arrays” on page 93 for further information on how to
use properties to perform specific operations on the object.

NOTE
Array Group  |Property |Description
Columns Sets the number of columns for the array
Rows Sets the number of rows for the array
i Width Sets the width for all cells into the array
Cells size _ . -
Height Sets the height for all cells into the array
. Specifies the distance between columns. You can increase or
Width .
Pitch decrease the distance
. Specifies the distance between rows. You can increase or
Height .
decrease the distance
Offset Sets a misalignment between rows or columns
Specifies the direction for the misalignment:
Interleave o .
Direction o X - Sets the misalignment between rows
e Y- Sets the misalignment between columns
Represents the number of cells to be considered for the extra
Group .
pitch
First Indicates the first column to which the extra pitch will be applied
Extra Pitchs Pitch Sets the additional distance
Sets the direction for the extra pitch:
Direction « Ydirection will add the distance between rows
«  Xdirection will add the distance between columns
Rows/Col- |Determines whether the counter increase is done by rows or
umns columns direction
Left .to Right Determines whether the counter increase is done by Left to
or Right to . . o
Right or Right to Left direction
Increment Left
Count N
ounter Top to Bot Determines whether the counter increase is done by Top to Bot-
tom or Bot- S
tom or Bottom to Top direction
tom to Top
On Disabled |Determines whether the counter increase is done even by Dis-
Cells abled Cells or not
This group of properties is displayed only after selecting one or more individual
cells. (See also "Creating the contents of individual cells" on page 99)
Sets the marking offset for the selected cell(s):
Offset » X -Sets the horizontal offset
e Y- Sets the vertical offset
Enabled Enables/disables the selected cell(s)
Cells Rotation Applies a rotation angle to the selected cell(s)
Allows linking a document with specific contents to the selected
cell(s). Double-clicking the cell will result in a document opening
. . |with the same Plain ID as the selected cell. You can treat it as a
Linked Plain

document and then link it to as many cells of the array as you
want. (For detailed instructions, see "Creating the contents of

individual cells" on page 99)
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Importing graphic objects

Actions | Laser Reader Window Help

¥ Remove object(s) Del (] ‘ Q 2 i "Ii’ 9

Insert T Textstring

Align

Flip Imported

4
4
»
4

Spacing :_:1_; Array

By using the Imported toolbar buttons or the Actions menu, Laser Editor allows import-
ing two dimensional graphics.

Supported file formats

Laser Editor allows importing and editing the following graphic formats:

7

NOTE

Vectorial:

- HPGL 1/2 (. PLT and .HPGL) - Vectorial formats were originally conceived
plotters treating, so they include plotter's specific features (such as, the line
width), which the laser does not consider. Please note that there is not an
automatic adjustment of the spot laser as the plotter's pen changes.

- AutoCad DXF - Two dimensional vectorial graphic exchange format that was
originally developed by Autodesk, and then disclosed to the public. However,
it is still maintained by Autodesk that periodically updates it.

- AutoDesk DWG - Vectorial graphic format licensed by Autodesk. It is a file
format used for storing two and three dimensional design data and metadata.
It is the native format for several CAD packages.

For AutoCAD .DXF and .DWG graphic formats, new filter configuration
options have been added that allow selecting how to process the file. For
further information, see "Setting the Filter Options (DWG and .DXF files)" on
page 106.

For all vectorial objects, new advanced processing options have been
added that allow the automated editing of vectors. For further information,
see "Using Advanced Processing options" on page 107.

¢ Image files (bitmap):

- BMP, is the standard format for bitmap graphics. It can be generated with
any graphic application, from digital cameras or scanners.

- GIF, is a format similar to BMP. It can be generated with any graphic applica-
tion, from digital cameras or scanners.

- JPG, is one of the most common compressed bitmap formats. A BMP image
converted into JPG has a much smaller (in bytes) dimension.

- PNG, is an extensible file format for the lossless, portable, well-compressed
storage of raster images, that is, PNG files are compressed bitmaps.

- TIF, a common format for exchanging raster graphics (bitmap) images
between application programs, including those used for scanner images.

e Laser documents (. XL.P) - Engraving graphic layouts generated by Laser Editor.
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You can use the Properties window, the toolbars tools, or the mouse to resize, move,
rotate, and transform the imported graphic so as to fit the object to be engraved.

B For information on mouse operations, see "Using the mouse to select and

NOTE

manipulate objects" on page 121.

For information on how to operate on graphics, please refer to "Common
operations on objects" on page 119.

Clicking a properties title in the Properties window and then pressing F1,
opens a table with a description of those properties.

The following sections describe how to work with imported graphics:

SOUATALOGIC

"Raster graphics vs. Vectorial graphics" on page 104
"Importing a file into Laser Editor" on page 105

"Setting the Filter Options (.DWG and .DXF files)" on page 106
"Using Advanced Processing options" on page 107

"Imported graphics properties" on page 110
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Raster graphics vs. Vectorial graphics

Laser Editor allows editing and importing two dimensional vectorial graphics and also
importing and editing bitmap graphics created with other applications.

About raster graphics
Raster graphics describe images using coloured dots, called Pixels, located within a grid.

The image is described by the specific position and colour of every pixel in the grid, and
the creation process is very similar to that of a mosaic.

When you edit a raster graphic, the pixels are edited rather than the lines and curves.
The raster graphics change with resolution, as the data which describes the image is
fixed in a grid with specific dimensions. Editing raster graphics can change their quality.
In particular, resizing may make the edges of the image irregular since the pixels within
the grid are redistributed. In addition, displaying raster graphics on an output device
with a lower resolution in relation to the image reduces the display quality.

About vectorial graphics
(.plt, .hpgl, .dxf, .dwqg)

Vectorial graphics describe the images using lines and curves, called vectors, which all
include properties related to color and position. The image is described by points
through which lines pass, creating the form of the outline. (Note that laser engraving is
monochromatic.)

Raster vs. Vectorial marking
Raster

The raster engraving technique allows marking a vectorial object as if it were a raster
object. The image is split into rows and rows are marked sequentially, as the laser
brushes the image across the surface in a back-and forth slowly-advancing linear pattern
that reminds one of an inkjet or similar printer.

The laser moves at a fixed speed and the level signal modules continuously according to
the "darkness" of the pixel being drawn. This technique can be performed only on mate-
rials whose response changes deeply with the power of the investing beam; polycarbon-
ate and PVC can behave this way with the use of proper additives, while metal cannot.
In general, raster engraving on plastic cards produces best results.

In laser engraving, a raster graphic is slower in engraving and less defined in terms of
outline lines and filling. It can be used, with appropriate conversions, for engraving digi-
tal photographs.

Vectorial

In vectorial marking, the laser follows the lines and curve of the pattern to be engraved,
much like a pen-based plotter draws by constructing line segments from a description of
the outlines of a pattern. It traces all vectors, regardless of how the object is being
scaled.

In laser engraving a vectorial graphic is faster in engraving and more defined in terms of
outline lines and filling. A vectorial graphic cannot be used for engraving digital photo-
graphs.
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Importing a file into Laser Editor

To import a file:

e Create or open a document to enable the insertion of objects (see "CREATING
GRAPHIC LAYOUTS" on page 26 and "Opening existing layouts" on page 43).

e Do one of the following:
- In the horizontal toolbar, click on &] Imported. (If this button is not visible,
click the #) Insert Objects button on the vertical toolbar).
- From the Laser Editor menu bar, choose Actions > Insert > Imported.

e The Choose a file to import window is displayed. From the Files of type dropdown
list, choose the file you want. (See "Supported file formats" on page 102 for more
information).

e Select the file you want to import. The image is displayed in the work area.
U When you select the .DWG or .DXF file formats (AutoCAD files), the Filter

Configuration window will be displayed for you to select how to process the

file to import. See "Setting the Filter Options (.DWG and .DXF files)" on page
NOTE 106.

e Using the Properties window, the mouse, and the toolbars, you can do the follow-
ing:
- Move or resize the object (see "Common operations on objects" on page 119)
- Edit bitmaps properties (see "Imported graphics properties" on page 110)
- Link an imported file to the layout (see "Linking the imported file" on page 105)
- Fill it with filler lines (only if the lines of the imported object are closed) and

perform other operations on graphics (see "Common operations on objects" on
page 119)

- Use advanced processing functions to edit nodes of vectorial graphics (see
"Using Advanced Processing options" on page 107)

For a quick-reference on using toolbars in Laser Editor, see "Using tool-
bars tools" on page 6.

Clicking a properties title in the Properties window and then pressing F1,
opens a table with a description of those properties.

NOTE
Linking the imported file

The Linked property allows specifying the full path of the imported file. This way, at any
document's loading, the program looks for the original file into the specified path and, if
it does not find it, uses the internal copy that was created. If the original file has been
changed, or updated, the document is also updated.

e Select an imported object in the work area.

¢ In Properties window, under Imported, set the Linked property to True.

e The Linked file property is displayed that shows the full path of the imported file.

To change the path, use the browse button.
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Setting

the Filter Options (. DWG and .DXF files)

When you import a . DWG or .DXF file into the laser editor, that is, an AutoCAD file, the
Filter Options window displays for you to select how to process the file.

Imported

AutoCAD files can be strings that use specific and proprietary fonts, which

might not be available in your system. Using these options you can fix this issue, as well
as process the layers of the original file as groups of editable objects.

To set the filter options:
e Clickthe &) Imported icon in the toolbar and then select AutoCAD DXF/DWG
files as the File Type.

e Select the file to import and click Open. The following window is displayed:

™, Fitter C i 15 o]
AUtoCAD DXF files (.dxf)
Import strings as vectors [
Default fant
Process layers as groups  [¥]
Import hatches

| [ ] [ Cancel |

e Select the proper options, taking in mind that:

7

NOTE

- Import string as vectors

If it is set to False (default) strings will be imported as strings. In this case, if
the original font is not available, an error or a warning could be returned. To
fix this problem, use the Default font option and specify a default font.

If it is set to True, strings will be imported as pure vectorial objects, that is,
they will not be strings objects anymore.

- Default font - It allows selecting from the dropdown list the font that must
be used if the original one is not available.

If you imported the strings as strings (Import strings as vectors = False),
and set a Default font other than the original, the resulting layout might
shows differences in terms of space or objects alignment. To fix this type
of problem, do the following.

Review the import result for problems.
Import the object again setting Import as vectors to True.

Compare the results and change the font properly, until achieving the desired
result. If necessary, import the required font in your system (see "Importing
fonts" on page 60).

- Process layers as groups - Typically, AutoCAD files are composed by more lay-
ers each containing different information. For example, in a mechanical draw-
ing, the notes might be on a layer, while technical data might reside on other
layers. If this option is set to True (default), the layers will be transformed into
groups of objects, which will be grouped layer by layer. This allows managing
and operating on layers, as well as adding specific properties.

e When finished, click OK. The object will appear on your document.

¢ To edit the vectors in an automated way, see "Using Advanced Processing options"
on page 107.
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Using Advanced Processing options

The Advanced Processing options provide vectorial processing functions that allow edit-
ing vectors in an automated way. It is used if the original document does not satisfy your
marking requirements, or if it shows graphic problems that result in marking imperfec-
tions.

You can make vectorial the imported object so as to check its polygons and then use

these functions to fix problems such as not closed or double polygons, before sending
the document to mark.

These functions are available for vectorial objects (. PL.T, . HPGL, .DXF, .DWG).

Step 1 - Make the object vectorial and check nodes:
e Select the imported object and then do one of the following:

- From the menu bar, choose Actions > Make vectorial.

- On the vertical toolbar, click () Object operations and either click (5 Make
vectorial or % Ungroup selection in the horizontal toolbar.

e Double-click the object to display the vectors nodes, and then check if polygons
are properly closed or if there are double lines that overlap each other. (For fur-
ther information on how to open, view, and edit nodes, see "To edit nodes:" on
page 122).

The following shows an example of a .DXF imported file that shows these type of
imperfections. On the left you see the object as it was imported, while on the right the
same object has been made vectorial, as above described:

Ry 41 4 e

/j/_‘ e /////~_ R — ////:il, T S— //’/;:j ..... :
. r} """ T % | e —
\\\ \ | \\\, \\\j\ | \\\ \\ o
S DS I N

At a first sight, it does not show problems. But if you open the nodes, by dragging the
small grey squares, problems will appear:

Not closed polygons

pouble polygons
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These problems will result in marking imperfections.

To exit the Edit nodes operating mode press ESC.

NOTE

¢ Insuch a case, you can use the Advanced Processing functions to edit polygons
automatically.

Step 2 - Automatically edit vectors to correct imperfections:
e Select the object and then do one of the following:

- From the Actions menu, select Advanced Processing.

- On the vertical toolbar, click () Object operations and then [7] Advanced
Processing.

The following will be displayed:

\
™ Filter Options ===

Sort Edges & Close Polygons =

Sort Edges & Close Polygons
Join Open Palylines
Split in polygons

There are three options that you can use in association:

e Sort Edges & Close Polygons - It operates on areas: it tries to locate areas that are
enclosed into polygons and then close them eliminating any double line.

e Join Open Polylines - It operates on the distance between nodes and it tries to
close them at the maximum distance. That is, it tries to join polygons that are near
enough and then close them.

e Splitin Polygons - It allows dividing a vectorial object into individual polygons.
This is particularly suitable in the case of an imported object that is made of more
polygons, placed on different layers: using this option you can see how objects are
grouped on each layer, ungroup them, and then operates on polygons separately.

Example of usage

Let's take our example of imported object above to describe how the Advanced Process-
ing options can be used in association to fix all problems.

e Select the object and then from the Actions menu, select Advanced Processing
(orclick ) Object operations on the vertical toolbar, and then [[7] Advanced Pro-
cessing).

e Apply the first option Sort Edges & Close Polygons, which, by operating on areas,
should remove any double or not closed polygons.

However, the result is still not as expected as it shown in the following picture:

8
\
.

N\

(7

e Click & Undo, or press CTRL+Z, to cancel the operation.

e From the Actions menu, select Advanced Processing again and then apply the
second option Join Open Polylines.
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e Apply afilling: From the Filling properties dropdown list, select Single line:

e It seems working, but let's check the nodes: Click ¢y Undo to cancel the filling,
make the object vectorial by double-clicking and check the nodes:

As you can see in the example above, there are still double polygons, which would result
in marking problems if you apply, for example, the Islands filing, which requires per-
fectly closed and well prepared polygons.
e Tryit: from the Filling properties select Islands and then select Mark Preview
from the File menu. This is how the marking would result:

* Press ESC to exit the Mark preview mode and then click <3 Undo to cancel the fill-
ing.

e From the Actions menu, select Advanced processing.

e Apply the first option again, Sort Edges & Close Polygons to remove all double
lines.

e Make the object vectorial by double-clicking it and check the nodes again. All
nodes will now be closed and double lines will not exist anymore.

e To check the marking results, apply the fillings again and then select Mark pre-
view from the File menu. The following pictures show the results of both fillings:

Marking result with Single line filling
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Marking result with Pocketing filling

The object will now be marked as expected, showing closed and well-oriented polygons.

Imported graphics properties

The Properties window supports context-sensitive Help: During layout editing, selecting
a properties title (for example, Geometry), and then pressing F1, opens the context Help
for those properties:

Refer to section "Common operations on objects" on page 119 for further
information on how to use properties to perform specific operations on the
object.

NOTE Refer to section "Importing graphic objects" on page 102 for more informa-
tion on imported objects.
Group Property |Description
Brightness |lt allows adjusting the brightness of a bitmap
Contrast It allows adjusting the contrast of a bitmap
Resolution It all.ows changing the resolution of the image, expressed in dots
per inch
If it is set to True, specifies the reverse engraving for the
imported bitmap:
Reverse g . ﬁ m:,.m
Image l . e I
Keep Aspect ¥
_ + poston e
Gray tones - Converts the image in dithering to gray tones.
(Default)
Half tones - Converts a grayscale image to simulated halftone
Video Mode |dots. Halftones varies the size of halftone dots to simulate shad-
ing
Error diffusion - Converts a continuous tone image into a fre-
quency modulated halftone
If it is set to True, allows specifying the full path of the imported
Imported Linked file; it is_ the path that tt\e. program VYill search v.vhﬁznever the doc-
ument is loaded. (See "Linking the imported file" on page 105)
Linked file  |Shows the full path of the linked file. You might change the path
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Using the tiling function

The Tilable property is only available when editing vectorial objects on ring
documents (for further information, see "Creating a document for ring

engraving" on page 39).
NOTE g g" on page 39)

The Tilable geometry property is used when marking indivisible objects on a rings sep-
arator, that is, on a cylindrical surface.

Typically, when marking on a ring document, the laser focuses on a ring portion (sector)
to mark.

In some applications the object to mark can be longer than the sector itself. For exam-
ple, in jewellery you might need to mark the manufacturer logo, or the client's name on
a wedding ring. This might result in deformations.
By applying the tiling function:
e The object is separated into its constituting polygons.
e If a polygon its larger than the sector and it is closed (otherwise, the function
won't work). it will be "sliced" into portions whose size is equal to the ring's sec-
tors to be marked.

This way, the object will be marked as if it were an individual sector, thus resulting in
high precision marking.

The Tilable property is used in association with the Sector size and Sector gap Advanced
properties of the ring document, how it is described in the example in the following.

Example of tiling usage

The following example describes how the software operates when using the tiling func-
tion and how the ring's Sector size and Sector gap properties are to be set, accordingly
to your specific needs.

e Open a Ring document by selecting File > New > <= Ring document.

e Let's suppose that we must import the logo of a jeweller. So, click & and import
the file.

e Asthe Text string property, type the date and then set the desired Font, Style, and
Filling properties. Then, set to True the Tilable property under Geometry:

=) %

| il
N A YO ACHY 7/ g Locked i
[ Kezp Aspect ¥
; Contour [a]
& 3 Ry
! T

e Deselect the string and set the Sector Size and Sector Gap properties for the doc-
ument in order to define the sectors properties:

4 Geometry
4 Ring
Diameter 10.00mm
Height 2,00 mm
mark Insde

Margin 0,00 mm
,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, - & ] - 4 Gnd =
step 10.00mm
Snap to Grad (&
- R = prems Py

4 Advanced
Sector size 0.00mm
Sector Gap. 0.00

Reset axis at the end of execution i}
Use ring radius as Z axis position (]

e Set the properties according to your needs, keeping in mind that:

- The Sector Size property defines the width of the sector, that is, the portion
to be engraved within a single movement of the rotating axis. The object will
be divided into sectors whose size is equal to the sector's maximum size,
which it is based on the laser's depth of focus.

The 0 value (default) provides a high level of quality. A single movement will
be made for each polygon and the polygon will be centered in its belonging
sector.
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With tilable objects, you might set a value smaller than 0 for high precision
needs. Note that smaller value results in longer marking time.

- The Sector Gap property allows to further fine tune the tiling operation.

If it is set to O (default) only one cut will be used for both the left and right
objects.

If the value is lower than 0, two cuts will be used, to either overlap the poly-
gons (left and right borders), or to leave a space between them.

Note that this setting is based on the laser's depth of focus, as well as on the
mechanical precision of the rotor.

e Save your layout.
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UNDERSTANDING OBJECTS COLOUR IN THE WORK AREA

The objects in the work area can take on different colours, depending on their status or
characteristics, as illustrated in the picture:

aser Editor

Laser Editor

Laser Editor

Colour

Meaning

Red

The graphic object is NOT correctly placed within the graphic area. A
red colored object will NOT be engraved correctly

Blue

The graphic object is correctly placed within the graphic area and is
enabled for engraving. Its engraving parameters are NOT the standard
ones of the document; special laser engraving parameters have been
set which are only relative to this object (see "Custom Laser parameters
for Objects" on page 54). There can be various blue coloured objects
within the graphic area; their laser parameters may differ from each
other

Grey

The graphic object is correctly placed within the graphic area but is NOT
enabled for engraving and will NOT be engraved. (The Enable property
in the property browser is set to False)

Black

The object is correctly placed within the graphic area and is enabled for
engraving. Its engraving parameters are the standard ones of the docu-
ment
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USING GLOBAL VARIABLES

In order to view and manage global variables, you must be connected to the
laser device. For further information, see “Connecting to the laser device"
on page 147.

NOTE

This function is also accessible at the Laser Engine interface level. For fur-
ther information, please see "LASER ENGINE USER INTERFACE" on page
151.

Purpose of the functionality

Global variables are strings or counters that are stored in a small database at the device
level. You can then use special character sequences to access a global string or counter
variable and share its content between more objects or documents. (See also "Using
special character sequences” on page 61).

For example, you can use the same counter in as many strings as you need, or refer a
global string variable in any number of document(s).

To summarize, this function offers the following main advantages:

A counter is not only strictly associated to a string, anymore. You can create a
counter that is common to more strings and that is managed at the machine level.

You do not longer need to create a specific program for each document to be
engraved in order to increment a counter.

A centralized database, managed by Laser Engine, is provided. You can use it to
store, view, or edit global variables either remotely, via the Laser Editor user inter-
face, or through a project, in order to update or edit them at runtime.

Variable contents (for example the current number for a counter) are not yet
strictly connected to a specific document file. As an example, counters are auto-
matically updated after each use. Users do not need to take care of saving them
anymore: You can turn off the machine, or edit the document and, the next time
the machine is turned on, the counter will be incremented accordingly to the
value that was previously reached.

For further information on global variables management, see:

"Adding, viewing, or editing a global variable" on page 115

"Using special character sequences to associate global variables to a string" on page
117

114 LIGHTER™ SUITE

SOATALOGIC



USING GLOBAL VARIABLES

Adding, viewing, or editing a global variable

Follow this procedure to add, view, or edit global variables. You will then be able to

associate them to objects by using special character sequences.

e Be sure that you are connected to the laser device (see "Connecting to the laser
device" on page 147).
e Do one of the following:

- From the Laser Editor menu bar, choose Laser > Edit device global variables.

- On the Laser Editor toolbar, click [ Edit device global variables.
e The Device variables is displayed for you to add or manage variables remotely.

To add a global variable:

e In the Device variables window, do the following:

- Click on Add new counter to add a counter variable type.

- Click on Add new string to add a string variable type.
The new variable will be added in the table using the default parameters.
e To edit the parameters, select the variable and then double-click the field you
want to change. Use the following table as a reference:

Table 3: Global Variables Parameters

Field ‘ Description
Counters
. The unique identifier for the counter. This is the name that is to be used into the

Variable special character sequence to refer the counter
The current value of the counter. This value will be displayed when the global

Value variable is referenced into a string object through the appropriate special char-
acter sequence

Start The minimum value for the counter

Stop The maximum value for the counter

Step The increment value (positive or negative)

Cycles The number of times the counter will be marked before it is incremented by

one step

Cycles Count

It allows keeping track of the number of markings that have been executed
within the required Cycles number. This parameter is reset to 0 when the num-
ber of engravings has been reached and the Counter has been incremented.

(It only applies if the Cycles parameter has been set to a value other than 1)

Digit The minimum number of digits to be displayed
The numeral system that the Counter will use to represents the numbers. The
following values are allowed:
e 2 -The marked number will be converted to binary form. Binary uses
only 2 digits (0 and 1) and is also called base-2. The value 10 in base 2
will be marked 1010.
o 8-The marked number will be converted to octal form. Octal uses 8 dig-
its which are 0,1,2,3,4,5,6,7 and is also called base-8. The value 10 in
Base base 8 will be marked 012.

e 10 - The number will be marked in decimal form. Decimal has 10 digits
which are 0,1,2,3,4,5,6,7,8,9 and is also called base-10. The value 10 in
base 10 will be marked 10.

e 16 - The number will be marked in hexadecimal form. Hexadecimal is
made up of 2 parts which are hex(6) and decimal(10) which are
0,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F. It is also called base-16. The value 10 in
base 16 will be marked 0A.
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Strings

Variable The gnique identifier for the string. This is.the name that is to be used into the
special character sequence to refer the string

Value The content of the variable, that is, the text string

The figure below shows an example, where one counter and two strings variables have

been added:
f —r ™
/% Global variables -
Counters oK
Variable Value  artmarkir op markir  Step Cycles Cycle Count Digits Base :J
Apply
0 993 1 1 0 3 10
Cancel
Strings
Variable Value
A

Figure Device Variables dialog

e When you are finished, click Apply and then OK to close the dialog and return to
Laser Editor.

The global variable will be saved to the device and stored into the Laser Engine-man-
aged database. You will then be able to retrieve it from Laser Editor, in order to check or
edit it.

To view, edit, or delete an existing global variable:

You can use Laser Editor to display a global variable that has been saved to the device,
so as to be able to check or edit the values.
e Be sure that you are connected to the laser device (see "Connecting to the laser
device" on page 147).
e Press the [J] Edit device global variables button on the toolbar to make the
Device variables dialog appearing that lists the variables that are currently stored
on the device.

e Do one of the following:

- To edit the parameters, select the variable and then double-click the field
you want to change. Use table ": Global Variables Parameters" on page 115 as a
reference.

- To delete a global variable from the Laser Engine database, select the vari-
able and then click on Delete counter(s) or Delete string(s), depending on
which variable type you are deleting. Click Yes to confirm your choice.
e When you are finished, click Apply and then OK to close the dialog and return to
Laser Editor
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Using special character sequences to associate global variables to a

string

Follow this procedure to associate a global variable (string or counter) to one or more
strings. You can associate the same variable to strings that belong to different docu-
ments. (See also "Adding, viewing, or editing a global variable" on page 115).

To associate a global variable to a string:

Add a string to the document and then select it (see "Adding a Text string” on page
60).

In the Properties window, under String, enter in the Text box the desired special
character sequence, depending on which global variable you are using. It can be a
string, a counter, or both (see the example here below):

- %v[stringname] or %V[stringname] - Where stringname is the name that you
have assigned to the global variable string when you created it (that is, the
Variable field of the Device variables dialog). V forces the uppercase.

- %v[countername] - Where countername is the identifier that you have
assigned to the global variable counter when you created it (that is, the Vari-
able field of the Device variables dialog).

Note that the variablename value is case sensitive, so be sure that you
type it exactly as you did in the Device variables dialog.

NOTE
Press Enter. The string changes to the specified format. When the string is sent to

marking, the counter increments accordingly to the parameters that were speci-
fied when creating the variable.

Example

In the example shown below, we have associated the same counter with two different
strings that are located into different documents. After sending to marking the two doc-
uments, at the laser device level the global counter has incremented.

SOUATALOGIC

¢ Inthe following figure, a string object has been associated with global variables
stringl (value: Marking) and counterl (see figure "Figure Device Variables

dialog" on page 116).

: Markihg003 w

Value

=
%v[string1] %v[countery]

In the following figure, a second string object, which is located in a different docu-
ment, has been associated with global variable string2 (value: Laser Editor) and to
the same global variable counterl.

Docuentz® 3| property Value

__a_stri
ﬂ o
Text Yo [string2] %v[counter]]
Font
Style
Height

Y -

Garamond
Regular
5.00mm
0.00

0.00 ®

Shear
Angle

4 Displacement
Spacing

0.00 %
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e After sending the two documents to marking, the global counter has incremented,
as you can see in the Device Variables dialog box here below:

-
/% Global variables

Counters

I-'lllﬂ‘hlnpmi Step l C’dem

*-ﬂ--_--

EE%E

£
g
||
7

Add New String

Strings

7
5
:
Ei

Variable Value
Delete String(s)
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COMMON OPERATIONS ON OBJECTS

SOUATALOGIC

This section describes all the operations that you can execute on graphic objects either
by using the mouse, or the Properties window, or the toolbars buttons.

Topic

"Using the document's grid" on page 120

"Enabling/disabling objects" on page 120

"Using the mouse to select and manipulate objects" on page 121

"Copying, pasting, cutting, or removing objects" on page 123

"Aligning, flipping or spacing objects" on page 124

"Grouping, merging, or joining objects" on page 125

"Editing objects vectors" on page 128

"Zooming" on page 132

"Specifying the filling patterns" on page 133

"Setting the origin of an object" on page 134

"Optimizing the objects marking order" on page 135

"Calculating the marking time" on page 136

"Marking preview" on page 137
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Using the document's grid

The document's grid is a series of traced lines which intersect. They can be used to pre-
cisely align and position objects in the drawing window.

The distance between lines in the grid can be set by specifying the spacing in the docu-
ment property browser. (For further information on how to create documents, see
"About documents" on page 29).

To customize the grid:

Deselect any object in the work area to display the Properties window for the doc-
ument. By default, under Geometry, the Grid property is set to True, meaning that
the grid is enabled.

To set the exact distance between lines, enter the desired value as the Step. By
default, this value is set to 10,00. Enter a lower value to align and position objects
with greater precision.

To snap to grid objects, set the Snap to grid property's value to True. This way,
objects will be moved and aligned to the closest grid line.

Enabling/disabling objects

In order to be marked, an object must be enabled in the layout. By default, each object
that you add to a document is enabled.

To disable an object:

Select the object in the graphic area to display its properties.
In the Properties window, under Geometry, set the Enable value to False.

The object is still displayed in the graphic area, but its colour changes to gray to
indicate that it is disabled and it will not be marked
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Using the mouse to select and manipulate objects
You can select and operate on objects by using the mouse.
Besides selecting objects, the mouse allows for quick, rough sizing and positioning.

For extremely precise resizing, positioning, or skewing, use the objects
Geometry properties in the Property browser. (See "Geometry properties

for Objects" on page 52).
NOTE j page 52)

What you can do with the mouse:
e "Selecting object(s)" on page 121
e "Moving, resizing, or locking objects" on page 121

e "Skewing and rotating objects" on page 122
e "Editing nodes" on page 122

Selecting object(s)

To select a single object:
e Click to select an object. When the object is selected, it appears as follows:

=] & t
-

» String «

Y i Ry

The & symbol represents the center of the selection and corresponds to the
origin that has been set for the object (see "Setting the origin of an object" on
page 134). Note that the Property browser lists the properties for the selected
objects.
* You can use the handles that appear around the object to move or resize the
object. (See below).
e To deselect an object, click on a blank area of the document.

To select multiple objects:
Do one of the following:
e Drag with the mouse to select multiple objects.
e Hold down CTRL while clicking on the desired objects.
e You can use the handles that appear around the selected objects as if it were a sin-
gle object. (See below).

Moving, resizing, or locking objects

When you have selected an object, you can use the mouse to change its position in the
document, as well as to resize it. You can also lock it so as to prevent any change.

To move an object:
e Select the object.
e When the mouse pointer changes to a cross « , left-click and move the object to
the desired position in the document. (Note that the Geometry properties of the
object are affected).

To resize an object:
e Select the object.
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e Position the pointer over a handle until the pointer changes to the same shape as
the handle, then left-click and drag to resize the object.

e Use the following as a reference:

Object handle

Mouse pointer

You can

Wt W Drag to resize the object
£ 1 Drag down to change the height of the object
i “ Drag left or right to change the width of the object

To lock/unlock an object:

Select the object.
Click the <= handle. The moving and resizing handles disappear and the pushpin

changes to the @ shape. This prevents the object from being changed.
e To unlock the object, click the @ handle.

Skewing and rotating objects

You can double-click an object so as to enable the skewing and rotating handles.

To rotate an object:
e Double-click the object(s). Note that the handles look as follows:

= - @
v Dtring) ¢
% = &

e Position the pointer over the & handle until the pointer changes to a cross, then
left-click and drag up or down the handle to rotate the object.

To skew an object:
e Position the pointer over a handle until the pointer changes to the same shape as

the handle, then drag to skew the object.
e Use the following as a reference:

Object handle

Mouse pointer

You can

=

“—

Drag to resize the object

!

3

Drag down to change the height of the object

Editing nodes

You can use the mouse to edit the nodes of a vectorial object.

To edit nodes:

¢ Double-click a vectorial object. The object's outline becomes green-colored and

the pabaiioi st ot o o

Edit nodes toolbar appears.

e Position the pointer over a polyline until the pointer changes to a cross, then click
to display the nodes.

Please refer to section "Editing objects vectors" on page 128 for further information.
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Copying, pasting, cutting, or removing objects

acElaEar |y N 0lae)

You can use either the standard toolbar buttons, the Edit menu, or the shortcut keys to
copy, paste, or remove objects from the graphic area.

Drag with the mouse to select multiple objects if you want to copy, paste,
or remove them in a single operation.

NOTE

To copy and paste an object:
e Select the desired object(s) in the graphic area. Do one of the following:

- From the standard toolbar, click the (7] Copy button and then the [[] Paste
button.

- From the Laser Editor menu bar, choose Edit > Copy and then Edit > Paste.

- Press Ctrl+C and then Ctrl+V.
e The copy is pasted on top of the original object. Drag to move it.

To cut an object:
e Select the desired object(s) in the graphic area. Do one of the following:
- From the standard toolbar, click the %, Cut button.
- From the Laser Editor menu bar, choose Edit > Cut.

- Press Ctrl+X.
e You can then paste the object.

To remove an object:

Select the desired object(s) in the graphic area. Do one of the following:
From the standard toolbar, click the #) Remove button.

From the Laser Editor menu bar, choose Actions > Remove object(s).

The object is removed from the document.
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Aligning, flipping or spacing objects

R G & 6D e 8

B & o |2

You can use the Adjust objects toolbar or the Actions menu to quickly align, flip, space,
and dimension graphic objects. Most of these functions are only enabled if more
objects are selected in the graphic area. In particular, the spacing tools are only enabled
if at least three objects are selected.

To adjust graphic objects:
e Onthe vertical toolbar, click &) to display the Adjust objects horizontal toolbar.
(All commands are also available from the Actions menu).
e Use the following table as a reference:

Button

Description

Align left - Select at least two objects, then click this button to align all objects to
the leftmost one

Align top - Select at least two objects, then click this button to align all objects to
the top-level one

Align right - Select at least two objects, then click this button to align all objects
to the rightmost one

Align bottom - Select at least two objects, then click this button to align all
objects to the lowest one

Align center X - Select at least two objects, then click this button to align all
objects along the X axis

Align center Y - Select at least two objects, then click this button to align all
objects along the Y axis

Flip horizontally - Select one or more objects, then click this button to flip the
object(s) horizontally. If you select more objects, they will be flipped both individ-
ually and in relation to each other

Flip vertically - Select one or more objects, then click this button to flip the
object(s) vertically. If you select more objects, they will be flipped both individually
and in relation to each other

Space horizontally - Select at least three objects, then click this button to space
objects the same distance apart horizontally

Space vertically - Select at least three objects, then click this button to space
objects the same distance apart vertically

Make same size - Select at least two objects, then click this button to make
them the same size

Make same width - Select at least two objects, then click this button to make
them same width

Make same height - Select at least two objects, then click this button to make
them same height

ag

Restore transformations - Reverses any change you have made, that is,
restores the selected object(s) to its original size or orientation
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Grouping, merging, or joining objects

eccleagsleals

You can use the Objects operations toolbar or the Actions menu to assemble objects in
the graphic area so as to form a single object, as well as to edit object nodes, either
manually or using the advanced processing functions (see "Editing objects vectors" on
page 128).

The assembling functions are only enabled if more than one object is selected in the
graphic area.

These tools can be used on all objects. However it is not possible to merge or intersect
bitmap pictures.

In particular:

The Group and Merge tools allow assembling objects, either if they overlap or
not, into a single object so they can be moved or transformed as a group. Single
objects keep their properties. The Ungroup tool can be used to reverse the
grouped object back to individual objects.

The Union, Intersection, Difference, and Exclusion tools allow assembling vecto-
rial objects so that their constituting polygons are merged into a new vectorial
object. You can edit vectors. The Undo button can be used to reverse the opera-
tion. The filling properties of the resulting object is taken from the first selected
one. If this filling can't be applied to all the objects in the selection, it is taken from
the next one. If none of these fillings is possible, it will be the first one from the
common filling list. Other options are disabled by the user interface.

To use the grouping tools:

Select more objects in the graphic area.

On the vertical toolbar, click () to display the Objects operations horizontal tool-
bar.

Select the desired toolbar button. (All commands are also available from the
Actions menu). The following table shows examples of how tools are used:

Grouping tool Result

In this example, we have two overlapping objects. The black
star is the first selected object.

We drag the mouse to select both objects.

> Group selection

As aresult, the two stars are assembled in a single object so
that they can be moved or transformed as a group. The sin-
gle objects keep their individual properties, as well as their
custom laser and filling properties.

The outline of the overlapping area will be marked twice.

Use the # Ungroup selection button to disassemble the

grouped object into individual objects so each can be moved
or changed individually.

SOUATALOGIC
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£ Merge selection

As aresult, the two stars are assembled in a single object so
that they can be moved or transformed as a group. The sin-
gle objects keep their individual properties, with the excep-
tion of the laser and filling properties.

This button can be disabled if the selection contains a raster
object, an array or if the fillings of the objects have no com-
mon acceptable values. The merged object takes the filling
and outline attributes according to these rules in this order:

« The filling and the outline of the first selected object
(the black star) if all the selected objects allow such
parameters.

« Thefilling and the outline of the first object in the list
whose parameters are in the intersection parameter
list of all objects.

« If none of the filling or the outline already set for the
objects are in the intersection parameter list and this
list is not empty, the first filling in the list is applied.

Vectorial data that compose the objects are merged into a
single object. In this case, the common area will not be con-
sidered when engraving.

Use the 5> Ungroup selection button to disassemble the

grouped object into individual objects so each can be moved
or changed individually.

[ Union Selection

As a result, the two vectorial objects are assembled into a
single object, that is, their constituting polygons are merged
into the new vectorial object. Individual objects loose their
custom properties.

The new object is vectorial: double-click it to display the
nodes and the Edit nodes toolbar that allows editing the vec-
tors (see "Starting nodes editing" on page 130 for further
information).

To disassemble the group, you must either use the <3 Undo
Union toolbar button or the Undo/Redo command list.
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i Intersection Selection

As a result, the objects are assembled into a new single vec-
torial object whose vectors are different from those that
compose the original objects.

Note that only the area that is common to the overlapping
objects will be considered for the engraving.

The new object is vectorial: double-click it to display the [
nodes and the Edit nodes toolbar that allows editing the
vectors (see "Starting nodes editing" on page 130 for fur-
ther information).

To disassemble the group, you must either use the <3 Undo
Union toolbar button or the Undo/Redo command list.

[ Difference Selection

As aresult, the objects are assembled into a new single vec-
torial object whose vectors are different from those that
compose the original objects.

Note that only the outline of the first selected object, minus
the area that was shared with the second object, will be -
marked.
The new object is vectorial: double-click it to display the .
nodes and the Edit nodes toolbar that allows editing the
vectors (see "Starting nodes editing" on page 130 for fur-
ther information).

To disassemble the group, you must either use the <3, Undo
Union toolbar button or the Undo/Redo command list.

[ Exclusion Selection

As a result, the objects are assembled into a new single vec-
torial object, that is, their constituting polygons have been
merged into the new vectorial object. 5
Note that the common area has been removed. The outlines

of the two objects will be marked, minus the common area.

From the engraving point of view, the result is the same as
the Merge tool, but this object is vectorial: double-click it to
display the nodes and the Edit nodes toolbar that allows
editing the vectors (see "Starting nodes editing" on page
130).

To disassemble the group, you must either use the <3 Undo
Union toolbar button or the Undo/Redo command list.
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Editing objects vectors

PreoNeN el 7y

In vectorial graphics the image is described by points through which lines pass, creating
the form of the outline.

Besides resizing a vectorial shape using the handles (see "Using the mouse to select and
manipulate objects" on page 121), you can enter the node editing mode and move control
points or nodes around so as to make changes to the shapes. (See "About nodes and con-
trol points" on page 128).

Laser Editor allows adding simple vectorial objects to your layout (see "Working with
simple vectorial objects" on page 57), and provides the Make vectorial function for you to
make any string or code a pure vectorial object. This way, you can edit their shape by
manipulating control points and nodes, either using the mouse or the Edit Nodes tool-
bar.

In laser engraving a vectorial graphic is faster in engraving and more defined in terms of
outline lines and filling. A vectorial graphic cannot be used for engraving digital photo-
graphs.
See the sections that follow:

e "About nodes and control points" on page 128

e "Making an object vectorial" on page 129

e "Starting nodes editing" on page 130

U If you are working with elaborate objects (for example, imported draw-

ings), consider using the Advanced Processing function (7] button), also

available from the Actions menu, which provides an automated way to edit

NOTE vectors. See "Using Advanced Processing options” on page 107.

About nodes and control points

When you double-click a vectorial object, nodes appear, as small boxes connected by
green lines. You can then drag the node, or edit the type of node using the Edit Nodes
toolbar: for example, you can make a node symmetric or asymmetric (see "Starting
nodes editing" on page 130). When you do this, a line with two small circles at the ends
will appear over the node. These are called control points.

The figure below shows an example:

i
i
i
|
i
i / Asymmetric
! / control points
i {
4 _
i /I’ \)
Symmetric control s |

points ‘ i yd

The type of node determines the behaviour of polylines before and after the node.

Note that the control point defines two points through which the polyline passes. The
position of the control points in relation to the node defines which type of node you are
working with (symmetric, asymmetric, or angular). You can drag the small circles to
change the shape.

128 LIGHTER™ SUITE CIOATALOCGIC



COMMON OPERATIONS ON OBJECTS

Making an object vectorial

This function allows making vectorial a string or a code, so that you can enter the edit-
ing nodes mode and change or deform their shape as you need. Note that, when a
string is made vectorial, it loses its specific string's properties to become a pure vectorial
object.

To make an object vectorial:
e Select the object you want to make vectorial. (You can also operate on grouped
objects.)

e Do one of the following:
- From the Laser Editor menu bar, choose Actions > Make vectorial.
- On the vertical toolbar, click L) and then click (j5 Make vectorial in the hori-
zontal toolbar.

e To enable the edit nodes function, click the 4 . Edit nodes button (or double-click
the vectorial object). This will result in the Edit nodes horizontal toolbar being dis-
played and in the color of the lines changing to green.

e Click the object to display a small square vertex handle at each vertex of the
shape's boundary. These are the nodes that you can use to edit the shape:

DA T W S s S e L Ll ,l D
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Starting nodes editing

To edit vector shapes, you must go into node editing mode. This is done in two ways:
¢ by double-clicking a vectorial object
e by selecting the vectorial object and then clicking the # . Edit nodes button

You can use the mouse to drag the nodes or you can use the Edit nodes toolbar, as it is
described below. For further information on how to make a string or a code vectorial,
see section "Making an object vectorial" on page 129.

To edit the nodes:
e Click a node(s) to select it —+

Select multiple nodes by holding down the Ctrl key while clicking the nodes you want to
select.

B If you select multiple nodes, you can move them simultaneously.
NOTE

e The following table provides several examples using the Edit nodes toolbar:

Action Result

Click ~» Angular nodes to create an angular node so that 1
you can manage separately the two control points.

Click “=, Asymmetric nodes to make a node that allows

you to manage an individual control point. To change the
shape, drag the control point.

Click sa« Symmetric nodes to make a node that allows you

to move simultaneously and symmetrically the two control
points. To change the shape, move a control point.
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Select multiple nodes and click “3~ Join nodes to manage

them as a single node. Click away from the shape to return
to the original situation.

Click 4, Break path to take the selected node and break it

in two at that point. Where one node was, there are now two
unconnected nodes. The nodes can now be moved inde-
pendently of one another.

Select two nodes and click _i, Delete path to delete the
polyline between them.

Use the Join segment button to draw a polyline connecting
two separated nodes.

changes to a cross and then double-click-it:

To add a node to a segment, point to the border of the segment until the pointer

To remove a node, click the node and press the Delete key.
Click on the #) Insert objects button to close the Edit nodes operating mode.
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Zooming
QaQaQ

By changing the zoom, it is possible to display the whole graphic area on the screen or a
greatly enlarged detail of a particular part. The maximum zoom depends on the screen
resolution and the dimensions of the graphic area.

To zoom objects, you can use the Zoom dynamic toolbar or the View menu of Laser Edi-
tor.

To zoom or reduce objects in the graphic area:
e On the vertical toolbar, click the @, Zoom button. The horizontal zoom toolbar is
displayed.
e Use the toolbar buttons to change the zoom as required:

- To gradually zoom the work area, use the @ Zoom in button as many times
as you want. Use the @ Zoom out button to gradually reduce the zoom.

- To zoom a certain element, select the element and then click the @, Selec-
tion button. This button is unavailable if no object is selected in the graphic
area.

- To revert to the standard view, click @) Page.

- To zoom a specific area in the drawing, click the @ Window button and then
trace a rectangular window around the perimeter. Laser Editor sets the zoom
level so that the specific rectangle fills the window.
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Specifying the filling patterns

You can specify different filling patterns for objects, that is, filling the object with filler
lines. To this purpose, the Filling properties in the objects Properties window are used.
(See "Filling properties for Objects" on page 55).

The figure below shows some examples:

Resolution None
core =
Custom laser parameters Triple lines
4 Materials
Material
Single line Cross line Triple line

Islands ) Raster

% -

Qeing ______ [T =]
Interline None
Angle Cross Ines
4 Advanced Triple lines
Direction Dot
S S Raster
Single line . Cross line . Triple line
= ] L ]
g; ; »
=
) Raster
1

B The Filling properties do not apply to Arrays or Imported Raster images.
NOTE

To set the filling properties:

e Select the object in the graphic area. The properties for the object are displayed in
the Properties window.

e Select from the Filling property dropdown list the desired pattern. (By default, this
value is set to None, meaning that no filling is set for the object).
e More properties are displayed below that allow customizing the filling pattern.

Refer to section "Filling properties for Objects" on page 55 for a complete descrip-
tion of each property
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Setting the origin of an object

The origin is a point that defines the position of the object into the engraving area. This
origin relates to the point of origin of the document's engraving area (see "Geometry

properties - Layer" on page 37, Origin property).

The origin is represented by the cross symbol € . By default, this symbol is placed in the
centre of the object.

Laser Editor allows changing this property for any object to better fit your special
engraving requirements.

To set the origin of an object:

Select the object in the work area for which you want to set a point of origin other

than Center.

In the Properties window, under Geometry, select the desired value from the Ori-

gin dropdown list.

Note that the cross symbol moves accordingly. The following example shows an
object whose origin has been set to Center Top in a document whose point of ori-

gin is set to Center:

-

origin of the object

(Center Top) I

an

origin of the
ngraving area: Center
(document’s origin)

[ e

Enable @
Locked O
Keep Aspect (]
Contour 0
pocketing B
Origin Center top
4 Position (5.00, 10.00)
X 5.00 me
Y 10.00 mm
9.93x9.99
Width 9.93mm
Height 5.99mm
Angle 0.00
Scale
X 51.19%
Y 50.54 %
Skew 0.00
Filling None
Clones 0
Custom laser parameters &
.
Material
Save I

You can specify the object's position by setting the X and Y coordinates. (Refer to
"Geometry properties for Objects" on page 52 for a description of each property).
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Optimizing the objects marking order

Laser Editor has a function that sets automatically the marking order of the objects that
compose your layout for optimal performance.

In other words, the system orders the objects to be engraved so as to minimize the path
of the spot laser between objects, resulting in a shorter marking time.

To optimize the objects engraving order:
e When your layout is composed and ready for engraving (see "CREATING GRAPHIC
LAYOUTS" on page 26), do one of the following.
- From the Laser Editor menu bar, choose Actions > Marking order.
- On the vertical toolbar, click &) Adjust buttons and then click 2 Marking
order in the horizontal toolbar.
¢ The Optimizing marker order window is displayed, showing the operation prog-
ress.
e When finished, note that the objects order in the Objects engraving order pane,
has changed. See picture below:

W
ST '
0 7000001734565 \giiii 7 ‘ 5\‘

QK( Q/ : N Laserkditor & st

Optimizing marking order...

i . |

[ Accept ] [ Cancel ]

v

Objects marking order

JOY

Engraving Order

L [1%] &
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Calculating the marking time

Laser Editor allows you to calculate the marking time of your graphic layout, that is, how
long the engraving operation will take.
The marking time is determined by the level of detail that you add to the objects that
compose the layout. If you can't exceed a specific marking time, consider removing
some details.
Keep in mind that this is an approximate value that is just intended to help
you in calculating the time. The actual marking time depends also on the
specific device you are using, as well as on its settings.
To view the final results of your marking, besides calculating the marking
time, see "Marking preview" on page 137.

NOTE

To calculate the marking time:
e Create your engraving layout (see "CREATING GRAPHIC LAYOUTS" on page 26).
e There are two possible scenarios:

- If the marking time for the layout is less than 30 seconds, the Marking time
button on the toolbar shows the expected time automatically. For example:

(1) In 31

- If the marking time for the layout exceeds 30 seconds, in order to calculate
the estimated time, you must click the (3 o0:00 button.

| Marking time: 01[m] 31[s] 296[ms]
39 markings/h

1 i
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Marking preview

The Mark preview function allows you to check the final result of the marking process of
your layouts directly in Laser Editor.

When selecting this option, the Mark preview window shows both the lines that the
laser will actually mark, according to the filling you specified, and the marking time. This
way, you can precisely verify the time that the process will take and the result that you
will obtain, such as, for example, if lines are placed equidistantly apart.

The drag and drop function allows you to move layout's objects around the work area.

An object: with functionality for mark preview is available at scripting level

also. Programmers can create their own user interface including a preview

of the document to be engraved. For further information, see the Project
NOTE  Editor online documentation, chapter "Language Reference".

To mark a preview:
e Create your layout. (See "CREATING GRAPHIC LAYOUTS" on page 26).
The following shows an example of string object:

i 4 [ sinale
4, £ & S

&

Outline option
Tolerance
Fill By

R

o ¥

Note that the Cross lines Filling property is applied.
e Do one of the following:

- From the File menu, select Mark preview.

- From the Laser Editor standard toolbar, click the .4 Mark Preview button
that is made available after opening or creating a document.

The following window is displayed:

N ok previen [

Zooming
capability

AsCr,

Drag and drop
function

V@

The Mark preview windows shows exactly how the lines will be marked.

e Use the zooming bar the right side to further check the results, and the drag and
drop function to move items.

e If needed, edit your layout so as to achieve the desired result.
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CHAPTER 4

PERFORMING THE ENGRAVING
OPERATION

This chapter is divided into the following sections:

Topic

"Setting custom laser parameters" on page 139
"Displaying the limits" on page 143

"Simulating the marking operations" on page 145
"Connecting to the laser device" on page 147
"Send marking" on page 148
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SETTING CUSTOM LASER PARAMETERS

The engraving parameters must be set before engraving the graphic layout. Correct
engraving parameters are essential to ensure engraving quality. When setting laser
parameters you should consider the laser source you are using, the material to mark,
and the required process.

Engraving parameters can be the same for all graphic objects: by default, each graphic
object uses the laser parameters properties of the document. However, you can set dif-
ferent laser parameters for each object; this will result in the object's colour changing to
blue.

To set laser properties for all objects:
e Create or open a document (see "About documents" on page 29). Be sure that no
object is selected in the work area.

¢ Inthe Properties window, under Geometry, set the Laser properties as required.
Please refer to section"Laser properties for documents" on page 30 for information
on how to set the parameters.

To set laser properties for individual objects:

e Select the object(s) in the document. (See "About graphic objects" on page 51).

e Inthe Properties window, set to True the Custom Laser property.

e Set the properties that appear as required. Please refer to section "Custom Laser

parameters for Objects" on page 54 for information on how to set the parameters.

Note that, after editing, the object's colour changes to blue.
For further information, see:

e "Using more engraving runs” on page 140

e "Using the wobble function to engrave with thicker lines" on page 141
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Using more engraving runs

The Laser properties allow you to set the number of runs of the laser light on the object
to engrave. You might set up to 3 passages, each with different laser parameters.

This option may be particularly useful to make several light engraving runs to clean the
workpiece after a more incisive engraving process.

Be sure to select the best parameters according to the material used and
the required processing type. To carry out a good cleaning run, it is import-

ant that the speed is the same as an engraving run.
CAUTION

To set more passages:

e Click a blank area on a document (to set the parameters for all objects), or select
an individual object (see "To set laser properties for individual objects:" on page
139).

¢ Inthe Properties window, under Laser (or Custom Laser for an object), select the
number of Passages, that is, the number of runs of the laser light (1 to 3). The
parameters for each passage will be displayed allowing you to set different param-
eters.

e Set the other parameters as required. Please refer to section "Custom Laser
parameters for Objects" on page 54 for information on how to set the parameters.
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Using the wobble function to engrave with thicker lines

Wobble is a function integrated in Laser Editor that allows engraving the single lines of
vectorial graphics, either True Type characters or imported figures, with thicker lines.

Normally, the line thickness corresponds to the dimension of the laser spot. If you need
to increase this thickness, you can use the wobble function.

The two figures below represent the functioning principle of the wobble:

The figure on the left shows the result of a vector engraving with the wobble disabled,
while the figure on the right shows the same vector but with the wobble enabled:

@

The conversion of the vector into a dense spiral provides greater thickness of the
engraved line.

To enable the wobble function:

The wobble function configuration parameters must be tested and checked
in order to obtain the desired effect. Engraving times with the Wobble func-
NOTE tion are longer, only use the Wobble function when absolutely necessary.
You can enable the wobble function either at a document or at object level. To do so,
you can use the Laser (or Custom Laser) > Wobble property.

e To enable the wobble function, do one of the following:
- Create or open a document (see "About documents" on page 29), then, in the

Properties window, under Laser, set to True the Wobble property. This will be
the default setting for all objects that you add to the document.

- Select the object (see "About graphic objects" on page 51), then, in the Proper-
ties window, set to True the Custom Laser property and then the Wobble
property.
e Specify a value for the Radius property, that is, the radius of the spiral curve to be
used.

e Specify a value for the Speed property, that is, the frequency of spiral repetition.
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Use the Simulator tool to verify the result of the Wobble function: from the Laser

Editor menu bar, choose Laser > Simulator:

&1 Simulator

4 Passagel
Power
Frequency
Scan speed
Shot Time

Custom laser parameters

0.00mm
Center
(088, 1.5
0.88mm
1.5%mm
3292000
33.92mm
0.00

0.00°

100,00 %
100.00 %
000

None:

7
1passage
0%
20.000 kHz
10.00mmje

150ps
i
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Note that the single line character has a much thicker outline. The same result would be
obtained with real engraving.
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DISPLAYING THE LIMITS

This function refers to displaying the margins of the drawing on the work plain. Margins
are displayed using a red laser pointer.

Limits function displays the bounding box of the object(s) that will be engraved: this
result is obtained by driving head scanners to move along the box path at a fast speed.

In order to use this function you must be connected to the device and the Manual Mode
must be activated. In Auto Mode this function is not available (see "Auto Mode vs. Man-
ual Mode" on page 148).

7

NOTE

For further information on the laser pointing parameters that are used to
display engraving limits, see "Setting custom laser parameters" on page
139.
These functions are also accessible at the Laser Engine interface level
through the /¥ Start limits and |-|> Limits previous/next sector menu but-
tons.

For further information, see "LASER ENGINE USER INTERFACE" on page
151.

To display the limits:

e Be sure that you are connected to a device (see "Connecting to the laser device" on
page 147) and that you have activated the Manual Mode (otherwise, the Limits
buttons are unavailable). To activate it do one of the following:

SOUATALOGIC

7

NOTE

- Select % Switch to Manual Mode on the toolbar.

- From the Laser Editor menu bar, choose Laser > Switch to Manual Mode

This is a toggle button: if the Manual Mode is activated, the tooltip says
Switch to Auto Mode, and vice versa.

e Do one of the following:

- To see the engraving limits for one or more specific objects, select the
object(s) and click on /¥ Limits on selection on the toolbar. (Alternatively,
choose Laser > Limits on selection from the menu bar).

- To see the engraving limits for the whole graphic area, click on ¥} Limits all
on the toolbar. (Alternatively, choose Laser > Limits all from the menu bar).

- To see the engraving limits for the sectors that compose the object when
engraving on a ring document, clickon « & Limits previous sector and Limits
next sector buttons on the toolbar. The buttons become available (green
coloured) after pressing either the Limits on selection or Limits all button.
(Alternatively, choose Laser > Limits next sector and Limits previous sector
from the menu bar)
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The example below shows how the limits for a sheared word (Editor) would appear:

Related topics:
e "Setting custom laser parameters" on page 139
e "Simulating the marking operations" on page 145
e "Connecting to the laser device" on page 147
e "Send marking" on page 148
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SIMULATING THE MARKING OPERATIONS

Laser Editor can be used to simulate the engraving results, that is, when you are finished
creating the layout, you can test the engraving via a video graphic simulator before
sending it to the device for marking.

B To verify the final result of your layout, as well as its marking time, you

can use the Mark preview function (menu File > Mark preview). For further
information, see "Marking preview" on page 137.
NOTE
If you are not connected to a device, pressing F5 or Send Marking (which would other-
wise start the laser engraving), results in a graphic window being displayed, which simu-
lates the engraving operation. The simulation maintains all the speed, filling, wobble or
other parameters set in the document.

The simulation can only be done in Manual Mode. In Auto Mode the feature
is not available and the laser engraving is managed automatically through
the Laser Engine (see "Auto Mode vs. Manual Mode" on page 148). Note

NOTE  that, when in Auto Mode, the Simulator button is pressed meaning that the
device is working in simulation.
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To simulate the engraving:

e Be sure that you have activated the Manual Mode. To activate it do one of the fol-
lowing:

- Select ,® Switch to Manual Mode from the toolbar of Laser Editor.

- From the Laser Editor menu bar, choose Laser > Switch to Manual Mode.

This is a toggle button: if the Manual Mode is activated, the tooltip says
Switch to Auto Mode, and vice versa.

NOTE
e There are two possible scenarios:

- If you are not connected to a device, pressing F5 (or clicking /¥ Send Mark-
ing) will automatically activate the simulator.

- If you are connected to a device, the [ Simulator button is enabled and
you must press it (or choose Laser > Simulator from the menu bar) to activate
the graphic simulator.

The following picture shows an example:

i Simulator =)

R LasetMarking

e Tointerrupt the marking simulation, use the & Stop marking toolbar button (or
choose Laser > Stop Marking form the menu bar).
Related topics:
e "Setting custom laser parameters" on page 139
e "Displaying the limits" on page 143
e "Connecting to the laser device" on page 147
e "Marking preview" on page 137
e "Send marking" on page 148
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CONNECTING TO THE LASER DEVICE

The following connection procedure only applies to users who have a
Supervisor installation of Laser Editor (for further information, see section

"Installation types and connection modes" on page 19).
NOTE yp page 19)

In Laser Editor, the laser device that is used for marking graphic layouts is managed by
the Laser Engine interface and can be either local, in the case of a stand-alone marking
solution, or remote, in the case of an unattended marking solution, typically on a pro-
duction line.

In particular, the connection mode (local or remote) depend upon your type of installa-
tion:

e If you have an unattended Supervisor installation of Laser Editor, you can use the
procedure that is described here below to remotely connect to a Laser Engine,
provided that the remote control has been enabled. (See "Local/Remote control"
on page 160).

e |f you have a Stand-alone installation (without remote control), you can only
access the Laser Engine interface that controls your local device. The Connect to
device buttons of Laser Editor that are described in the following procedure, are
not available for this installation type.

For further information about using the Laser Engine interface, see chapter "LASER
ENGINE USER INTERFACE" on page 151.

To set your Windows Firewall so as to enable remote connection:

This operation is required in order to enable remote communication between Laser Edi-
tor and Laser Engine. It involves setting your Windows Firewall properly:

e Click Start, click Control Panel, and then double-click Windows Firewall.
e Select the Exceptions tab, and then click Add Port.
e Inthe Port number box, type 4659 and then click OK.

e Repeat step 3, but type 4657 in order to open the port for files and binary data
transfer.

To connect to the device:

Do one of the following:
- From the Laser Editor menu bar, choose Laser > Connect to device.

- On the toolbar, click Connect to device.

¢ Inthe Connect to device window that is displayed, select the device you want to
connect to.
Note: that all the available devices are listed, both local and remote devices. In the
case of a remote device, IP Address is also displayed.
It is only possible to connect to devices with IP Reachable property “true”.

e Click OK.
Note: that the status bar of Laser Editor shows both the status of the connection
and information on the connected device.

Related topics:
e "Simulating the marking operations" on page 145
e "Send marking" on page 148
e "Launching Laser Engine" on page 152
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SEND MARKING

Laser Editor allows two ways for sending a graphic layout to marking:

¢ |In Manual Mode - By pressing F5 (or choosing Laser > Send Marking) to send a
layout. By pressing F9 or click on (or choosing Laser > Send Marking on selection)
to send a selected object. If you are operating on a stand-alone marking unit, and
are interacting directly to the laser device, you can either use the simulator to test
the layout, or send it to marking. (See "Simulating the marking operations" on page
145).

¢ |n Auto Mode - By saving the graphic layouts to the device. The layouts will then
be sent to marking based on the programs that have been created via Project Edi-

tor.
The functions described in this section are also accessible via the Laser
Engine interface. For further information, see “Launching Laser Engine" on
page 152.
NOTE

Auto Mode vs. Manual Mode

Lighter has different working modes:
e "Auto mode" on page 148
e "Work mode" on page 148
e "Manual mode" on page 149

Auto mode

In Auto mode, a document or a project saved in the device is processed and sent to the
laser control board, waiting for external I/0O signals to start the marking process.

When Laser Engine starts in Auto mode, the document or the project that is saved in the
device and that is set as the default document is automatically processed and sent to
the laser control board, waiting for external 1/0 signals to start the marking process.
The Auto mode is particularly useful in work environments where:

* no operator are assigned to the engraving station;

e the marking process is automate using external PLC;
Note that, in order to use Laser Editor for interactions with the laser device, that is, set-

ting the laser configuration parameters or sending documents directly to marking, you
must switch to the Manual mode.

Behavior

Typically, in this mode, you can do the following operations:
e Select a project or document to be marked using Laser Engine.
* Press Auto Mode button % in Laser Engine.
e Use external I/O signals to start the marking process;

Work mode

In Work mode, the document actually opened in Laser Editor is temporary saved in the
device, processed and sent to the laser control board, waiting for external 1/0 signals to
start the marking process.
The Work mode is particularly useful in work environments where:

e an operator is assigned to the engraving station;

e Laser Editor is used to select and modify the documents;

e external I/O signals are used to start the marking process;
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Note that, in order to use Laser Editor for interactions with the laser device, that is, set-
ting the laser configuration parameters or sending documents directly to marking, you
must switch to the Manual mode.

Behavior
Typically, in this mode, you can do the following operations:
e Open the project or document to be marked using Laser Editor.
e |f needed, perform any editing or testing operation prior to mark.
* Press Work Mode button g2} in Laser Editor.
e Use external I/O signals to start the marking process;

e Inwork environments such as a production line, after selecting the document, you
can activate the Auto mode so as to enable external starts from the PLC.

Manual mode

In Manual mode, the operator has full control of the marking process and no external I/
O signals are accepted.
The Manual mode is particularly useful in work environments where:
e anoperator is assigned to the engraving station;
e Laser Editor is used to select and modify the documents;
e no external I/O signals are used to manage the marking process;
Note that, you must activate the Manual mode in order to create and test a layout

before saving it on the device, or if you want to change the laser configuration parame-
ters.

Engraving simulation and testing operations are only available in Manual mode.
Behavior
Typically, in this mode, you can do the following operations:

e Open the project or document to be marked using Laser Editor.

e If needed, perform any editing or testing operation prior to mark.

* Press Send Marking button /¥ in Laser Editor.

e Inwork environments such as a production line, after selecting the document, you
can activate the Auto mode so as to enable external starts from the PLC.

To switch to Auto Mode if Manual mode has been activated:
e Choose the Laser > Switch to Auto Mode from the menu bar.

or
* Clickon % Switch to Auto Mode on the toolbar.
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Sending the layout to marking

To send a layout directly to marking:
e Be sure that you are in Manual Mode. To switch to this mode, do one of the fol-
lowing:
- Choose Laser > Switch to Manual Mode from the Laser Editor menu bar.

- Click /% Switch to Manual Mode on the toolbar.

e PressF5orclickon /¥ Send Marking on the toolbar. (Alternatively, choose Laser
> Send Marking from the menu bar).

If you are not connected to a laser device, the graphic simulator will auto-
matically be activated instead. (See "Simulating the marking operations" on

age 145).
NOTE Pag )

e Tointerrupt the laser marking or the simulation, use the /& Stop marking button
on the toolbar (or choose Laser > Stop Marking form the menu bar).

To save a layout to the device for next marking:

e From the Laser Editor menu bar, choose File > Save to Device or press  on the
toolbar.

¢ Inthe Save document as window that is displayed, select from the Devices drop-
down list the device you are sending the layout to.

e Enter a name for the document and click OK. This is the name that will be used in
the Project Editor to write a program to upload the document send it to the
engraver in an automated way.

The Project Editor is a tool integrated into Laser Editor that allows creating
customized programs. To access it, choose File > Project Editor. The tool
has its own context-sensitive Help and it is used to automate marking pro-

NOTE  cedures, or to update the layout contents at runtime. Default programs and
easy-to-use examples are provided with the tool.
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CHAPTER 5
LASER ENGINE USER INTERFACE

This chapter describes how to use Laser Engine, which is an application that is provided with
Laser Editor and allows operating on the laser device.

The interface allows previewing how a document or project that was saved to the device will be
marked, as well as performing many other fine-tuning operations before marking.

Laser Engine can be installed with Laser Editor or independently, and available buttons or func-
tions may differ depending on the installation type that you have chosen when installing Laser
Editor. For further information, refer to "Installation types and connection modes" on page 19.

For further information:

Topic

"Launching Laser Engine" on page 152

"User interface overview" on page 152

"Managing users and access rights" on page 157
"Switching between working modes" on page 160
"Disenabling the Winsat Task" on page 163
"Configuring the laser parameters" on page 165

Laser Engine can now be integrated into customers' applications as an

ActiveX server.

Developers can now write their ActiveX clients and build highly customized
NOTE user interface for their clients, using Laser Engine to control the laser.

To this purpose, a new object has been created as entry point in the

ActiveX server. (For further information, see the Project Editor online doc-

umentation, "Language Reference" chapter).

This feature must be licensed.

SDOATALOGIC USER MANUAL 151



LASER ENGINE USER INTERFACE

LAUNCHING LASER ENGINE

To launch Laser Engine:

1. After you install Laser Editor, the Laser Engine icon appears on the applications
toolbar, as it is shown below:

Laser Engine
Icon

2. Todisplay the Laser Engine user interface, do one of the following:
e Double-click the Laser Engine icon to display the application window.
e Right-click the Laser Engine icon, and then click Show.

3. To close the Laser Engine window, do one of the following:

e Click the Close button at the top right of the window.

¢ Right-click the Laser Engine icon, and then click Minimize.

U Starting from the release 5.3, you can also launch both Laser Engine and
Laser Configuration from Laser Editor, by using the ad hoc toolbar buttons

NOTE @ ¥ or the Laser menu commands.

For further information on the elements that appear on the window, please refer to sec-
tion "User interface overview" on page 152.

USER INTERFACE OVERVIEW

This section provides a quick reference to the graphical user interface of Laser Engine,
both for the functions available in the main window and for the shortcut menu that you
access by right-clicking the Laser Engine icon in the applications toolbar.

For further information:

e "Main window elements" on page 153
e "Menu buttons" on page 155
e "Shortcut menu commands" on page 156
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Main window elements

The picture below shows the main window of Laser Engine when you access it.

In this example, a document is selected whose contents are displayed in the Preview

area:
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The numbered elements are described below:

Area

Description

@

Menu buttons - The left side of the Laser Engine window contains the but-
tons that allow accessing the main functions. All buttons are toggle: move the
pointer over a button to see the current selection. For more information on
each button, see "Menu buttons" on page 155.

Documents and projects saved to the laser - The Documents tab that is shown
at the startup, lists all the project or documents that have been saved to the
device and that you can send to marking (see "Sending documents to marking" on
page 198):

e« The = iconindicates a document (.x1p) created with Laser Editor

o The % iconindicates a project created with Project Editor

e The === icon indicates a sequence (.xse) created with Laser Editor
When you select an item, the Preview area displays the contents. If a sequence if
selected, the first document in it is displayed.
Note that right-clicking a document or a project, results in a shortcut menu open-

ing that allows you to delete the element or to set it as the default, that is, as the
document or project that will be selected at Laser Engine startup:

Documents I Device Status | X Axis | ZA

e name Ext

£ blank xp

Set as default
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©

Tabs - In this area, the following tabs can be displayed:
« Documents, that lists the project and documents, as it is explained here
above. For further information, see "Sending documents to marking" on
page 198.
« Device Status, that shows information relating to the status of the laser
device. It is a read-only tab. For further information, see "Viewing the
Device Status" on page 199.

The availability of the following tabs depends upon the laser source you are using
and how it is configured, that is, if axis are enabled. For further information, see
"Managing axis and executing the laser test" on page 192.
« X-Y Axis, that allows managing the horizontal and vertical axis prior to
marking a plane document.
« Z Axis, that allows managing the Z axis prior to marking, as well as execut-
ing the laser test for focusing.
« Rotor Axis, that allows managing the R Axis prior to marking a ring docu-
ment.
« Statistic, that shows statistic relating to marking processes and marking &
verification processes (feature available with Marvis enabled; see the Mar-
vis Application Note for more details)

Document's or project's preview - If you select a document (as in the example),
this area shows how the graphic objects will be actually marked. If you select a
project, it gives you information on the project

Marking time - It previews the required marking time, based on the objects to be
marked, showing also the progress

Zoom function - In the case of a document, it allows zooming the objects to be
marked

Device status icon - [t tells you the current status of the device: for example a

green icon means Device is waiting for start, while a red icon means Device

ready. For further information on device statuses, see "Viewing the Device Sta-
tus" on page 199

Reader available icon - It tells you the current status of the reader: for example
a green icon means Reader available for verification, while a red icon means
Reader is working. For further information on device statuses, see MARVIS
configuration.

©®QY®

Laser Engine icon on the applications toolbar - Right-click this icon to open a
shortcut menu that lists a number of commands. See "Shortcut menu com-
mands" on page 156 for further information
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24

NOTE

USER INTERFACE OVERVIEW

If users access control has been enabled and you do not have proper rights
to use the buttons, you will be prompted for a password with rights. (For
further information, see "Managing users and access rights" on page 157).

The following table provides a short description of all available menu buttons. A link to
the relevant section in this chapter is provided.

Button

Description

to Local/to Remote - It allows specifying the Laser Engine supervision level: it
can be Local (Laser Editor and Laser Engine are on the same machine) or Remote
(Laser Editor and Laser Engine are on different machines.) After setting the
Remote control, operators who have a Supervisor installation type might control
remotely the laser.

This button is only available if you have an Interactive installation with remote
control allowed.

By setting the Remote control, all other buttons become unavailable.
For further information, see "Local/Remote control" on page 160

to Auto/to Manual mode - It allows switching between working modes. This
button is only available if the Local control has been activated.

When the Auto mode is activated, the engraving operations are executed auto-
matically. The Manual mode is used for editing and testing graphic layouts.

You can set the default working mode via the shortcut menu. For further informa-
tion, see "Auto/Manual working mode" on page 162

Start - It allows sending a document to marking, or stopping the marking opera-
tion, respectively. When pressed, this button changes to /&

This button is only available if the Local control has been activated. For further
information, see "Sending documents to marking" on page 198

Start Limits - It allows displaying the margins of the graphic objects to be
marked.

For further information, see "Displaying the limits" on page 143

Limits previous sector / Limits next sector - These buttons allow displaying
the margins of the sectors that compose the objects to mark, when engraving on
ring documents. The buttons become active after clicking on Start Limits
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Shortcut menu commands

Right-clicking the Laser Engine icon on the Windows application toolbar, results in a
shortcut menu opening:

System test

Laser configuration

Start in auto mode

Start in remote mode

Right-click the Laser
Engine icon to display ([l

the shortcut menu Quit

The commands available on the shortcut menu are shortly described below. A link to
the relevant section in this chapter is provided.

Menu command

Description

Minimize/Show

Allows minimizing or displaying the Laser Engine user interface

Always on top

Allows keeping always visible the Laser Engine window

User Management

Allows accessing the user management function. You must have the
appropriate privileges to manage users. See "Managing users and
access rights" on page 157 for further information

Global variables

Allows accessing and managing the global variables; these are
strings or counters that are stored in a small database at the device
level. If users management has been enabled and access to this func-
tion has been limited, you will be prompted for a password with
proper rights. See "Using global variables" on page 114 for further
information

Troubleshooting

Allows checking errors and tracking system events

System test

Displays the dialog that allows checking your hardware and cables
connections. See "Testing the system" on page 204 for further infor-
mation

Laser configuration

Allows accessing the parameters for configuring the laser. See "Con-
figuring the laser parameters" on page 165 for further information

Start in auto mode
Start in remote mode

Allows specifying the working mode that must be activated at
startup. See "Auto/Manual working mode" on page 162 for further
information

Quit

Exits the Laser Engine interface. Use this command if you need to
restart Laser Engine
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MANAGING USERS AND ACCESS RIGHTS

Minimize

Show

Always on top
Global variables
Troubleshooting
System test

Laser configuration

v | Startin auto mode

Start in remote mode

Quit

The User management function allows you to set and manage the users' rights on the
system.

By default, Laser Editor does not request any login and any user can access and manage
all system's functions.

To change this setting, you must first enable the Users management function by enter-
ing a unique password that gives you administrator privileges; then, you can specify the
rights on the system's functions for specific classes of users.
This function is also accessible and usable at the Laser Editor level by
clicking the .. Manage device users button on the toolbar or by choosing

NOTE Manage device users from the Laser menu.

To enable the users management and to set the access rights:

e Right-click the Laser Engine icon on the Windows applications bar.
¢ On the shortcut menu that appears, click User management.
e The dialog box for typing the password is displayed:

D Please enter password [

Please enter password to confirm operation:

Password:

@ Do not remember
©) Remember for minutes
(©) Remember until program is closed

e Type a unique password of your choice.

If the password you specify is not unique in the system, an error message
will be displayed.

NOTE

e Specify whether and how long the system must remember your password: You
can specify either a specific time interval in minutes, or the entire program's ses-
sion. Once the specified time is elapsed, the password will be requested to enter
the function.

To change the administrator password, or to disable the users access con-
trol, see "Disabling users' access control" on page 159.

NOTE
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Click OK. The User management window will be displayed.

M bes

| o g g Laser Global variables

| Administrator

| Everyone @ ] ®

| operator ()

| Designer ()

| Developer ()

O oo e e e B
[oc [ et ]

The left side of the grid lists the available types of users, while in the upper part the
functions you can limit the access to are listed. An asterisk (*) indicates that the access
control is currently disabled for those users because no password has been set, and a
selected checkbox indicates that the user has rights to the function.

Available users are:

The Administrator has full rights on the system's functions and can manage the
users' rights; you cannot edit this user.

The Everyone user is the default user, who has all rights except the users manage-
ment function; it is editable and you can use it as a basis for setting the other
users' rights.

Three additional types of users are provided: Operator, Designer, and Developer.

These represent the typical operators of a laser system for whom you might limit
the access rights to the functions.

The functions you can limit the access to are:

Function name Allowed operations

Manage users This function allows managing users' access rights to the system

Auto/Manual

This function allows switching between manual and auto working
mode. See "Auto/Manual working mode" on page 162

Manage layouts

This functions allows creating a layout and sending it to marking. See
"CREATING GRAPHIC LAYOUTS" on page 26

This function allows implementing a project with Project Editor and

Programming then sending it to marking. (See the Project Editor's online help that

is integrated into the Laser Editor help system.)

Laser configuration

This function allows accessing and configuring the laser configuration
parameters. See "Configuring the laser parameters" on page 165

This function allows creating global variables that you can access

Global variables both from Laser Editor or from the Laser Engine interface. See "Using

global variables" on page 114

To enable the access control for the Operator, Designer, or Developer user, in the
User management window click Set passwords. The Change passwords window is
displayed.

/% Change Passwords =

User: ¥

New password:

Repeat password:

ok ][ cancel ][ aeply

Click the User arrow to display the list of users and then select the desired user, for
example Designer.

Select Administrator to change the current password, or to disable the
users access control by entering an empty password.

NOTE

Type a unique password of your choice, and then confirm it.
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Do one of the following:
- Click OK to return to the User management window.
- Click Apply to clear the fields if you want to disable access control for the
user, or if you want to change the password.

Note that the Designer user inherited all Everyone's rights, that is, has access to
all functions, but the checkboxes are still unavailable and you cannot clear them.

To limit the access rights to a specific function for the Designer user:
- Clear the corresponding checkbox for the Everyone user.

- The checkbox becomes available for the Designer user also; clear it to limit
the access to the function for this type of user, as shown in the example
below:

NOTE

Manage users Auto/manual Manage layouts Programming Laser configuration  Global variables

Administrator

Everyone [
Operator ()

Designer [
Developer (¥)

B

Click OK to save your settings. The next time users try to access the Laser configu-
ration function, the system will prompt them to enter a password with the appro-
priate privileges.

Some functions are dependent to each other. For example, a user who has
access rights to Programming must also have access rights to Manage lay-
outs and Auto/Manual, so the system will prevent you from disabling them.

Disabling users' access control

To disable the access control for a type of user or for all users:

Access the user management function using the Administrator password.

In the User management window click Set passwords.

Click the User arrow to display the list of users and then do one of the following:
- Select Administrator to disable access control for all users. This way, all users
will have access rights to all functions.
- Select the type of user you want to disable from the User list.

Leave the Passwords fields empty and then click OK if you want to close the
Change password window, or click Apply to keep it open.

In the message window that is displayed, click Yes.

To re-assign the access to a function for a type of user:

SOATALOGIC

Access the user management function using the Administrator password.

In the User management window, select the checkbox corresponding to the func-
tion you want re-assign.

Click OK.
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SWITCHING BETWEEN WORKING MODES

In this section:
e "Local/Remote control" on page 160

e "Auto/Manual working mode" on page 162

Local/Remote control

The Remote/Local button is only available if your installation is Interactive
with remote control allowed (For further information, see “Installation
types and connection modes" on page 19).
By default, at the startup, the local control is enabled. This way, only
authorized operators can activate the remote control so allowing remote
connections from other operators in the network.

NOTE

The Remote/to Local button of the Laser Engine left menu, allows specifying who is
supervising the Laser Engine, that is, who is controlling and can actually send com-
mands to Laser Engine.

The button is toggle: Move the pointer over it to see the current selection. In the figure
below, the Local control is activated:

E Documen'
/ : N & blar

[—( to Remote IC
™ -

Local control

The Local control is used when Laser Editor and Laser Engine are both installed on your
PC, that is, if you are locally connected and directly controlling the laser source.

In this case, Laser Engine will accept commands from you, but not from other operators
on the network.

Behaviour when resuming Local control from Remote control

If the Remote control has been activated and you need to make changes at runtime,
such as displaying limits or testing a layout, do the following:

e Click the to Local button in the left Menu of Laser Engine to resume the Local con-
trol.

¢ You will be notified if other operators are remotely connected and remote connec-
tions will be terminated.

Remote control

The Remote control can be used for two purpose:

e Establish a network connection between Laser Editor and Laser Engine installed
on different machines. Laser Editor must have a Supervisor installation and Laser
Engine must be set in Remote mode. Laser Engine will accept commands from the
first Laser Editor who connects. Only operators in the network who have a Super-
visor installation of Laser Editor can remotely connect to Laser Engine. (For further
information see "Installation types and connection modes" on page 19).

e Control the laser marker using TCP / IP protocol embedded in Lighter (Lighter
6.3.0 and later). Laser Engine will accept TCP / IP commands from the first who
connects.

Behaviour:
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Establish a network connection between Laser Editor who have a Supervisor installation
and a laser marker with Laser Engine set in Remote mode:

e Click the to Remote button in the left Menu of Laser Engine to set the Remote
control.

e The laser source connected to Laser Engine will appear on the list of available laser
sources for remote connection.

e From Laser Editor clicks the Connect to device button and then selects the laser
source from the list that is displayed. (See "Connecting to the laser device" on page
147).

Control the laser marker using TCP / IP protocol embedded in Lighter™ (Lighter™ 6.3.0
and later):
e Specify the port number of the TCP / IP Protocol used by Laser Engine in a remote
mode environment. (For further information see "Setting the Network parameters"
on page 188).
e Click the to Remote button in the left Menu of Laser Engine to set the Remote
control.

To set the Remote mode as the default working mode:

e Right-click the Laser Engine icon on the Windows applications bar.

e On the shortcut menu that appears, click Start in Remote mode to set it as the
default mode. Note that the menu command is now checked:

Minimize
Show
Always on top

User management
Global variables
Troubleshooting
System test

Laser configuration

Start in auto mode

v | Startin remote mode

Quit
e Lighter will ask you to confirm your choice. Press Yes to continue:
~% Waming [

Remote users will be allowed to take control of this application at start up.
,l A\ Proceed anyway?

e To deselect the Start in Remote mode selection, click again on it.
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Auto/Manual working mode

“Local/Remote control" on page 160).

B This button is only available if the Local control has been activated (see

NOTE

The Auto/Manual button of the Laser Engine left Menu, allows switching between
working modes. The button is toggle: Move the pointer over it to see the current selec-
tion. In the figure below, the Manual mode is activated:

For further information, please see chapter "PERFORMING THE ENGRAVING OPERATION"
on page 138, section Auto mode vs. Manual mode.

You can set the Auto mode as the default working mode, that is, as the mode that will
be used at Laser Engine startup.

To set the Auto mode as the default working mode:

e Right-click the Laser Engine icon on the Windows applications bar.

e On the shortcut menu that appears, click Start in auto mode to set it as the
default mode. Note that the menu command is now checked:

Troubleshooting
System test
Laser configuration

v Startin auto mode

Start in remote mode

Quit

e To deselect the default mode, click it.
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DISENABLING THE WINSAT TASK

WinSAT is a Windows Scheduled Task, which is executed weekly every Sunday at 1 AM
(by default, on our Embedded PCs): more information about this task can be found at
the following link https://en.wikipedia.org/wiki/Windows_System_Assessment_Tool

The execution of this Task can create issues to the Laser Marker during communication
with PLC, as it interferes with the communication stacks which are included inside
Lighter: because of this, if the Laser Marker is going to be connected to the PLC via Prof-
iNet I0/Ethernet IP/ TcpServer, the user must manually disable this scheduled task, so to

be sure that the PC on board the Laser Marker doesn't execute such task.

To disable the WinSAT scheduled Task, please follow these steps:
e Open the Administrative Tools from the Control Panel:

EF All Control Panel Items

ol

‘OO E - Control Panel = &ll Control Panel Items

> l@l I Search Control Panel

P Ackion Center

@Backup and Restore

_@'Notificat\on Area Icons

u" Personalization

[ L acation and Other Sensors

@Windows Mobility Center

Adjust your computer’s settings

Admiristrative Tools

Wiews byt Small icons ¥

[ AutoPlay

B BitLacker Driv

Administrative Tools
Configure administrative settings For your

lanagement

¥ Mouse
.15 Parental Controls

l:l;:l Fhone and Modem

'._', Windows Update

e Select the 'Task Scheduler":

Credential Manager _‘-L, Date and Timdcompuater, Programs
[t Deskiop Gadgets é Device Manager Fia Devices and Printers
!: Display @ Ease of Access Center Falder Options

|4 Fonts 1@ HomeGroup ¢ Indexing Options
Intel® HD Graphics Internet Options = Keyboard

¥ Metwork and Sharing Center
M Performance Information and Tooks

@ Power Options

@Programs and Features rl Recovery _9 Region and Language
%Remotenpp and Desktop Connections -ﬁj Sound @ Sync Center

184l System i Taskbar and Start Menu [ Troubleshooting

B2, User Accounts a Windows Card3pace W windaws Firewall

-ioix
O_’C) | Conkrol Panel = Al Cortrol Panel Ttems = Administrative Tools * 523 | Search administratee Tools )
Organize »  [m 7 Open = » [ &
7 Favorbes Marma |Dal!rmdl’lsd |Typa |1—T|as I |I
B pesaop [#l* Component Services 11/912016 2:18 AM Shorbeuk KB
M Downloads (& Computer Mansgement 11/9/2016 2:15AM  Shortok 2KB
Bl Recerk Placis {8 Connection Manager Administration Kit ILJ9/Z006 2:06 AM Shorbok 2KB
4 Librarios [ Data Sources (ODBC) 11j9/2016 2:18 A Shortas 2 KB
= Documents (B Event viewer 11/9/z016 2:18 AW Shortok KB
J1 Music E’ Inkbernet Information Services (1151 6.0 Mana...  119/2016 2:17 AM Shorbok 2KB
= Fictures |‘pmr—:, Inkernet Information Services (115) Manager 119/2016 2:17 AM Shortout 2 KB
B videos fil, 1501 nibistor LLS[Z016 2:18 8 Shorbok zk8
. Comouser |!:a Loeal Security Policy 11/9/2016 2:18 AM  Shorkau ZKB
£ 051(C) (7 Perfarmance Monitar 11)9/2016 2:15 AM Shorbout 2KB
i DATA(D2) I;__I-Prlnl‘ Management 1192016 2:15 AM Shiorbout 2KB
- STORE NGO (F2) [P Scan Management L1f8/2016 2:17 &M Shorbok ZKB
|F:?Scr\ritc5 for Network Fie System (MNFS) 11{9/2016 2:18 AM Shorbok 2KB
G Nebwork [ Services 1Lj8/2018 215 AM Shortok ZKB
(& System Corfigur ation Shoetout ZKB

|8 Wirdows Mercry Nagnostic

LLj9/2016 2:13 AM
1149/ 2:18 AM
11/9/2016 2:17 AM
L1f9/2016 2:18 amM

ZKB
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e Follow the filepath Task Scheduler (Local)\Task Scheduler Library\Microsoft\Win-
dows\Maintenance and check WinSAT. If the Status is 'Ready’', then right click on
the WinSAT task and select 'Disable’.

@ 1ask scheduler =0l x|
File  Action  View Help

R e ] ol 7 il
) Task Scheduler {Local) =

: : prSmpetiners [HestRunTins _[lastrynl |Actions
R T=kaheken hrary o Ready /4 1:00 starting 1/1/2007 pikaiakimiani A1 11/3/2016 il Maintenance: -
B [ Microsoft — Run
B[] windaws End & Create Basic Task..,
| Appip " Expott..s
" Application Expe Pcerties Import Task...
j :Iint;:th Delsts [ Display All Running Tasks
| CertificateServi 5] Enable All Tasks Histary
| Customer Exper :
& vefiog o | o | 2 e Folcer..
" Diagnosis X Delete Folder
| DiskDiagnostic General  Triggers |Attinm| Conditions | Settings | History (disabled) |
1 Location ] o, ¥
| Maintenance | Trigger [ Details Status I @ Refresh
| MemoryDiagros Weekly AL00 AM every Sunday of every week, starting 1/1/2000 Enabled
| MobilePC Help
i
1 NetTracs b Run
| NetworkAccessi—
" Offine Files A End
T & Disable
.| Power Efficienc
= pas Export...
| Registry = Properties
| RemoteApp anc
| RemoteAssistar K Delste
" Server Mansger 7 Help
| shell
_ | SideShow -~ -
Y SHmareig A B

e Once the operation has been done, double click on the 'Save-Data.bat'batch
file on the Desktop, to make sure the change has been made permanent; after
this, restart the Laser Marker.
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CONFIGURING THE LASER PARAMETERS

Minimize
Show
Always on top

User management
Global variables

Troubleshooting

System test

v Startin auto mode

| Startin remote mode
|
Quit

This chapter describes the laser configuration parameters that you can set to configure
the laser devices for optimal engraving performance.

To access the Laser configuration window:

e Right-click the Laser Engine icon on the Windows applications bar.
e Onthe shortcut menu that appears, click Laser configuration.
B If users management has been enabled and access to this function has

been limited (see"Managing users and access rights" on page 157), you will

be prompted for a password with proper rights.
NOTE promp p prop g

e The Laser configuration window is displayed, allowing you to set all the properties
for the laser devices you are connected to.

e To set parameters, use the following tables as a reference:
- "Setting the General parameters" on page 166
- "Setting the head Scanner parameters" on page 167

- "Setting the Laser parameters" on page 171

"Configuring the Field Orientation" on page 175

"Setting the Correction parameters" on page 176

"Setting the Aiming parameters" on page 177

"Setting Input/Output parameters” on page 178

"Setting the X, Y, Z, and Rotor Axes parameters" on page 180

"Configuring the Marking on the Fly function" on page 182

"Setting the Network parameters" on page 188
"MARVIS™ configuration" on page 189

"Distance Sensor configuration" on page 190

- "Service" on page 191
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Setting the General parameters

This window allows you to specify the user interface language, the linear measurement
unit and the troubleshooting parameters.

Parameter Description
It lists the available languages for the user interface. Select
the language you want to use.
Note that by default, the language is set to Autodetect,
meaning that it depends upon the language of your operating
system
. Sets the linear measurement unit. Available options are mm
Linear .
or inches
. Sets the number of decimals to be used. Admitted values are
Decimals

0to5

Max log space (KB)

Max log file number

The log funcionality is intended for the exclusive use of tech-
nical support staff. Setting values other than the default ones
could cause the system to slow down and / or its instability

Database
Max Size [MB]

It specifies the maximum disk space for troubleshooting's
database. Admitted value are 1 to 500 MB

Max Level Tracing

Set the level of events to track and save on the troubleshoot-
ing's database

ERRORS Tracks only system errors
WARNINGS Tracks system warnings and errors
Tracks system information, warnings
INFO
and errors

Trace

Enable the events you want to track and save on the trouble-
shooting’s database

It tracks the events related to the com-

LIGHTER munication between laser editor and
laser engine
It tracks the events related to the Ether-

ETHERNET_IP net_IP communication between laser
marker and client device

AXIS It tracks the events related to axes

movement

INPUTS_OUTPUTS |It tracks the events related to the I/0

It tracks the events related to the com-

READER munications with the reader

It tracks the events related to the TCP-

TCP-SERVER SERVER protocol communications
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Setting the head Scanner parameters

The Scanner page of the Laser configuration window, is used to set the scanner speed
and the waiting times for adjusting the engraving quality with respect to running times.

Properties |Property Description
Group
Speed the scanners use when moving between polygons
Jump Speed [Kpts/s] (that is, when not marking)
Passive g-switched laser sources oscillate' at start up,
resulting in first line(s) being progressively thicker. The Scan
Ramp parameter sets a time (expressed in millisecond), for
Scan Ramp [ms] . .
the scanner to accelerate from zero to maximum speed: this
allows to reduce the flaw. This parameter needs only to be
set for passive g-switched laser sources
Acceleration needs to happen only at start up to allow emis-
Scan Threshold [ms] sion stabilization. The Scan Threshold is the a_mount of time
that must elapse (after the laser has been switched off) for
the acceleration ramp to be repeated
The position the scanner moves to when standing-by, that is,
at the end of the marking operation. If the emission cannot
be completely stopped, this parameter allows moving the
Scan scanner so as to prevent damages. Possible values are:

«  Center, moves the scanner to the origin. This is the
mandatory setting if you are using the Marking on the
Fly function (for further information, see "Configuring

Standby Position the Marking on the Fly function" on page 182 func-
tion)

«  Corner, moves the scanner to the bottom left corner. If
this option is selected, the Corner Position fields are
displayed below, indicating the exact position in points.
By default, this position is the farther from the origin

»  Dynamic, moves the scanner dynamically back to the
centre after elapsing a certain amount of time

)(zorner Position [pts] Indicates the position of the corner along the X coordinate
$orner Position [pts] Indicates the position of the corner along the Y coordinate
Refers to the waiting times required for high quality engraving. K and C are two
variables, where K is the proportional coefficient for speed and C is constant. The
system calculates the waiting times for the movement of the laser according to
these parameters. Waiting times are all expressed in microseconds [ps]. (For fur-
ther information, see "Calculating waiting times" on page 168)
K first [us]
C first [us] »  First = First point of a vector. (That is, waiting time
Polygon K next [us] before proceeding with the first movement.)
Delays H proceeding with '
C next [ps] o Next = Conjunction point between two vectors
K last [ps] e Last =The last point of a vector
C last [ps]
This button enables more parameters that allow configuring
Edit advanced the laser source, so as to suit your needs. This function is
parameters button |intended for specialized technicians who will be provided
with an ad hoc password
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The following parameters are editable after activating the Edit advanced parame-
ter function

Con [ps] The time that the laser spends to mark an individual pixel
Raster

The waiting time before the laser marks the next pixel. The

Del
elays C off [ps] higher this time, more powerful the next pulse

The waiting time between lines, that is, before the laser

C line [us] marks the next line

The following parameters are editable after activating the Edit advanced parame-
ter function

The time that elapses before the system actually start emit-
ting.

Laser C draw [ps] The laser system can have a sort of inertia, that is, a

Delays response delay between the "emission” signal and the actual
emission
The time that elapses before the system extinguish the laser

Ci [us] emission.
Jump s This phenomenon is complementary to the one originating

the Cdraw delay

Calculating waiting times

The engraving process is achieved by means of a laser beam deflection device controlled
by two retroactive electrical drives (PID) which angular position is proportional to the
control voltage provided. Due to the very nature of the system, the reaction time
(phase) of the drives is not negligible. If this reaction delay wasn't taken into account,
poor results would be obtained: the solution is that the control system waits the mirror
for correct positioning before proceeding.

The waiting times required for high quality engraving are illustrated below. Waiting
times are linear functions (linear phase) of the engraving speed; this is why they are
parameterized by two variables: K, proportional coefficient for speed and C, constant.
The system computes the waiting time according to these two parameters with the fol-
lowing formula:

Speed

T=C+K.
Max speed

The speeds indicated in the formula are expressed in thousands of coordinates per sec-
ond and the maximum reference speed mentioned in the formula is equal to 1000 [Kco-
ord/s], which corresponds to the following speeds expressed in [mm/s] according to the
lens:

e f100=1133.3 mm/s
e f160=1822.2 mm/s
e {254 =2900.2 mm/s

U Waiting times are all expressed in microseconds [ps].

NOTE

The following example shows how to engrave the word "LASER". Thick lines indicates
actual marking, thin ones a jump of the mirrors (that is, a movement of the mirrors

between marked vectors):
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The following examples will better illustrate how incorrect technical waiting time setting
can affect the result.

TFirst [ps]

Waiting time for the scanner to actually reach the required position before switching
the laser on.

o If the delay is lower than the optimal value, notice how the first vec-

= /A\ tor of each polygon is distorted and longer than the correct length
L ~%| e If the delay is higher than the optimal value, the engraving process
will be slower but no effects will be visible

TNext [ps]

Waiting time for the scanner to reach the correct position before tracing the vector
after the first with the exception of the last. This waiting time is according to the engrav-
ing speed and depends on the angle between the two consecutive vectors. If the angle
is equal to 180°, the waiting time will be equal to zero, while the waiting time will
increase as the angle decreases, the time being maximum when the angle is equal to
zero degrees.

o If the delay is lower than the optimal value notice how the polygon

: t A vectors are rounded and not sharp
o If the delay is higher than the optimal value, notice how the polygon
L A vectors are more marked and deeper than they should be
TLast [ps]

Waiting time for the scanner to reach the correct position before switching the laser off
(scanning the last vector of a polygon).

o If the delay is lower than the optimal value, notice how the last poly-

) L A gon vectors are shorter and incomplete

o If the delay is higher than the optimal value, notice how the vector

L A end points are more marked

TDraw (Diode Laser) [ps]

Time the system takes to actually start emitting. Even if low, the system can have a sort
of inertia, that is, a response delay between the "emission" signal and the actual emis-
sion.

This time does not depend on speed (only constant component in the formula is
required).

o If the delay is lower than the optimal value, notice how the first vec-
L A tor of each polygon is shorter

o If the delay is higher than the optimal value, notice how the initial

= L A vector points are deeper
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Tdraw is usually smaller than Tfirst. Since they both deal with the starting
point of the first vector, the first is usually neglected.

NOTE

TJump (Diode Laser) [ps]

Time the system takes to extinguish the laser emission. This is the complementary phe-
nomenon to the one originating Tdraw,

This time does not depend on speed (only constant component in the formula is
required).

« If the delay is lower than the optimal value, notice the blurring

between the polygons
) .| * [Ifthe delay is higher than the optimal value, the engraving process
o ' will be slower but no effects will be visible
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Setting the Laser parameters

The Laser page of the Laser configuration window, contains the following parameters:

7

NOTE

The Laser source is set to the default parameter that has been set for
Laser Editor. You can still set a source type other than the default one.

Properties
Group

Property

Description

Laser

Source Type

This is the currently selected laser source

Edit advanced parameters button. This button enables more parameters that
allow configuring the laser source, so as to suit your needs. This function is
intended for specialized technicians who will be provided with an ad hoc password

Description

This parameter is displayed after activating the Edit
advanced parameter function.

It allows entering a description of the laser source

Power Change Type

This parameter is displayed after activating the Edit
advanced parameter function.

Some systems (especially lamp ones) have high ‘optical
inertia': they take time to stabilize laser emission after power
supply has changed. Diode sources behave this way only if
the level ramp starts below emission threshold. This param-
eter can have two values (do not change settings in laser.ini
file):

«  Once: Power Change time (see "Delays" on page 172
parameters) is applied only on the first engraving pen
down (diode sources)

»  Always: Power Change Time is applied to every level
variation (lamp sources)

Enable continuous
emission

If this property is set to True, you will then be able to set to 0
the Frequency parameter. The Frequency parameter is used
to adjust the laser output frequency by directly operating on
the Q-switch; it can be set at documents or objects level (see
"Laser properties for documents" on page 30).

The Q-switch is an electro-optical system which controls the
opacity of a lens making it possible to change the laser beam
frequency. Setting to 0 the Frequency parameter prevents
the emission from being discontinuous

Aiming Beam Type

OFF The aiming beam is turned OFF

The aiming beam is ON when:
» the limits of a layout or an object are
performed and the systemis in
STANDBY SHUTTER CLOSE or READY

Smart
state
« the marking process start and the sys-
tem is in STANDBY SHUTTER CLOSE
state
Automnatic The aiming beam is ON when the system is in

STANDBY SHUTTER CLOSED state
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Aiming Beam Stand
By Time

The time during which the Aiming beam remain ON is called
Aiming Beam Standby Time. If the Aiming Beam Standby
Time expire and no changes in system status occurred during
this time, the Aiming beam is automatically turned OFF by
the system. The Aiming beam is automatically turned ON
(compatibly with the system status) as soon as the system
detect a system status change. The Aiming Beam Standby
Time is configurable from 10 to 60 minutes

OFF The focusing beam is turned OFF
Focus Beam Type Automatic The focusing beam is ON when the system is in
STANDBY SHUTTER CLOSED state
Laser The time during which the Focus beam remain ON is called
Focus Beam Standby Time. If the Focus Beam Standby Time
expire and no changes in system status occurred during this
time, the Focus beam is automatically turned OFF by the
Focus Beam Stand . .
By Time system. The Focus beam is automatically turned ON (com-
y patibly with the system status) as soon as the system detect
a system status change. The Focus Beam Standby Time is
configurable from 10 to 60 minutes. The default value in
Laser.inz is 10 minutes
. . It allows enabling/disabling the communication with the
LaserLink diagnos- . . . -
tic external device so as to check its state before marking. If it is
set to False the check is not performed
Power level signal controls the electrical current fed to the laser diode: the higher
the current, the higher the power emitted. It is expressed as a percentage of the
maximum
Min. Level [%] Minimum allowed power level signal. This is the value the
Level software uses when the user sets to 0% the laser power
evess Thermal Level [%] |Level signal the laser moves to when standing-by
Maximum allowed level signal. This is the value the software
Max. Level [%]
uses when the user sets 100% laser power
. Time, expressed in milliseconds, for effecting the ramp used
Ramp Time [ms] S .
to pass from the minimum level to maximum level
Thermal standby, expressed in ms, it is the standby time
Power Change [ms] between the end of the level ramp and start of engraving.
g This standby serves for the laser to stabilize before starting
to work
Delays Expressed in seconds, this is the standby time between the

Stand by [s]

end of engraving and the level ramp which resets the mini-
mum value (of standby). This standby lets the laser remain
stable between two close engraving with consequent saving
of work time
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The following parameters are editable after activating the Edit advanced parame-
ter function

Duration of the laser shot pulse i.e. the time the Q-switch is
open (or, better, transparent). Crystal unwinding time is
always order of magnitude faster than shot time therefore
this parameter affects shot energy only indirectly as it can be
used to tune crystal re-populating time (it begins only when
Q-switch is closed)

Shot Time [us]

Parameters

This parameter sets default Q-switch frequency. Frequency
is inversely proportional to laser beam power, that is, if the
frequency is too high, the power may not be sufficient for the
engraving process. Frequency can be changed trough the
user interface and be customized for each object but raster
engraving with LEVEL technique uses this parameter as
Pixel Rate, that is, the rate at which pixel are generated (and
therefore scanner moved). In this case the 'Shot Frequency'
parameter is used to control Q-Switch modulation. Setting it
to zero (O)causes Q-Switch modulation to be synchronous
with scanners movement (that is, one pulse per pixel)

Shot/Base Fre-
quency [Hz]

The following parameters are editable after activating the Edit advanced parame-
ter function

First Pulse
Killer

FPK: When operating on a steady Q-switch frequency, the power of the pulses
emitted depends upon the frequency itself (as this is the time the crystal take to
repopulate), and the level of the optic pump (the diode). However, the very first
pulse is different because crystal population increased a lot during the stand-by
time: energy of the first pulse can be times bigger than the following pulses. The
FPK is a technique to avoid the first pulse

Time the level or pen down signal is low to suppress First

FPK Delay [ps] Pulse Killer (FPK)

FPK Level [%] Level of the first pulse killer

The following parameters are displayed after activating the Edit advanced

Frequency

parameter function

Rule

Min Frequency [Hz]

Max Frequency [Hz]

Defines minimum and maximum frequencies [Hz] allowed
(comma separated)

Speed

The following parameters are displayed after activating the Edit advanced

parameter function

Rules

Min Speed [Kpts/s]

Max Speed [Kpts/s]

Defines minimum and maximum marking speed [mm/s]
allowed (comma separated)
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The following parameters are displayed after activating the Edit advanced

parameter function

Min Power [%]

Max Power [%]

Constant Power
Correction [%]

Gain Power Correc-
tion [%/Hz]

This ruse is used to control the beam peak energy does not
overtake damage limits. Low frequencies correspond to high
single shot energy. Scanning mirrors can be damaged by sin-
gle high energy shots.

Power rule consists of a list of five parameters.

The first two parameters indicate the absolute minimum and
maximum power level allowed.

Third and fourth parameters are used to calculate maximum

Power power related to selected frequency according to this for-
Rules mula Pmax = C + K * F where Pmax is the maximum power
allowed, C (Constant Power Correction) and K (Gain Power
Correction) are the numbers in the rule and F is the current
Offset Power Cor-|frequency.
rection [%] Fifth parameter is used to set the Power Offset. In certain
types of laser (fiber laser) the relation between the power
level and the power output is such that, at a power level of
zero, the laser emits already a significant amount of output
power. Offset Power Correction parameter represents the
percentage of power level that is emitted when the laser is
set to the minimum power level
The following parameters are displayed after activating the Edit advanced
parameter function
Delay Rule |Min Delay [ms] Defines minimum and maximum dot delay [ms] allowed
(comma separated). Dot delay is used in vectorial marking
Max Delay [ms] and it is the time used to mark the "dot" entity
The following parameters are displayed after activating the Edit advanced
parameter function
Pulse Pro- |This parameter is only available for MOPA laser source. MOPA laser source allows
file to select the laser pulse duration between a selected range of values. These values
are called Pulse Profiles
Profile Selection |List of available Pulse profiles
The following parameters are displayed after activating the Edit advanced
parameter function
This parameter is only available for MOPA laser source. MOPA laser source allows
to select the laser pulse duration between a selected range of values. These values
are called Pulse Profiles
Custom name assigned to the selected pulse profile. This
Description name will be visualized in Laser Editor Property Browser
Pulse Pro- pulse profile list
file proper- . . .
ties Duration Laser Pulse duration of the selected pulse profile
Min Frequency [Hz] |[Minimum frequency allowed by the selected pulse profile
Max Frequency [Hz] |Maximum frequency allowed by the selected pulse profile
Enable / disable the selected pulse profile. If disabled, the
selected pulse profile will not be visible in Laser Editor Prop-
Enable erty Browser pulse profile list. If a document uses a pulse
profile that is currently disabled, the pulse profile will be
replaced with nearest one
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Configuring the Field Orientation

In the Field Orientation window, you can select the Scanhead orientation and the Layout
Marking orientation by selecting the desired image to simulate the work environment.
V,’ Laser Configuration M‘

General Scanhead Orientation

Scanner
Laser
T
Correction
Aiming

Input / Output
X Axis

Y Axis

Z Axis

R Axis

Marking on the Fly

Network
MARVIS Layout Marking Orientation

Distance Sensor

Service
| <R 2 o,
=+, S e ~
| e || <

[ oK ] [ Cancel ] ‘ Apply |

SDOATALOGIC USER MANUAL 175



LASER ENGINE USER

INTERFACE

Setting the Correction parameters

The Correction page of the Laser configuration window is used to set the optical correc-
tion required to recover the distortion of mirrors and lens.

Properties |Property Description
Group
Focal Length [mm] It contains a list of available optical lenses that you can
install on the scanner head of the laser device
This button allows duplicating a lens to be used as a tem-
Duplicate lens plate for creating a new one. You can then set the Lens
Lens parameters to suit your needs
Delete Lens This button allows deleting a lens created by the user
This button allows importing a lens using another configura-
Import lens tion file (laser.inz). This way, you can use a configuration of a
custom lens that was executed on a different device
Parameters in this area allow the user to set his own optical corrections (for exam-
ple, if scan head is not properly aligned with the marking filed)
L If it is set to True, allows you to specify the path of a custom
Use correction file file to be used for Field Correction
Offset X [pts] It allows aligning horizontally the field
Offset Y [pts] It allows aligning vertically the field
Scale X [%] P
Sale V4] Scale factors used to correct magnification
Theta X [deg] Theta angles used to calculate optical correction
Optical Cor- |Theta Y [deg]
rection Horizontal sides|These parameters correct an error introduced when scan
ratio [top/bottom]  |head is not properly aligned with the marking field.
: . .| This produces a deformation of the field from a square into a
Vertical sides ratio : : . .
Iright/left] trapezium. To fix the problem, use the Diagonals ratio
parameter
. . Rotates the optical field to align it to the physical field. Since
Field rotation angle|,, . T ,
this operation introduces errors near the field borders, only
[deg] o
values lower than 1° are accepted
The ratio between top and bottom sides (Horizontal sides
Diagonals ratio ratio), right and left sides (Vertical sides ratio) that a user can
use to fix a deformation adjusting the optical correction
These parameters allows configuring your own lens. They are used together with
the Duplicate - Delete and Import lens buttons. (See above)
Description A string describing the lens
Focus Depth Range along the Z axis the beam is focused
Nominal Focal
Length [mm] These parameters determine the size of the marking area
Lens Real Focal Length|and other properties of the system
parameters [mml

Field Width [mm]

Field Height [mm]

Marking field dimensions. The optical field is always a
square, but physical can have different measures in actual
application

Mechanical Field
Side [mm]
Logical Field Side

[pt]

Side of the marking field square.

This value is used to perform conversion between points and
millimeters
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Setting the Aiming parameters

The Aiming page of the Laser configuration window, is used to correct the pointer limits
in relation to engraving so as to obtain perfect overlaying, since the power laser and the
pointer laser wavelengths are different.

Resonator can contain a red light diode. This is used to highlight marking area to the
operator usually in industrial applications. Not every laser has a red diode.

The different wavelength of the visible red diode with respect to laser light causes a dif-
ferent refraction inside the objective lens. As a consequence the coordinate generated
when displaying layout limits must be corrected to match layout engraving.

This page allows some tuning on limits placement; if the result appears still wrong,
please contact the technical support team.

Properties |Property Description
Group
Scanner Scan Speed [Kpts/s] Scanners speed used when tracking limits, expressed in

Kspots/s

Correction

Alignment offset expressed in points, applied to X coordinate

Offset X [pts] when tracking limits. This value is limited to +1% of the coor-
dinates range
Alignment offset expressed in points, applied to Y coordinate
Offset Y [pts] when tracking limits. This value is limited to +1% of the coor-
dinates range
Scale applied to X coordinate when tracking limits. This value
0,
Scale X [%] is limited to £5% (95+105%)
Scale Y [%] Scale applied to Y coordinate when tracking limits. This value

is limited to £5% (95+105%)
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Setting Input/Output parameters

The Input / Output page of the Laser configuration window is used to set durations and
delays of laser Input signals in relation to engraving.

Properties |Property Description
Group
Start time [ms] ﬁ:lts the minimum duration, in ms, of the start engraving sig-
Inputs Start delay [ms or|Sets the delay, in ms, between acceptance of the start
mm] engraving signal and actual start of engraving
Stop time [ms] iglts the minimum duration, in ms, of the stop engraving sig-
Delay between the work in progress (Laser Busy) signal and
Busy advance [ms] |actual laser emission. This parameter may be useful if this
signal is used to open an electromechanical shutter
Delay between the end of actual laser emission and the end
Busy delay [ms] .
of Laser Busy signal
End time [ms] Duratiqn of the end engraving signal (Laser End) after Laser
Busy signal ends
The SW_READY output signal is ON when all
these events are true:
Standard » adocument or a sequence is running in
AUTO MODE or WORK MODE
o the systemisin READY state
Outputs The SW_READY output signal is ON when a
Compatibil- |document or a sequence is running in AUTO
ity MODE or WORK MODE independently from the
system status
SW Ready Mode The SW_READY output signal is ON when all
these events are true:
» adocument or a sequence is running in
AUTO MODE or WORK MODE
Ready To| ¢ thesystemisin READY state
Mark o the system is ready to start a new mark-
ing process
The SW_READY output signal is OFF during
the marking process and during spooler pro-
cessing and loading
OFF The green spot indicator is not active (always
OFF)
The green spot is steady ON only when all
these events are verified:
Green Spot |Green Spot Type System « the systemis in READY state
Ready To| » adocumentisin AUTO MODE or WORK
Mark MODE
The green spot indicator is steady OFF during
the marking process

178 LIGHTER™ SUITE OSIDATALOGIC



CONFIGURING THE LASER PARAMETERS

Marking
Confirma-
tion

The green spot turns ON when all these events
are verified:
o the systemis in READY state
o adocument is in AUTO MODE or WORK
MODE
» the marking process was correctly exe-
cuted (no errors, no stop marking, no
status changing)

The green spot indicator turns ON at the end of
the marking process and remain active for a
configurable period of time from 0.1 s to 5 s.
This time is called Indicator Time and it is
expressed in ms.

If a new marking process is started while the
green spot is still active, the green spot will be
automatically turned OFF

MARVIS™
Verification

The green spot turns ON when all these events
are verified:
o the systemis in READY state
e adocument is in AUTO MODE or WORK
MODE
» the marking process was correctly exe-
cuted (no errors, no stop marking, no
status changing)
o the MARVIS™ verification process was
successful

The green spot indicator turns ON at the end of
the marking process and remain active for a
configurable period of time from 0.1 s to 5 s.
This time is called Indicator Time and it is
expressed in ms.

If a new marking process is started while the
green spot is still active, the green spot will be
automatically turned OFF

Indicator Time [ms]

The period of time the green spot indicator turns on in Mark-
ing Confirmation mode and MARVIS™ Verification
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Setting the X, Y, Z, and Rotor Axes parameters

The pages Y Axis, X Axis, Z Axis, and Rotor Axes are used to set the parameters related to
the three mechanical axes whose movement are controlled by step motors.

In particular:

e Zaxis is the mechanical axis. It allows focusing on different levels.

e X, Y, and Rotor axis are the mechanical axes used to position objects under the
laser via step motor control.

Axis management and settings depend on the board controlling their movement. These
parameters are typically used by who installs and sets the step motor for axis manage-
ment. (For further information, see "Mechanical axis management" on page 193).

Properties
Group

Property

Description

Conversion

These two parameters
ment

set the conversion between motor steps and axis move-

Steps [steps]

The number of steps to move the motor to the distance
given a the Units value

Units [mm, inch, deg...]

The distance to move the axis when the motor moves the
specified number of steps. The units value depends on the
axis you are managing: if this is a rotary axis, the value is
in degrees (e.g., the number of steps to rotate of 360°); if
this is a linear axis, the value is expressed in a linear unit
of measure, which is the one you have set for the applica-
tion

Parameters

Enable axis

If set to True, enables the axis management. The relevant
tab will appear in the Laser Engine window

Free Brake Output

If set to True, disable the Brake output of the correspond-
ing axis keep it free as general output

Free Disable Input

If set to True, disable the Disable input of the correspond-
ing axis keep it free as general input

Dedicated 1/0s

It only applies to the rotor axis (R Axis). It allows manag-
ing up to 4 axis, totally independent of each other. To this
purpose, a new outputs set can be managed.

If set to True, check the I/Os documentation related to
your control board and then connect the R Axis to the ded-
icated outputs set.

If set to False, check the I/0Os documentation related to
your control board and then connect the R Axis to the out-
puts set used by the X Axis

The following parameters allow the user to set a speed that best fits the mechani-
cal characteristics of the motor in use, so as to prevent the motor from sliding. You
can use either steps or units as the unit of measure

Start speed [steps/s]

The motor speed at the beginning of the acceleration

Start speed [units/s]

ramp

Speed [steps/s]

The motor speed at the end of the acceleration ramp

Speed [units/s]

Ramp time [ms]

The time used by the acceleration ramp to go from mini-
mum speed (Start speed) to working speed (Speed)

The motor speed used by AUTO FOCUS SEARCH proce-
dure during the accurate search phase. It is important that

Autofocus Search
Speed [step/s]
Autofocus Search

Speed [unit/s]

this parameter is set to a significantly lower value than the
Z axis Speed to obtain a reliable focus search

Reset at same speed

If set to True, the same speed that you have set above will
be used for axis reset (home search).

If set to False, some properties will appear below allow-

ing you to enter a different speed for the home search
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Reset start speed
[steps/s]
Reset start speed
[units/s]

The motor speed at the beginning of the acceleration
ramp during reset operation. (These parameters are dis-
played if the Reset at same speed value is set to False)

Reset speed [steps/s]

Reset speed [units/s]

The motor speed at the end of the acceleration ramp
during reset operation. (These parameters are displayed if
the Reset at same speed value is set to False).

Reset ramp time [ms]

The time used to accelerate from minimum speed (Reset
Start Speed) to working speed (Reset Speed). Axis reset is
performed at a different speed to seek for maximum pre-
cision. (These parameters are displayed if the Reset at
same speed value is set to False)

Brake release [ms]

Electromechanical brake release time. This is the time
that elapses between the brake release signal activation
and the start of mechanical movement

After move delay [ms]

Settlement time between the end of the axis movement
and the marking start. After the motor (especially rotating
ones) reaches the position, a time must elapse to stop
vibrations; this time depends on system inertia

Home search direction

The direction of home search. It can be set to Auto,
Decreasing motor steps, or Increasing motor steps.

In particular, the Auto option allows to directly search the
home in the correct direction, based on the current posi-
tion of the axis

Reset on Startup

If it is set to True, the axis will be moved in Home position
at Laser Engine startup

Limits

The following parameters refer to the minimum and maximum limits (in steps) that

the axis can reach

Minimum [steps]

Minimum [units]

Minimum motor position limit

Maximum [steps]

Maximum [units]

Maximum motor position limit

Zero [steps]

Zero [units]

Position of the logic zero in relation to the mechanical
zero. Each movement of the axis is considered in relation
to the logic zero. Conversely, home search locates the
mechanical zero (home sensor)

Ring Offset [steps]

Ring Offset [units]

Logical zero offset of axis Z in the revolution center. This
parameter enable the possibility of using two zero logical
reference, the logical zero for layer documents and 'Ring
Offset’ added to logical zero for Ring documents

Reverse axis

The True value sets the reverse of axis logic. It can be used
when axis orientation is reverted, so that the mechanical
zero is placed where the operator expects

Commands

The following parameters can be used to test the settings during setup phase

Home search

It enables the search of the home sensor (mechanical
zero) at the speed that has been specified for the Reset
parameters

Move to [steps]

Move to [units]

These parameter allows moving the axis in the desired
position

The following parameters are read-only and depend upon the three parameters
above

If checked indicates that the home position (mechanical
Home flag

zero) has been reached

Current position [steps]

Current position [units]

It shows the last position the axis has reached (steps or
units) accordingly to the Move to parameters
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Configuring the Marking on the Fly function

B The Marking on the Fly function is only available on iMark control boards.
NOTE

When this option is enabled all objects are automatically ordered so that they will be
marked in the opposite direction of the roller. In this way we take advantage of the
movement to extend the marking field.

This feature is typically used on a production line where a conveyor roller is connected
to the laser system, and both are controlled by a PCI control board.

You might connect an encoder to the system for best performances or set the Continu-
ous marking mode to mark repeatedly the same content.

A Wizard is provided that you can access from the Marking on the Fly configuration win-
dow, which helps you to properly configure and use this function.

When using an Encoder
When high quality or high precision is required, for example, in the case of very small
laser markings, an encoder allows for best performances.

The encoder counts the roller movements and instantly determines its speed. This
allows to obtain the correct position of the moving target and to ensure high marking
precision.

When the target is detected by the sensor and the start is given, the encoder calculates
the target's position by giving a specific amount of pulse counts for a specific distance.

Time for calculation is allowed by the Start Delay property.

If you are not using an encoder (e.g., if the target moving speed is known
or no high marking precision is required), you can simulate it by enabling

NOTE the Simulation parameter, and then specifying an average speed.

When using the Continuous marking mode

The Continuous marking mode allows setting the laser so that the same marking will be
repeated at predefined distances or intervals.

Typically, it is used when you need to mark repeatedly a continuous tube at a specified
distance.

When you set this mode, the sensor detects the target and the start is given only once;
then, the marking is repeated every time the specified distance is reached.

If an encoder is being used, the distance value for repetitions must be set in mm, while
if no encoder is being used, the value is set in ms
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Setting the configuration parameters

Prerequisite:

In order for the Marking on the Fly function to work properly, it is manda-
tory that you set the following parameter:

Laser Configuration > Scan parameters > Standby Position = Center.

NOTE

By clicking Marking on the Fly in the Laser Configuration window, the following configu-
ration window opens.

& Laser Configuration

General

-
L —

Scanner

Encoder |
Laser
| Smulation

Field Orientation

Scale factor 0.00 [counts/mm]
Correction

[7] Reverse encoder
Aiming
Input / Output Diceckon; ‘
X Axis Position Perpendicular 2
¥ Asis Offset 0 fmm]
Z Axis [ Reverse polygon ordering
R Settings

Unit (mm] X
Network

Start delay 0 frm]
MARVIS

Start queue delay 0 frm]
Distance Sensor

[7] Continuous marking
Service

Distance 0 frmm]

J

Note that a Wizard is provided that guides you through the correct setup of hardware
connections and parameters that control this function. (See "Parameters description” on
page 186 for a description of all parameters).

The following describes how the Wizard is to be used.

Using the Wizard

¢ Inthe Marking on the fly configuration window, click Wizard. The first window dis-
plays that allows checking the hardware and cable connections.

Mg o iy Conguraton L )

Hardware and cables connection

Welcome o the  Mak  on  Fy  configwaton wizard
This wizard wil drive you trough the System configuration for optimal marking on moving
targets. This page will help you check that hardware and connections are working properly.
Folow the instuctions in this box fo complele the set up procedure.
) Power on the transport belt If the encoder is properly connected, the gear image should
animate. I it does not, check the cconnections.
b your system does not have an encoder select the checkbox to simulate encoder signals.
) Adtivate the external start signal and verify that the LED tums green

Press "Next" to continue.

. @

Stertsonal ] Semdate Encoder Sgral

@ @ @ @ @ @ @ ]

oo gt 1 g2 o3 ot it outs ot 7

@ @ @ @ ] @ @ e
Touts Tets Wi betil e bt et botis

ss | [Tz ] (Lo ]

¢ Follow the instructions as described in the Wizard to check that everything is con-
nected and working properly and that the photocell is correctly mounted:
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- If you have an encoder, after powering on the transport belt, ensure that the
blue gear in the window animates.

- If you do not have an encoder connected to your system, select Simulate
Encoder Signal.

- After activating the external start signal, ensure that the Start Signal led in
the window turns green.

Input 0 tol5 turn green to indicate currently active input signals, if any; otherwise, they
are grey (if not in use or inactive).

If you only need to check hardware and cables connections, you might
close the Wizard.

NOTE

Click Next. The Scan Head Position window is displayed that allows defining the
origin of the object to mark relative to the marking field in order to determine the
correct marking direction:

 Maryg on Py Congratin =

Scan Head Position

This page will help you set the correct orientation parameters of the lasertransport system.

a) Tun the laser on and acivate the aming beam if it is off
b) Press the "Run” button. The laser will draw an arrow with the red aiming beam. Place a
white paper sheet under the scan head in case you camnot see it
©) The arrow should point the same direction the belt is moving. If not press the "Rotate”
button unil it does

d) Startthe transport - the transport must be running when you press "Next"

Press "Next" to continue:

Follow the instructions and complete the test as described in the window until the
arrow points correctly.

Click Next. The Speed conversion window is displayed that allows calculating the
Scale Factor that defines the speed of the transport belt. This way you do not
need to use specific instruments to calculate this value:

 Markyng on iy Configuration &=}

Speed conversion
This
a) Power off the transport belt
b) Place two or more obiects at the same distance on the transport beit
©) Set the distance between objects inthe editbox
) Power on the transport belt
The "puises” editbox willdisplay the computed encoder puises.

Press "Next" to continue.

[T [Cene ]

Follow the instructions as described in the window.

The value that is displayed in the Speed box after completing the test is the value
that is to be used to calculate the Scale Factor that must be entered in the Mark-
ing on Fly Configuration window (counts/mm if you have an encoder, mm/sec. if
you are using the simulation). The speed corresponds to the number of pulses
that elapse between the objects to mark.

Click Next. The Start Delay window is displayed that allows calculating the dis-
tance between the start sensor, which detects the object to mark, and the center
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of the marking field. This test does not actually mark; rather, it allows checking
that the distance is correctly set:

& Markyng on Fy Confguraton =)
Start Delay
This page will help you set the comect distance between start sensor and marking field
&) Power off the transport belt.
b) Place one or more objects on the transport belt.
¢) Measure the distance between the sensor and the center of the field marking as indicated
inthe drawing and input it.
d) Press the "Run" button.
) Power on the transport belt
The laser will track a small circle on the object(s) with the red aiming beam while they are
moving. If you cannot see the cicle(s) either the distance or computed speed (previous page)
is incorrect
o
L .‘
>,
&
T T |
=l =

e Follow the instructions as described in the window.
After pressing Run, ensure that the small circle that the laser tracks is pointing the
target when this arrives in the marking field. If not, verify the Start delay distance,
and then repeat the test. If the Start delay is correctly set, you must recalculate
the computed speed (Wizard window Speed Conversion).

e Click Next. The Fine Tuning window will displays that allows fine tuning the
parameters and verifying that the speed of the transport belt (Scale Factor) has
been correctly calculated. The test will actually execute a marking while the belt is
moving.

 Markyng on iy Configuration =)

Fine tuning

“This page will nelp you fine tune parameters in order to have better marking quality. A circle
wil on aterget object to

) Power offthe transport bet
b) Flace one object on the transport belt
) Press the "Run" button
d) Enable laser marking
| &) Power on the transport belt
) Check that the circle has been marked comectly, otherwise press the figure that more
closely resembles the figure marked - this changes the speed - repeatthe previous steps.

Press "Finish" to save the confiquration

— o
Power [%}: [100 : |
G @ @ QD |
‘Scan speed [mnjsl: |2000 -

‘ P | scobtacos oo =]

[ e—

|

‘ L <o || oo || cod |

e Follow the instructions as described in the window. Note that by repeating the
test and selecting the desired circle, the speed changes until the circle is marked
correctly.

e You might also change the Power, Frequency, and Scan speed values to suit your
specific needs, based on the material on which you are marking.

e When finished click on Finish.

e Complete the parameters in the Marking on the Fly Configuration window, as
needed. See the table in the following for a description.
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Parameters description

The table here below describes the parameters that appear in the Marking on the Fly

window:

Properties
Group

Parameter

Description

Enable the Marking

on the Fly

Select the checkbox to enable the feature.

(For best practices in setting this feature so as to follow your
needs, see "When using the Continuous marking mode" on
page 182)

Encoder

Simulation

If this option is selected, Encoder is simulated by the iMark
control board, that is, the laser will chase the target at the
given speed

Scale factor

The conveyor roller (or the target moving) speed. There are
two possible scenarios:

« If an encoder is being used, this value corresponds to
the number or pulses for millimeter, as measured by
the encoder

» If you are using the simulation, you must specify a
value that corresponds to the average roller speed
based on the time (in mm/sec.)

Use the Speed conversion window of the Wizard to calcu-
late this value

Reverse encoder

It allows reverting the signal to the encoder so reverting the
marking direction

Direction

Position

The axis along which the targets are marked on the conveyor
roller, relative to the head scanner.

Use the Scan Head Position window of the Wizard to cor-
rectly determine the direction

Offset [mm]

An additional offset that can be used to fine-tune the mark-
ing operation. Negative offsets will move the layout in the
direction that the target is coming from. Use this parameter
to adjust layout position and take full advantage of target
movement to extend marking field. The following picture
shows how this parameter affects the marking operation:

Reverse
ordering

polygon

It sets the ordering of the polygons, based on both the scan
head configuration (X /Y Axis) and the direction of the object
to mark.

Use the Scan Head Position window of the Wizard to set
this parameter

186 LIGHTER™ SUITE

SDATALOGIC




CONFIGURING THE LASER PARAMETERS

Settings

Unit [mm] or [ms]

Measure unit, either in [mm] or [ms], for the Start Delay
parameter

Start delay [mm] or
[ms]

Distance in [mm] or delay in [ms] between the center of the
marking field and the Proximity sensor.

Use the Start Delay window of the Wizard to calculate this
value

Start queue delay
[mm] or [ms]

The START QUEUE DELAY parameter is used to implement a
START_MARKING queue environment.

When the START QUEUE DELAY is set to a value >0 ms, the
START_MARKING events that occur from a START_MARK-
ING event and the duration of START QUEUE DELAY, are not
lost, but deferred.

This allows to position the sensor that manages the
START_MARKING, at a distance from the scanhead, greater
than the distance that separates the pieces to be marked.
The START QUEUE DELAY parameter shall be used both in
STATIC that in Marking on the Fly mode

Continuous marking

Select this option if you want to mark the same layout
repeatedly at a specific distance.

If an encoder is being used, this value is in [mm]. If you are
using the simulation, this value is in [ms]

Distance [mm]

The distance in [mm] between markings when the Continu-
ous marking mode is enabled
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Setting the Network parameters

The network configuration window contains the following parameters:

Properties |Property Description
Group
Device Network Specify thg name of thg device used by Lighter in a remote
Network mode environment. It is useful when many laser are con-
Name .
nected to the same network and you need to recognize them
TCP Server |Port Number Specify thg pqrt number of the TCP. Server Protocol used by
Laser Engine in a remote mode environment
Ethernet/IP |Network Adapter Specify the net.work adapter on which to enable the Ether-
net_IP connection
If Use DHCP is set, the IP address is assigned automatically
DHCP Settings (check .if your network support t.his capability).
If Specify IP address manually is set, you have to ask your
network administrator for the appropriate IP settings
Local IP Address IP Address of device
oca’ared g bnet Mask Subnet Mask
connection
Default Gateway Default Gateway
Preferred DNS Preferred DNS Server
Server
Alternate DNS Alternate DNS Server
Server
Network Adapter Specify Fhe network adapter on which to enable the Profinet
Profinet connection
Input Memory Size |Admitted values are 64, 128 or 254
Output Memory Size | Admitted values are 64, 128 or 254

To change the network settings, refer to the laser marker’s user manual.

In Profinet, the Device Network Name must be changed following these

rules:

Use only Alphanumerical characters ('a'...'z" and '0"...'1"), excluding capi-

tal letters, '-' and "'

The Device name must begin with a letter (‘a'...'z’).
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MARVIS™ configuration

The MARVIS™ configuration window is used to set the following parameters.

Properties |Property Description
Group
Device Firmware This button allows upgrading the reader's firmware
Upgrade
Device Discovery This button allows discovering one or more readers con-
nected to the network
Device IP Address  |IP address of the reader connected to the laser marker
Device Model Model of the reader connected to the laser marker
Device Name Name of the reader connected to the laser marker
Connection [Device Serial Serial number of the reader connected to the laser marker
. This button allows to set the parameters of reader connected
Manage Device
to the laser marker
Timeout determines the length of time for the waiting of
Timeout (ms) response from the reader before giving an error. Admitted
values are 5000 to 30000 ms
. This button performs a connection test between the laser
Device Test
marker and the reader
Parameters in this area allow the programming of generic input/outputs to be used
in automatic applications.
Note: the Matrix reader inputs/outputs are not used in MARVIS applications
ZIQI}?;{IS GOOD/BAD General purpose output signal of GOOD/BAD validation
MARVIS End Signal |General purpose output signal of validation End
Validation MARVIS Error Signal Gen_eral purpose output signal of generic error occurred
during the validation time
Acquisition Trigger This field gllow to select the acquisition trigger mode to use
for the validation
Good String User defined strings shown in MARVIS statistics image. See
Bad String MARVIS Application Note for more information
External Illuminator |If set to True, the laser marker use the external illuminator
Parameters in this area allow to set the desired preferences for saving the images
acquired during the validation time
Image Saving This field allows to choose which images to save
Images Max Images Space Thi; parameter s_ets the maximum space reserved for saving
[MB] the images. Admitted values are 1 to 1000 MB
Current Saving Path |This field shows the saving path for images
Image Saving Path | This button allows to choose the saving path
Image format This field allows to choose in which format to save images
These parameters in this area allows the setting of the space reserved for valida-
Database |tion statistics information
Max Size [MB] ’Admitted values are 1 to 500 Mb
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Distance Sensor configuration

The Distance Sensor is used together with the Z Axis, to automatically adjust the focus
distance between the F-Theta scan lens and the object to be marked (available only for

Arex™ 400).

Properties
Group

Property

Description

Sensor Type

Disabled or M_OADM13T645S35A

Tolerance [um]

This property define the tolerance value used by AUTO
FOCUS SEARCH procedure. The AUTO FOCUS SEARCH pro-
cedure is completed with success when, at the end of the
procedure, the reading distance from the sensor is the
FOCUS DISTANCE REFERENCE value + the tolerance value

Edit advanced
parameters button

This button enables more parameters that allow configuring
the distance sensor, so as to suit your needs. This function is
intended for specialized technicians who will be provided
with an ad hoc password

Direction  Calibra-
tion Distance [um]

This property is used by the AUTO FOCUS SEARCH procedure
to automatically define the search direction way

tance Sen-

Accurate Search
Distance [um]

This property is used by AUTO FOCUS SEARCH procedure to
define the distance below which only the accurate search
procedure is performed

sor

Enable sensor check

This button start the communication with the distance sen-
sor and the real-time distance reading.

The red laser beam of the distance sensor is ON while the
aiming and focusing beam of the system are OFF

Readin Distance . . .
g Show the real-time distance in mm
[mm]
Shown when the distance sensor communi-
Sensor . . .
. cate correctly with the system and it is working
Available )
in the range
Shown when the distance communicate cor-
Sensor Status Sensor out . L .
rectly with the system but it is working out of
of range
the range
Sensor not . .
) Shown when the distance sensor is not ready
available
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In the Service page are displayed system informations (available only for Arex™400).

Properties
Group

Property

Description

Serial Number

System serial number

Shows the laser control board FW and HW revision separated

FW revision by dot
a):;tfsm Working System working hours expressed in hours and minutes
CPU Temperature Shows the CPU internal temperature of the laser control

board

BOARD#1 Tempera-
ture [°C]

Shows the temperature of the laser control board sensor
near the switching power supply unit

System Info

BOARD#2 Tempera-
ture [°C]

Shows the temperature of the laser control board sensor
near the rear panel connectors

Scanhead Tempera-
ture [°C]

Shows the temperature of the internal sensor inside the scan
head

Rack Temperature
Error [events]

This counter is incremented every time the system tempera-
ture is out of the operating temperature range

Scanhead Tempera-
ture Error [events]

This counter is incremented every time the scan head tem-
perature is out of the operating temperature range

Service Interface
Error [events]

This counter is incremented every time the service interface
failed due to MMC error

Safety Info

Safety Relay Switch-
ing [events]

Counter of the SAFETY FUNCTIONS events. The SAFETY
FUNCTIONS events counter is incremented every time the
INTERLOCK or LASER_STOP safety function are activated

Serial Number

Source serial number

Source Working
Hours

Source working hours expressed in hours and minutes

Diode Working
Hours

Diode working hours expressed in hours and minutes

Laser

Temperature Error

This counter is incremented every time the Laser source
temperature is out of the operating temperature range

Source Info

Power Supply Error

This counter is incremented every time the External supply
voltage of the laser source is out of the specified range

Back Reflection
Error

This counter is incremented every time the laser source
detect an high optical power reflected back to the laser

Generic Alarm

This counter is incremented every time the laser source
detects an internal failure

Backup and Restore Service Data

Activate the Edit advanced parameter function to enable
Set, Reset, Backup, Restore and Reset All buttons
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Managing axis and executing the laser test

The X-Y Axis, Z-Axis and Rotor Axis tabs of the Laser Engine interface are

only available if the laser is compliant and properly configured, that is, if

axis have enabled at the laser configuration level (see "Setting the X, Y, Z,
NOTE and Rotor Axes parameters" on page 180).

In particular, the Rotor Axis tab, is only available if a rings separator is
installed on your device.

Laser Engine provides you with a graphical user interface for directly manage axes
movements, which are controlled by step motors.

You can move an axis either by setting axis parameters, or by using the arrow keys on
your keyboard.

For further information:
e "Mechanical axis management" on page 193
e "Using the X-Y or Rotor Axis tabs for axis management" on page 194
e "Using the Z Axis tab for axis management and laser test" on page 195
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Mechanical axis management

Description of the settings related to axis requires a brief description of the way the
software manages axis.

Axes reference

The figure below shows axis logical (blue) and mechanical (black) references. These can
be different as logical representation is built upon what the operator expects while
mechanical representation depends on design choices or needs. In the figure, Z axis
shows this difference: orientation is reversed and logical zero is placed on a totally dif-
ferent quote than mechanical zero (where the zero sensor is placed).

Step motors drive axis movement. Axis can be either linear or rotary. Devices that drive
axis movement obviously have Minimum and Maximum, that is, quotes than cannot be
outgone; this is true for rotary axis as well: even though rotation could continue, limits
are set so that reference cannot exceed them.

Min >

Mechanical Zero

Zero .
Logic Zero

Zimin ininint iy Giss St
-
D% / ///
- z
@ 7 Working plane

,,,,,,,,,,,,,,,,,,,,,,,,,,,,,

Linear vs. rotary axis

The software drives axis in the same way, be they linear or rotary.

The main setting is the conversion between motor step and axis movement. In linear
axis this is the number of steps to move the motor of 1mm (or any other reference:
1meter, linch, etc.); in rotary axis this is the number of steps to rotate of 360° (or any
other angle measure).

Inversion indicates rotation direction in rotary axis.

Mechanical Zero

A
/\ Logic Zero
A 4
A

Zero

/
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Using the X

-Y or Rotor Axis tabs for axis management

level (see "Setting the X, Y, Z, and Rotor Axes parameters" on page 180).

Fields on the tabs are only available if the Local control and the Manual
mode are activated. (See "Switching between working modes" on page
160).

B These tabs are only available if axes are enabled at the laser configuration

NOTE

X, Y, and Rotor axis are the linear and rotary mechanical axes used to position objects

under the laser via step motor control. (See "Mechanical axis management" on page 193
for further information).

By using these tabs, you can control axes movements and objects position on the work-
ing plane.

Before executing an axis movement command after the marker has been
turned on and/or Laser Engine has been restarted and/or the axis system
has been switched off and on again, it is necessary to execute a home

NOTE search command so that the system knows the current axis position.

To manage axes:
The example below describes how to use the X-Y Axis tab to check and manage the lin-
ear mechanical axes. Using the Home Search command button, results in the axis motor
moving so as to reach the proximity sensor. The meaning of the fields on the Rotor Axis
tab is identical.
e Select the X-Y or Rotor Axis tab of Laser Engine, depending on which axis you are
moving.
2§ LaserEngine 7.02 Betal. 103 (o)

[ Documents [ DeviceStatus | XAxis | zaxs | Rotoraxs [ Statistics
/Q Home Search | 3

¥=100.00, ¥=100.00 X Axis

330.00

Home Flag
Minimum Positon 0
Maximum Position 330
L Y9N | Currentpositon 100,002
/ B

¥ Axis
Home Flag

Minimum Position 0
Maximum Position 330

r"'% CurrentPosition 10000+

0
0.00 330.00

1855 Laser READY

Reader ERROR

¢ The example above represents a working plane with two linear axes that move the
object in the X and Y directions; it shows you the position of the laser spot on the
plane.

e Click Home Search. If the Home Flag is not checked, that is, if the zero has not
been reached, the motor starts moving towards the proximity sensor, until the
sensor is reached. The motors will not move if the Home Flag is already checked.

e The parameters underneath means the following:

- Home Flag - This checkbox is selected if the zero has been reached, that is if
the 0 sensor is activated.

- Minimum position - The minimum motor position that the axis can reach.
- Maximum position - The maximum motor position that the axis can reach.

- Current position - It shows the last position the axis has reached.
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Using the Z Axis tab for axis management and laser test

124

NOTE

The Z Axis tab is only available if the axis is enabled at the laser
configuration level (see "Setting the X, Y, Z, and Rotor Axes parameters"
on page 180).
Fields on the tab are only available if the Local control and the
Manual mode are activated. (See "Switching between working modes"
on page 160).

The Z Axis is used to focus the laser on different levels. (See "Axes reference" on page 193
for further information).

By using the Z Axis tab you can also perform the laser test for focus. (See "Executing the
laser test for focus" on page 196).

7

NOTE

Before executing an axis movement command after the marker
has been turned on and/or Laser Engine has been restarted and/or
the axis system has been switched off and on again, it is necessary
to execute a home search command so that the system knows the
current axis position.

Managing the Z Axis

The example below describes how to use the Z Axis tab to check and manage the axis.
Using the Home Search command button, results in the axis motor moving so as to
reach the proximity sensor.

e Select the Z Axis tab of Laser Engine.

SOATALOGIC

y
/% LaserEngine ==
[ Documents | Device statusinfo | ZAxis | statistics |
‘Qj 330.00 Home Search >
/ 330.00~
e Axis
Home Flag
Minimum Position 0
Maximum Position 330
Current Position 330.00
/7 >
Size [mm] 10.00 B
— Power [%] 70
.....
: d Frequency [kHz] 30.000
i > ]
Focal Distance Sensor
Focus Flag
Set Focus Distance
Reference h
Autofocus 3
0.00
Press an "Arrow Key " for continuous movement or
"CTRL+Arrow Key" for pulse movement
I:] el L4

e Please, refer to the previous section To manage axes: for further information on
the Home Search button and parameters underneath.
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Executing the laser test for focus

This function allows searching the focal plane.

For optimal performance, when engraving the laser head must be at the correct focus
distance from the item to be engraved.

The laser test allows engraving a geometric shape with predefined parameters and posi-
tion the axis at the same time.

To execute the test:
e Select the Z Axis tab of Laser Engine.

e Under Laser Test, set the following parameters:
- From the Type dropdown list, select the required geometrical shape for the
test (Square, Line, Circle, or Dot).
- Specify the Size for the shape and the laser output Power (expressed in per-
centage), according to your device's maximum power.

- Specify the laser output Frequency. This parameter is used to adjust the laser
output frequency by directly operating on the Q-switch.

- Specify if the Continuous Emission should be used. This parameter is used

only by DPSS laser source.

- Specify the Pulse Profile. This parameter is used only by MOPA laser source.
e Click: » tolaunch the test. A greater interaction of the laser with the material

under examination indicates that the optimal focus has been obtained.

The correct position can be identified as the engraving point in
which the laser generated noise and luminosity are at the maxi-

mum.
NOTE

Executing the Autofocus Search (if available)

The distance sensor is used togheter with the Z Axis, to automatically adjust the focus
distance between the scan head and the object to be marked, without using manual
tools

Set the focus position:
e Select the Z Axis tab of Laser Engine.

e Press the Home Search button
¢ Move the Z Axis in the Focus position
e Press Set Focus Distance Reference

To execute the Autofocus search
e Press Autofocus button
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Correcting lens distortion

In laser marking, lens and mirrors that are used to deflect the laser light, produce distor-
tions whose correction is critical to an accurate marking operation.

The Lens Correction function provides a way to easily correct this phenomenon.

Related topics:
e "Setting the Correction parameters” on page 176
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Sending documents to marking
This button is only available if the Local control is activated. (See
"Switching between working modes" on page 160).

To select a document, or to perform testing operations, as well as
to make any other change, you must activate the Manual Mode
(see "Auto/Manual working mode" on page 162).

NOTE

w v

|
By using the Laser Engine interface, you can send to marking any document that has
been saved to the device. (See "Saving a layout to a device" on page 45).

To send a document to marking
e Be sure that you are in Manual working mode. (To check the current working
mode, move the pointer over the [§ button.)
¢ Inthe Name area of the Documents tab, select the.xIp document you want to
mark.
* Click /¥ to send the document to marking. To stop the marking click /g .

Note that, as the laser marks, in the lower part of the Preview pane, the progress bar
moves and the marking time decreases.

The Laser Editor's Mark preview function (see "Marking preview" on page
137), that allows previewing how lines will be marked by the laser and
verifying the marking time, has been implemented as a scripting object.

NOTE Programmers can add the object to their user interface to allow operators
to check the layout being engraved.

(For further information, see the Project Editor's online documentation,
"Language reference" section).
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Viewing the Device Status

The Device Status tab of the Laser Engine interface is a read-only window that shows
the device status information. It is available only if you are using ULYXE™, VLase™,
Arex™ 20MW or AREX™ 400 devices.

The coloured icon at the right-bottom of the window shows the device status (see table
": Icons representing the device status" on page 199).

In addition to provide status information, this feature helps you to diagnose or correct

errors that might arise.

[ Doauments | Device Status

o | 2 | oo | Sttt |

System Informaton

Diode Serial No.

Working Time - hhhhh:mm:ss

Diode

Power Board Firmware version

Command Box Frmware version

Heat Srk Temperature

1785 Laser READY ®

The status icon on the right-bottom of the window changes accordingly to the device
status. The meaning of each icon is described in the following table.

Table 1: Icons representing the device status

Icon Device Status

¢) |oFF

The laser is OFF or disconnected

WARNING

This status means that the VLASE is connected, no error is
detected, but it cannot be used. Possible reasons are:

«  key sequence is incorrect

o emergency has been activated

o the laser is warming-up

Tip: For a detailed description, as well as for troubleshooting warnings, please refer
to the manual provided by your laser source's manufacturer

WAIT

The laser is waiting for input

STAND-BY or READY

The laser is in stand-by or it is ready, and the shutter is closed

READY The laser is ready to be used
f'\ BUSY The laser is currently marking
The laser device is in an error status.
ERROR When the error status is detected, neither documents nor

projects can be sent to marking

Tip: For a detailed description, as well as for troubleshooting error conditions, please
refer to the manual provided by your laser source's manufacturer
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Statistics
Shows the statistics about the marking processes and marking & validation processes.
PPN izserngine =)
[ Documents | Device Status | X¥Axis | ZAxs | RotorAxis | Statistcs |
\\@ Layouts Image
/ Marked Layouts: 68 since 08/01/2018 16:13:18
———— OK ERROR STOPPED
ﬁ Marking 63 0 5
v oK I 52

ERROR | 0%

/l v s

Validation

m H Good Bad

Match 47 1

Grade Treshold 42 6

Good Match | ©7

Bad Match ] | 2%
Good Grade | (|7 (7] sl bt acqured mage
Bad Grade = | | 12%
Hstory
968 s Laser READY
Reader Available ]

Statistics on marking processes are available in the Layouts section. The following statis-
tics are displayed:

e OK: marking processes correctly performed
e ERROR: errors in marking processes
e STOPPED: marking processes stopped by an external command
Statistics on validation are available in the Validation section (feature available with

Marvis enabled; see the Marvis Application Note for more details). The following statis-
tics are displayed:

e MATCH: to match what is marked
e GRADE TRESHOLD: for good/bad match and good/bad grade
Image section (feature available with Marvis enabled; see the Marvis Application Note

for more details). When the Display last acquired image property is checked the last
acquired image from the reader is shown.
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History: press this button to access the results history detail.
PN M - T -

Time Period
Start 02/12/201700:00:00 v End 03/01/2018 23:59:59 ~
Date Layout Name Match Status Grade Status Marking Status
02/01/201813:37:50 Ci/ProgramData/Datalogic... OK oK oK ol
02/01/2018 1337:44 Cy/ProgramData/Datalogic... OK oK oK
02/01/20181337:21 C:/ProgramData/Datalogic... OK FAILED oK
02/01/2018 1337:01 Cy/ProgramData/Datalogic... OK oK oK
02/01/2018 13:36:54 C:/ProgramData/Datalogic... OK oK oK
02/01/2018 1336:48 C:/ProgramData/Datalogic... OK oK oK
02/01/2018 1336:41 Cy/ProgramData/Datalogic... OK oK oK
02/01/2018 13:36:35 C:/ProgramData/Datalogic... OK oK oK
02/01/2018 13:36:28 Cy/ProgramData/Datalogic... OK oK oK
: [ upme
Statistics
Total Marking 100 % 0% 0% 7% 3% 100 % 0%
T | |
o P Total Match otal quality
| Good 115926 78105
ERROR 62
Bad E 37849 .
sTop 0
oK ERROR STOPPED  GoodGrade BadGrade GoodMatch Bad Match
Images Space [%]
. T — e
Co— R —
— = [ —

In the history window it is necessary to select the desired time period:
e Start: set the starting time
e End: set the end time
e (Clear: this button deletes all the information of the selected period (including
database and images).

When the images space and DB used space are full, the oldest data are automatically
overwritten. To delete the data manually, use the clear button.

Images Space [%]
L e __________________________________________ | 60%
p— =

Show Match Details: this button shows the match detail (to enable this button select
the marking in the time period filed)

[ # oetais - ] - ==
Code properties Image
Code [Datamatrix - Text: Uo |
‘ Configured Received Good/Bad
‘ Text Code UOPH28031010... UOPH280310... OK
| CellContrast threshold A A,5926 oK
‘ Cell Modulation threshold B B,040 oK
| Fied Patter Damage threshold c,200 oK
‘ Axial Nonuniformity threshold A A,001 oK
‘ Grid Nonuniformity threshold A A,005 oK
| Unused error correction threshold A A, 100 oK
| Print Growth threshold A A,000 oK

Minimum Reflectance threshold A A,000 oK

m »

Update: press this button to update the time period field (for it works, the end of the
time period must be set forward of the current time

Export Data: press this button to export the data to a . cvs file. It is also set an auto-
matic export from the drop down menu.
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Troubleshooting

The Troubleshooting allows the user to view the system errors and the events flow in
order to analyze problems and make a diagnosis.

The Troubleshooting GUI can be opened by right-clicking the Laser Engine tray icon and

then selecting "Troubleshooting".

Minimize
Show
Always on top

User management

Global variables

Troubleshooting I

System test
Laser configuration

Start in auto mode

Start in remote mode

Quit

Errors and Event Tracing GUI

Errors Tab

Shows the list of errors that have occurred in a given period of time in order to allow the
user to make an analysis (see "Max Level Tracing" on page 166 to set the events to be
tracked and saved on the Troubleshooting's Database).

.’ Troubleshooting M
Errors Event Tracing
Start Date 30/01/202000:00 v End Date 31/01/202023:59 v Level
Date Time Level Code Description
30/01/2020 09:0... ERRORS 257 Board initialization failed:Please check log tab for details
@ Current Session (7 History Page 1of 1 Prev Page Next Page [ Update ] [ Clear ] [ Export ]
[7] Live Update
DB used space I | 2.96% Show Log
A
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Event Tracing Tab

Shows the list of events that have occurred in a given period of time in order to allow
the user to analyze the data flow and highlight the problems (see "Max Level Tracing" on
page 166 and "Trace" on page 166 to set the events to be tracked and saved on the Trou-
bleshooting's Database).

fi .’ Troubleshooting M1
Event Tracing
Start Date 30/01/202000:00 v End Date 31/01/2020 23:59 v Level [ALL =] e [o -]
Date Time Level Type EndPoint Description Details

30/01/2020 09:0... INFO READER Current job hash:  Set XML Hash Job [:]
30/01/2020 09:0... INFO READER Reader disconnected

30/01/2020 09:0... ERRORS READER Reader connect... Reader Error

30/01/2020 09:0... INFO READER Reader disconnected

@ Current Session () History Page 1of1 Prev Page

update | [ Clear || Ewport |

Next Page

DB used space I

[ Live Update

| 2.96% Show Log

Group box

Description

Start Date

Defines the date and time from which to display errors and events

End Date

Defines the end date and time from which to display errors and events

Level

Defines the type of events to be displayed:
e ERRORS: show only system errors
«  WARNINGS: show only system warnings
e INFO: show only system informations

Type

Defines the type of events to be displayed related to a specific functionality

Current session

Display only the events generated in the current LaserEngine session and
which occurred between the start / end date

History

Display the events stored in the Troubleshooting's Database and that have
occurred between the start / end date

Update

Updates the list of events that occurred during run-time operations

Clear

Clears the list of events that occurred between the start / end date

Export

Live Update

Updates the list of events in real time

DB used space

Shows the percentage of space occupied in the Troubleshooting's Database
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Testing the system

Minimize
Show
Always on top

User management

Global variables

Troubleshooting
System test

Laser configuration

Start in auto mode

Start in remote mode
Quit

R
The System test shortcut menu command of the Laser Engine interface allows accessing
the dialog where you can check your system's connections.

In particular, besides testing the Laser, you can test all Inputs and Outputs, as well as the
external Start and Stop signals.

To test the system's connections:

e |nyour Windows application bar, right-click the Laser Engine icon to display the
shortcut menu.

e Click System test to display the dialog:

Las Test =

Type

Size [mm]

Power [%a] 70

Frequency [zl 30.00 =

Input Test

®n @1 (:Dz @3 ®4 @5 @s q:;? @ Startmarking
8 ®g ®10 ®1l ®12 C:Dﬂ 14 15 @ Stop marking

Output Test
Do [ B D2 s D4 s s B>
[k e P w @11 P12 @ 3 P 1a P 15

To test the Laser:
e Under Laser Test set the following parameters:

- From the Type dropdown list, select the required geometrical shape for the
test (Square, Line, Circle, or Dot).

- Specify the Size for the shape and the laser output Power (expressed in per-
centage), according to your device's maximum power.

- Specify the laser output Frequency. This parameter is used to adjust the laser
output frequency by directly operating on the Q-switch.
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- Specify if the Continuous Emission should be used. This parameter is used

only by DPSS laser source.

- Specify the Pulse Profile. This parameter is used only by MOPA laser source.
e Click the button launch the test.

To test the inputs:
The inputs are activated/deactivated via the external Start and Stop commands. If the
inputs do not become green (activated) something is wrong in your connections:

e When the external Start is pressed, the Start led becomes green. Check that the
Input leds become green.

e When the external Stop is pressed, the Stop led becomes green.

To test the outputs:

To test the outputs connections you must manually activate them, either one by one or
all at once:

Las Tet -
Type

Size [mm]
Power [36]

Frequency [kHz]
Cont. Emiss. |:|

L» ]

Input Test

(= @: (Dz @: @ 5 @ @’ i@ Startmarking
@: @° Pr U @ @1 @1 @ @ Stop marking

Output Test

®: ©®: (84 (@s] [@s] (@] [@sweey
®: (@2 (@] Ou] @2 O (8] (@)

e To check the outputs one by one, click the relevant button.

e To check all outputs at once, click Change all outputs.
If the Output button changes to green, it indicates that it is activated and that all
connections are set correctly. If the output button is still grey, something is wrong
in your connections.

e When the Ready button is green and activated, it indicates that the device is ready
for the marking operation.
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Photometric Adjustment

®)
§
xc
i1

[resE—

cEE

Resder Comected
7] el ress onmage

ot

This chapter describes how to configure the photometric parameters of the reader.

Click the Auto Setup button to automatically configure the photometric parameters

If the Auto setup is completed correctly the decoding is successful:

based on the luminosity and contrast observed in the captured

B Auto Setup estimates the exposure time and gain parameters

image but it doesn’t always correspond to the optimum results for

NOTE  Quality Grading. We recommend therefore to consider the Auto
Setup results as a starting point to obtain the optimum working
conditions. If you don't obtain the expected grading results from
your reference samples, you should adjust the photometry param-
eters manually and observe the statistical behavior of the grading
until the desired results are obtained.

The Manual Setting configuration window is used to set the following parameters:

Properties |Property
Group

Description

Exposure Time

Settings

It defines the time during which all pixels of the CMOS image
sensor synchronously capture the frame. This parameter
must be set according to the environmental conditions
(external lighting, code contrast etc.). In general, a longer
time corresponds to a lighter image but is susceptible to
blurring due to the code movement. A shorter exposure time
corresponds to a darker image.

NOTE: The range of values and step of this parameter
change according to the Internal Lighting Mode parameter
setting, therefore, after changes to Internal Lighting Mode,
recheck Exposure Time

Gain

Amplifies or reduces the pixel gray level effectively increas-
ing or decreasing the contrast of the image

Gain Multiplier

Multiplies the defined Gain from x2 to x10 times. If set to x1,
the defined Gain is left unchanged
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Internal Lighting

Sets the operating mode of the internal lighting system. Pos-
sible values are:

Disabled: the built-in LED array is turned off all the time. This
option can be useful if using an external lighting system;
Always On: the built-in LED array is turned on all the time at
the lowest power level. This option is useful if the LED-array
blinking (produced by -Power Strobed lighting modes and
rapidly occurring reading phases) disturbs the operator.

- Power Strobed: the built-in LED array is on only during the
image exposure time. Different Power Strobed lighting levels
can be set.

NOTE: To avoid LED array overheating, for Power Strobed
settings, the program automatically limits the range of
allowed values for the Exposure Time parameter. It is
strongly recommended to use high lighting values for short
exposure times

This parameter enables one of the two possible internal
lighting system LED groups: internal or external. The internal
LED Group provides Bright Field illumination for dark

LED Group absorbing backgrounds. The external LED Group provides
low angle Dark Field illumination for DPM applications or
highly reflective backgrounds
This parameter allows selecting which quadrants of the

Sectors

selected LED group will be enabled

Reading Distance

For Liquid Lens models, this parameter sets the reading dis-
tance (measured in mm) defined as the distance from the
reading window to the code surface

Results

Result Table

In the Result Table Tab the values of the reading are displayed

Console

In the Console Tab the readings of the parameters defined by
the user are displayed. The parameters to be displayed can
be selected by pressing the button Console Configuration.

Click Try to decode to perform a decoding test.

Click Still or Live to enable the desired viewing mode.
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Quality Grade Training

Accordingly with ISO /IEC TR 29158 that includes the AIM DPM-1-2006, seven quality
parameters or Metrics have been defined. The knowledge of the meaning of each qual-
ity parameter may be helpful in laser marking process tuning. Each quality parameter is
classified into grades from A to F, and OVERALL is defined as the lowest result among all
the parameters or metrics.

Type the acquisition number to be executed and start the learning by pressing Start
Training button. At the end of the learning the percentages/numbers and degree of
reading quality will be displayed in the Grade Profile column.

It is possible to suspend the training iteration process by pressing the Pause/Continue
button. This allows, for example, to change one or more samples during the training
process.

Click Stop Training button to stop the verification process before the end.
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Click Still or Live to enable the desired viewing mode.
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